aboutsummaryrefslogtreecommitdiff
path: root/comms/gqrx/Makefile
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2014-04-03 06:35:51 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2014-04-03 06:35:51 +0000
commit2ff70de73ab145cc7e18f40440ddeb2a3b6b8156 (patch)
treec5039e8507f72359e6d9a444277f2850fb4742bd /comms/gqrx/Makefile
parentdd93a36b9d8dfd8e01787b0d66ba10c6dd5c3efa (diff)
downloadports-2ff70de73ab145cc7e18f40440ddeb2a3b6b8156.tar.gz
ports-2ff70de73ab145cc7e18f40440ddeb2a3b6b8156.zip
Notes
Diffstat (limited to 'comms/gqrx/Makefile')
-rw-r--r--comms/gqrx/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/comms/gqrx/Makefile b/comms/gqrx/Makefile
index bf97d35b82e4..967c73bf015e 100644
--- a/comms/gqrx/Makefile
+++ b/comms/gqrx/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gqrx
-PORTVERSION= 20130504
-PORTREVISION= 4
+PORTVERSION= 20140313
CATEGORIES= comms hamradio
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -14,7 +13,11 @@ COMMENT= Qt-based software defined radio receiver
LICENSE= GPLv3
-LIB_DEPENDS= libgnuradio-core.so:${PORTSDIR}/comms/gnuradio \
+LIB_DEPENDS= libgnuradio-runtime.so:${PORTSDIR}/comms/gnuradio \
+ libgnuradio-analog.so:${PORTSDIR}/comms/gnuradio \
+ libgnuradio-blocks.so:${PORTSDIR}/comms/gnuradio \
+ libgnuradio-filter.so:${PORTSDIR}/comms/gnuradio \
+ libgnuradio-fft.so:${PORTSDIR}/comms/gnuradio \
libgnuradio-audio.so:${PORTSDIR}/comms/gnuradio \
libgnuradio-osmosdr.so:${PORTSDIR}/comms/gr-osmosdr \
libpulse.so:${PORTSDIR}/audio/pulseaudio \
@@ -23,7 +26,9 @@ LIB_DEPENDS= libgnuradio-core.so:${PORTSDIR}/comms/gnuradio \
libboost_program_options.so:${PORTSDIR}/devel/boost-libs
USES= pkgconfig qmake
-USE_QT4= moc_build rcc_build uic_build corelib gui svg
+USE_QT5= buildtools core gui svg network widgets
+
+QMAKE_ARGS+= VER="${PORTVERSION}"
PLIST_FILES= bin/gqrx