aboutsummaryrefslogtreecommitdiff
path: root/comms/gr-osmosdr/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-12-20 15:00:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-12-20 15:00:47 +0000
commit931952ad7fc7986c6f9ee8d2bd4ebcac2bf18d8a (patch)
treebccfd2bfe82bc8a192b1174ab3895ff3a8b5b1d8 /comms/gr-osmosdr/Makefile
parent5a27145800fc679687e4b84c3fec34f84d09bc36 (diff)
Notes
Diffstat (limited to 'comms/gr-osmosdr/Makefile')
-rw-r--r--comms/gr-osmosdr/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/comms/gr-osmosdr/Makefile b/comms/gr-osmosdr/Makefile
index edec723e77fe..85bc3e35cb48 100644
--- a/comms/gr-osmosdr/Makefile
+++ b/comms/gr-osmosdr/Makefile
@@ -12,7 +12,7 @@ COMMENT= GNU Radio OsmoSDR module
LICENSE= GPLv3
-BUILD_DEPENDS= swig:devel/swig13 \
+BUILD_DEPENDS= swig3.0:devel/swig30 \
cheetah:devel/py-cheetah
LIB_DEPENDS= libgnuradio-runtime.so:comms/gnuradio \
libgnuradio-pmt.so:comms/gnuradio \
@@ -22,6 +22,7 @@ LIB_DEPENDS= libgnuradio-runtime.so:comms/gnuradio \
USES= cmake fortran pkgconfig python:2.7 tar:tgz
USE_LDCONFIG= yes
+BINARY_ALIAS= swig=swig3.0
# See lib/CMakeLists.txt to enable more components
CMAKE_ARGS+= -DENABLE_DEFAULT:BOOL=OFF \