aboutsummaryrefslogtreecommitdiff
path: root/comms/gsmlib/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-11 11:07:01 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-11 11:07:01 +0000
commit909c20e5028f0226cd842be38c7f6152ee4ead7c (patch)
treeb193f93a3fe576f20111a71261e57b665c559acd /comms/gsmlib/Makefile
parent906d8c992c7e5b5b50882538d64e0175065c5f4b (diff)
Notes
Diffstat (limited to 'comms/gsmlib/Makefile')
-rw-r--r--comms/gsmlib/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index 16b821c983ad..f086806a46f7 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A library to access GSM mobile phones through GSM modems
USE_GETOPT_LONG= yes
-USE_GETTEXT= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_INC_LIBTOOL_VER= 13
@@ -32,6 +31,14 @@ CPPFLAGS= -I${LOCALBASE}/include -DBROKEN_STRFTIME -DHAVE_DECL_GETOPT \
${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${GREP} -lR "<malloc.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g'