aboutsummaryrefslogtreecommitdiff
path: root/comms/gsmlib/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-18 18:15:53 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-18 18:15:53 +0000
commitc55cb70deba4841ebf976c582d81a4b22a77a0f1 (patch)
treeca05a426f1dccaf67bb7aadf483447addc88bf0d /comms/gsmlib/Makefile
parent1100885686d84ccf95b4fe6c7614fec19de637f3 (diff)
downloadports-c55cb70deba4841ebf976c582d81a4b22a77a0f1.tar.gz
ports-c55cb70deba4841ebf976c582d81a4b22a77a0f1.zip
Notes
Diffstat (limited to 'comms/gsmlib/Makefile')
-rw-r--r--comms/gsmlib/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index 9c7c60b99f3c..e1a3a055960e 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -15,11 +15,11 @@ MASTER_SITES= http://www.pxh.de/fs/gsmlib/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= A library to access GSM mobile phones through GSM modems
+USE_GNOME= gnometarget lthack
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_INC_LIBTOOL_VER= 13
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
@@ -31,22 +31,16 @@ CPPFLAGS= -I${LOCALBASE}/include -DBROKEN_STRFTIME -DHAVE_DECL_GETOPT \
${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if !defined(WITHOUT_NLS)
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
.endif
post-patch:
@${GREP} -lR "<malloc.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>