aboutsummaryrefslogtreecommitdiff
path: root/comms/gsmlib/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-23 20:14:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-23 20:14:31 +0000
commitcb0539a8444b9e3ae4094ea9846e34c0e25e4ad2 (patch)
treed63c95490ddeef4e97ba219f97115e9c5434ce6a /comms/gsmlib/Makefile
parentcfb361a870e4f3d91007d79f6d3cfcea48259cec (diff)
downloadports-cb0539a8444b9e3ae4094ea9846e34c0e25e4ad2.tar.gz
ports-cb0539a8444b9e3ae4094ea9846e34c0e25e4ad2.zip
Notes
Diffstat (limited to 'comms/gsmlib/Makefile')
-rw-r--r--comms/gsmlib/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
new file mode 100644
index 000000000000..f0d81f28cf4f
--- /dev/null
+++ b/comms/gsmlib/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: gsmlib
+# Date created: Apr 24, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsmlib
+PORTVERSION= 1.8
+CATEGORIES= comms
+MASTER_SITES= http://www.pxh.de/fs/gsmlib/download/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= gsmctl.1 gsmpb.1 gsmsendsms.1 gsmsmsstore.1
+MAN7= gsminfo.7
+MAN8= gsmsmsd.8
+
+.include <bsd.port.mk>