aboutsummaryrefslogtreecommitdiff
path: root/comms/gsmlib
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-09-24 09:04:22 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-09-24 09:04:22 +0000
commit86e145d64604261018a763ba833dd3c6e215071f (patch)
tree06a728ebdfb09309d60e720abf14bff508cf4171 /comms/gsmlib
parentd18369b83b184c7693b10220f13bfabab09c336d (diff)
downloadports-86e145d64604261018a763ba833dd3c6e215071f.tar.gz
ports-86e145d64604261018a763ba833dd3c6e215071f.zip
Notes
Diffstat (limited to 'comms/gsmlib')
-rw-r--r--comms/gsmlib/Makefile2
-rw-r--r--comms/gsmlib/files/patch-gsmlib::gsm_map_key.h20
2 files changed, 18 insertions, 4 deletions
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index 309cd296191c..91c111bb82a2 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A library to access GSM mobile phones through GSM modems
USE_GNOME= gnometarget lthack
-USE_GETOPT_LONG= yes
+USE_GETOPT_LONG=yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/comms/gsmlib/files/patch-gsmlib::gsm_map_key.h b/comms/gsmlib/files/patch-gsmlib::gsm_map_key.h
index 18ecc5748151..fe265b2691b2 100644
--- a/comms/gsmlib/files/patch-gsmlib::gsm_map_key.h
+++ b/comms/gsmlib/files/patch-gsmlib::gsm_map_key.h
@@ -1,5 +1,5 @@
---- gsmlib/gsm_map_key.h.orig Wed May 15 04:38:12 2002
-+++ gsmlib/gsm_map_key.h Wed Aug 18 22:19:20 2004
+--- gsmlib/gsm_map_key.h.orig Tue May 14 23:38:12 2002
++++ gsmlib/gsm_map_key.h Sun Sep 24 00:37:00 2006
@@ -25,6 +25,16 @@
// wrapper for map key, can access Sortedtore to get sortOrder()
@@ -17,7 +17,7 @@
template <class SortedStore> class MapKey
{
SortedStore &_myStore; // my store
-@@ -61,14 +71,6 @@
+@@ -61,18 +71,10 @@
const MapKey<SortedStore> &y);
};
@@ -32,3 +32,17 @@
// MapKey members
template <class SortedStore>
+- bool gsmlib::operator<(const MapKey<SortedStore> &x,
++ bool operator<(const MapKey<SortedStore> &x,
+ const MapKey<SortedStore> &y)
+ {
+ assert(&x._myStore == &y._myStore);
+@@ -97,7 +99,7 @@
+ }
+
+ template <class SortedStore>
+- bool gsmlib::operator==(const MapKey<SortedStore> &x,
++ bool operator==(const MapKey<SortedStore> &x,
+ const MapKey<SortedStore> &y)
+ {
+ assert(&x._myStore == &y._myStore);