aboutsummaryrefslogtreecommitdiff
path: root/comms/hamlib/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-05-01 03:31:17 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-05-01 03:31:17 +0000
commitf97b4df6a992d3f29b089f52b26bdbf13cce74e6 (patch)
tree1df222a0286df9f11ef205b2502ab4a734a5c0c9 /comms/hamlib/Makefile
parent000390ed4ab0465bda01f64021e88de1f2a48cd3 (diff)
Notes
Diffstat (limited to 'comms/hamlib/Makefile')
-rw-r--r--comms/hamlib/Makefile83
1 files changed, 43 insertions, 40 deletions
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 4bd43f9560ee..3da0f1d386a3 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -6,93 +6,96 @@
#
PORTNAME= hamlib
-PORTVERSION= 1.2.2
+PORTVERSION= 1.2.5
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= db@db.net
COMMENT= Shared libraries for Amateur Radio Equipment Control Applications
-USE_PERL5= yes
-GNU_CONFIGURE= yes
+BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+
USE_GNOME= pkgconfig gnomehack
+USE_GETOPT_LONG= yes
+USE_PERL5= yes
+USE_PYTHON= yes
+USE_AUTOTOOLS= autoconf:259 libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-perl-binding --with-python=${PYTHON_CMD}
+PLIST_SUB= VER=${PORTVERSION}
MAN1= rigctl.1 rigmem.1 rigswr.1 rotctl.1
MAN8= rpc.rigd.8 rpc.rotd.8
-.if defined(WITH_PYTHON)
-USE_PYTHON= yes
-.endif
+OPTIONS = PYTHON "Define if you want PYTHON bindings" OFF \
+ TCL "Define if you want TCL bindings" OFF \
+ XML "Define if you want XML" OFF \
+ RIGMATRIX "Define if you want rigmatrix support" OFF
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= required Perl 5.6 or newer. Install lang/perl5.8 or lang/perl5 and try again
+.endif
+
.if defined(WITH_XML)
-USE_GNOME+= libxml2
-PLIST_SUB+= XML=""
+USE_GNOME+= libxml2
+PLIST_SUB+= XML=""
.else
CONFIGURE_ARGS+= --disable-xmltest
-PLIST_SUB+= XML="@comment "
+PLIST_SUB+= XML="@comment "
.endif
.if defined(WITH_TCL)
-LIB_DEPENDS+= tcl84.1:${PORTSDIR}/lang/tcl84
+LIB_DEPENDS+= tcl84.1:${PORTSDIR}/lang/tcl84
CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}/lib/tcl8.4 --with-tcl-binding
-PLIST_SUB+= TCL=""
+PLIST_SUB+= TCL=""
.else
CONFIGURE_ARGS+= --without-tcl-binding
-PLIST_SUB+= TCL="@comment "
+PLIST_SUB+= TCL="@comment "
.endif
.if defined(WITH_PYTHON)
-BUILD_DEPENDS+= swig1.3:${PORTSDIR}/devel/swig13
CONFIGURE_ARGS+= --with-python-binding
-PLIST_SUB+= PYTHON=""
+PLIST_SUB+= PYTHON=""
.else
CONFIGURE_ARGS+= --without-python-binding
-PLIST_SUB+= PYTHON="@comment "
+PLIST_SUB+= PYTHON="@comment "
.endif
.if defined(WITH_RIGMATRIX)
-LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
CONFIGURE_ARGS+= --with-rigmatrix
-PLIST_SUB+= RIGMATRIX=""
+PLIST_SUB+= RIGMATRIX=""
.else
CONFIGURE_ARGS+= --without-with-rigmatrix
-PLIST_SUB+= RIGMATRIX="@comment "
+PLIST_SUB+= RIGMATRIX="@comment "
.endif
.if defined(WITH_GNURADIO)
CONFIGURE_ARGS+= --with-gnuradio
-PLIST_SUB+= GNURADIO=""
+PLIST_SUB+= GNURADIO=""
.else
CONFIGURE_ARGS+= --without-gnuradio
-LIST_SUB+= GNURADIO="@comment "
+PLIST_SUB+= GNURADIO="@comment "
.endif
-pre-everything::
-.if !defined(WITH_TCL) || !defined(WITH_PYTHON) || !defined(WITH_RIGMATRIX)
- @${ECHO_MSG} "You can specify the following command lines:"
- @${ECHO_MSG} ""
-.endif
-.if !defined(WITH_XML)
- @${ECHO_MSG} "WITH_XML=yes for XML support"
-.endif
-.if !defined(WITH_TCL)
- @${ECHO_MSG} "WITH_TCL=yes for TCL Binding support"
-.endif
-.if !defined(WITH_PYTHON)
- @${ECHO_MSG} "WITH_PYTHON=yes for PYTHON Binding support"
-.endif
-.if !defined(WITH_RIGMATRIX)
- @${ECHO_MSG} "WITH_RIGMATRIX=yes for RigMatrix support"
+.if defined(WITH_TCL) && defined(WITH_PYTHON)
+PLIST_SUB+= PYTHON_TCL=""
+.else
+PLIST_SUB+= PYTHON_TCL="@comment "
.endif
-#.if !defined(WITH_GNURADIO)
-# @${ECHO_MSG} "WITH_GNURADIO=yes for GNURadio support"
-#.endif
+
+pre-everything::
+ @${MAKE} showconfig
+ @${ECHO_MSG} "Use make config to set or unset above options"
@${ECHO_MSG} ""
+post-build:
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' \
+ ${WRKSRC}/bindings/Hamlib-pl.mk
+
.include <bsd.port.post.mk>