aboutsummaryrefslogtreecommitdiff
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-05-29 06:49:26 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-05-29 06:49:26 +0000
commit78c9b17c9cbf4e67438d366341368ca89b44f86e (patch)
treec6272729bffafa3bdae23a1a251c83cf0b5c7049 /comms/hylafax/Makefile
parent3373e4deb638f514252d0e3f920f080b3666f95d (diff)
downloadports-78c9b17c9cbf4e67438d366341368ca89b44f86e.tar.gz
ports-78c9b17c9cbf4e67438d366341368ca89b44f86e.zip
Notes
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile155
1 files changed, 49 insertions, 106 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index e1d78b2bc514..9aa572fb811c 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -1,119 +1,62 @@
# ports collection makefile for: hylafax
-# Version required: v3.0pl1
-# Date created: 16 May 1995
-# Whom: Julian Stacey <jhs@freebsd.org>
-# To Replace: flexfax v2.3beta038special
-# Name changed from flexfax to hylafax by author of both: Sam Leffler.
+# Version required: v4.0pl1
+# Date created: 19 Apr 1997
+# Whom: Jun-ichiro itojun Itoh <itojun@itojun.org>
+#
+# $Id: Makefile,v 1.8 1996/11/17 03:00:42 obrien Exp $
#
-# $Id: Makefile,v 1.7 1996/03/06 08:19:56 asami Exp $
-DISTNAME= hylafax-v3.0pl0
-PKGNAME= hylafax-3.0.1
+DISTNAME= hylafax-v4.0pl1
+PKGNAME= hylafax-4.0.1
CATEGORIES= comms
MASTER_SITES= ftp://ftp.sgi.com/sgi/fax/source/
EXTRACT_SUFX= -tar.gz
-PATCH_SITES= ftp://ftp.sgi.com/sgi/fax/source/
-PATCHFILES= hylafax-v3.0pl0-patch01.gz
-
-MAINTAINER= jhs@FreeBSD.org
-
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash gs:${PORTSDIR}/print/ghostscript
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-
-# Someone with more time & less space than me can investigate merging these.
-# LIB_DEPENDS= something:${PORTSDIR}/graphics/tiff
-# ./libtiff has 2M, & may be duplicates of what is in ${PORTSDIR}/graphics/tiff
-# LIB_DEPENDS= something:${PORTSDIR}/print/afm
-# ./afm/ has 536K of fonts, that perhaps could be merged.
-
-.if !exists(patches/patch-ab)
-IS_INTERACTIVE= yes
-# patches/patch-ab makes this BATCH compilable,
-# ( If you need interactive config, rm patch-ab )
-.endif
-PATCH_DIST_STRIP=-p1
+MAINTAINER= itojun@itojun.org
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ ${PREFIX}/lib/afm/Courier:${PORTSDIR}/print/afm
+# no dependency on ghostscript because we don't know which
+# version the user prefers
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= tiff34\\.1\\.:${PORTSDIR}/graphics/tiff34 \
+ jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg
+
+USE_GMAKE= yes
+CONFIGURE_ARGS= --with-INSTALL="" \
+ --with-MAKE=gmake --with-CC=/usr/bin/cc \
+ --with-LIBTIFF="-L${PREFIX}/lib -ltiff34 -ljpeg" \
+ --with-TIFFINC="${WRKSRC}"
HAS_CONFIGURE= yes
-MAN1= fax2ps.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 \
- hylafax.1 sendfax.1 sendpage.1 sgi2fax.1 textfmt.1
-MAN5= pagesizes.5f typerules.5f cid.5f config.5f destctrls.5f \
- dialrules.5f hosts.5f hylafax.5f info.5f log.5f recvq.5f \
- sendq.5f status.5f tsi.5f xferlog.5f
-MAN8= dialtest.8c faxabort.8c faxaddmodem.8c faxanswer.8c \
- faxcron.8c faxd.recv.8c faxgetty.8c faxq.8c faxquit.8c \
- faxrcvd.8c faxsend.8c mkcover.8c notify.8c pagesend.8c \
- pollrcvd.8c ps2fax.8c recvstats.8c tagtest.8c transcript.8c \
- tsitest.8c xferstats.8c
-
-FAXCOVER?= /etc/faxcover.ps
-# Default location to check for an optional over-riding host specific
-# customised faxcover that will be installed in these sources,
-# & end up where Hylafax installs all its stuff by default:
-# /var/spool/fax/etc/....
-# Note dont make FAXCOVER use a variable (such as ${PREFIX}),
-# as that wont work in `exists' below.
-
-# ------------------------------------------------------------------------------
-
-# We don't want INSTALL to be passed to configure
-do-configure:
- @(cd ${WRKSRC}; CC="${CC}" ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS}" \
- ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
-
-post-configure:
-.if exists(${FAXCOVER})
- @echo I see you have ${FAXCOVER},
- @echo which I will use to install a system default from.
- @# When I suggested to Sam (in the flexfax mailing list) merging
- @# in the distribution util/cover.templ & faxcover/faxcover.ps
- @# ( as they are virtually identical) Sam said they're for
- @# different things, & wouldn't do it. I don't know what the
- @# different purposes are, & I Do succesfully use the same file.
- -cd ${WRKSRC} ; mv faxcover/faxcover.ps faxcover/faxcover.ps.mv
- -cd ${WRKSRC} ; mv util/cover.templ util/cover.templ.mv
- -cd ${WRKSRC} ; ln -s ../cover.ps faxcover/faxcover.ps
- -cd ${WRKSRC} ; ln -s ../cover.ps util/cover.templ
- -cd ${WRKSRC} ; ln -s ${FAXCOVER} cover.ps
-.endif
-.if exists(patches/patch-ab)
- @echo "patches/patch-ab has supressed interactive configuration."
- @# If you need interactive config, rm patch-ab
-.endif
+MAN1= hylafax.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 sendfax.1 \
+ sendpage.1 sgi2fax.1 textfmt.1
+MAN5= pagesizes.5f typerules.5f \
+ hylafax.5f cid.5f config.5f destctrls.5f dialrules.5f hosts.5f \
+ info.5f log.5f pagermap.5f recvq.5f sendq.5f shutdown.5f status.5f \
+ tsi.5f xferlog.5f
+MAN8= cqtest.8c choptest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
+ faxanswer.8c faxconfig.8c faxmodem.8c faxstate.8c faxcron.8c \
+ faxgetty.8c faxinfo.8c faxq.8c faxqclean.8c faxquit.8c faxrcvd.8c \
+ faxsend.8c faxsetup.8c faxwatch.8c hfaxd.8c mkcover.8c notify.8c \
+ pagesend.8c pollrcvd.8c ps2fax.8c recvstats.8c tagtest.8c tiff2fax.8c \
+ tiffcheck.8c tsitest.8c wedged.8c xferstats.8c
+
+SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
+ ${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
+
+# for tiff34
+pre-configure:
+ @${RM} -f ${WRKSRC}/tiff.h
+ @${RM} -f ${WRKSRC}/tiffio.h
+ @ln -s ${PREFIX}/include/tiff34.h ${WRKSRC}/tiff.h
+ @ln -s ${PREFIX}/include/tiffio34.h ${WRKSRC}/tiffio.h
post-install:
- cd ${PREFIX}/bin ; strip \
- fax2ps faxalter faxcover faxmail faxrm faxstat sendfax sendpage
- cd ${PREFIX}/sbin ; strip faxd.recv faxgetty faxq
- @echo "Hylafax by default only does this sete[gu]id 0 stuff:"
- @echo " -u uucp -m 4755 faxq faxgetty"
- @echo "If you, like I, think it needs more, run 'make suid'"
- @echo "Now consider running faxaddmodem"
-
-SUID_EXES= /usr/local/sbin/faxgetty
-SUID_EXES+= /usr/local/sbin/faxq
-SUID_EXES+= /usr/local/bin/faxrm
-SUID_EXES+= /usr/local/bin/faxalter
-suid:
- @# This does too much, & may perhaps cause security loopholes,
- @# but default Hylafax doesnt do enough, eg faxrm wont work,
- @# & even worse, I have received a faxes that then silent failed
- @# to write to recvq.
- @# Only fax modem users who test their hypotheses may change this !
- @# (Imagine losing an important incoming fax, if recvq is unwritable.)
chown uucp ${SUID_EXES}
- chgrp dialer ${SUID_EXES}
- chmod 6555 ${SUID_EXES}
- find /var/spool/fax -print | xargs chown uucp
- find /var/spool/fax -print | xargs chgrp dialer
- find /var/spool/fax -print | xargs chmod g+w
- find /var/spool/fax -print | xargs chmod g+r
- find /var/spool/fax -type d -print | xargs chmod g+x
- # now remove some x bits that get set by mistake.
- -cd /var/spool/fax ; chmod g-x FIFO* log/* status/* recvq/* sendq/*
- @echo "Now nonsider doing somethink like this:"
- @echo " sh"
- @echo " n=1"
- @echo ' all="ttyd$$n ttyid$$n ttyld$$n cua0$$n cuai0$$n cual0$$n"'
- @echo ' chown uucp $$all; chgrp dialer $$all; chmod 660 $$all'
+ chmod 4555 ${SUID_EXES}
+ @if [ ! -f ${PREFIX}/etc/rc.d/hylafax.sh.sample ]; then \
+ cp ${FILESDIR}/hylafax.sh.sample ${PREFIX}/etc/rc.d; \
+ fi
+ ${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.mk>