aboutsummaryrefslogtreecommitdiff
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-08-16 14:40:30 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-08-16 14:40:30 +0000
commit581769c1a36b6118fc2b4f3d769f3142bcad399a (patch)
tree2ffd97ef3b8afec6ebb44ef6d483dbad928014ec /comms/hylafax/Makefile
parent5a53298f8531cf6ed19313e1efe7797a4662820e (diff)
downloadports-581769c1a36b6118fc2b4f3d769f3142bcad399a.tar.gz
ports-581769c1a36b6118fc2b4f3d769f3142bcad399a.zip
Notes
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 90c8d332bd65..abe221645b74 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hylafax
-PORTVERSION= 4.1.6
+PORTVERSION= 4.1.7
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
@@ -42,10 +42,11 @@ CONFIGURE_ARGS+=--nointeractive
MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER
HAS_CONFIGURE= yes
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
+USE_REINPLACE= yes
MAN1= hylafax-client.1 faxalter.1 faxcover.1 faxmail.1 \
faxrm.1 faxstat.1 sendfax.1 \
- sendpage.1 sgi2fax.1 textfmt.1
+ sendpage.1 sgi2fax.1 textfmt.1 edit-faxcover.1
MAN5= pagesizes.5f typerules.5f hosts.hfaxd.5f xferfaxlog.5f \
cid.5f doneq.5f hylafax-config.5f destctrls.5f dialrules.5f \
hylafax-info.5f hylafax-log.5f pagermap.5f recvq.5f sendq.5f \
@@ -65,6 +66,10 @@ SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
post-extract:
${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
+post-patch:
+ ${REINPLACE_CMD} -Ee 's,^(DIR.*=.*)/usr/local,\1${PREFIX},g' \
+ -e 's,/usr/local/man,${PREFIX}/man,g' ${WRKSRC}/configure
+
pre-install:
PLIST_SUB= SPOOL="`${GREP} SPOOL ${WRKSRC}/defs | ${CUT} -c10-`"