aboutsummaryrefslogtreecommitdiff
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-07-04 13:13:50 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-07-04 13:13:50 +0000
commitbbe8b66e9711b5880748ef784e7af3d419df3c60 (patch)
tree2cfc7fc5cf5ab09d45713e5116fe52e241dfd3cd /comms/hylafax/Makefile
parent06427e2661017a8590299cb15e3da4fca4756ff1 (diff)
downloadports-bbe8b66e9711b5880748ef784e7af3d419df3c60.tar.gz
ports-bbe8b66e9711b5880748ef784e7af3d419df3c60.zip
Notes
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index db27aa837512..90c8d332bd65 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= hylafax
-PORTVERSION= 4.1.5
+PORTVERSION= 4.1.6
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tdv94ped@cs.umu.se
COMMENT= Fax software
BUILD_DEPENDS= ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
+
# no dependency on ghostscript because we don't know which
# version the user prefers
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
@@ -27,16 +28,18 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-TIFFINC="${LOCALBASE}/include" \
--with-GCOPTS=" " --with-GCXXOPTS=" " \
--with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none \
- --with-DIR_HTML="${LOCALBASE}/share/doc/hylafax"
+ --with-DIR_HTML="${DOCSDIR}"
+
# Defaults to "North American Letter". Use "ISO A4" for A4.
.ifdef PAGESIZE
CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
.endif
+
.if defined(PACKAGE_BUILDING) || defined(BATCH)
CONFIGURE_ARGS+=--nointeractive
.endif
-MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER
+MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER
HAS_CONFIGURE= yes
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
@@ -62,6 +65,9 @@ SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
post-extract:
${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
+pre-install:
+PLIST_SUB= SPOOL="`${GREP} SPOOL ${WRKSRC}/defs | ${CUT} -c10-`"
+
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}