aboutsummaryrefslogtreecommitdiff
path: root/comms/hylafax
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-05-31 12:23:47 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-05-31 12:23:47 +0000
commit3c42352a731a6ffa55d4a6ec0767db090a5f0482 (patch)
tree57603978fa9e57750c2989171c21bacc4efb3143 /comms/hylafax
parenta740775726b6939e7ffc8234faab78bf39f31e36 (diff)
downloadports-3c42352a731a6ffa55d4a6ec0767db090a5f0482.tar.gz
ports-3c42352a731a6ffa55d4a6ec0767db090a5f0482.zip
Notes
Diffstat (limited to 'comms/hylafax')
-rw-r--r--comms/hylafax/Makefile24
-rw-r--r--comms/hylafax/distinfo6
-rw-r--r--comms/hylafax/files/hylafax.sh.in29
-rw-r--r--comms/hylafax/files/hylafax.sh.sample.in25
-rw-r--r--comms/hylafax/files/patch-Makefile.in (renamed from comms/hylafax/files/patch-Makefile)0
-rw-r--r--comms/hylafax/files/patch-configure144
-rw-r--r--comms/hylafax/files/patch-nls.mk32
-rw-r--r--comms/hylafax/pkg-plist27
8 files changed, 249 insertions, 38 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index bb9cd654765d..0990408f6f87 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hylafax
-PORTVERSION= 4.4.4
+PORTVERSION= 6.0.2
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
@@ -23,13 +23,15 @@ USE_GHOSTSCRIPT=yes
CONFIGURE_ARGS= --with-INSTALL="" \
--with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
--with-ZLIB=no --with-LIBZ=-lz \
- --with-TIFFINC="${LOCALBASE}/include" \
+ --with-TIFFINC="-I${LOCALBASE}/include" \
--with-GCOPTS=" " --with-GCXXOPTS=" " \
- --with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=/usr/include \
+ --with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=-I/usr/include \
--with-DIR_HTML="${DOCSDIR}"
+CFLAGS+= -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -Wall -L${LOCALBASE}/lib
-PORTDOCS= RELEASENOTES-4.3.txt RELEASENOTES-4.4.txt
-SUB_FILES= pkg-message hylafax.sh.sample
+PORTDOCS= RELEASENOTES-4.3.txt RELEASENOTES-4.4.txt RELEASENOTES-6.0.txt
+SUB_FILES= pkg-message
+USE_RC_SUBR= hylafax.sh
# Defaults to "North American Letter". Use "ISO A4" for A4.
.if defined(PAGESIZE)
@@ -84,6 +86,13 @@ SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= WITH_NLS=""
+.else
+PLIST_SUB+= WITH_NLS="@comment "
+.endif
+
pre-extract:
@if [ -d /var/db/pkg/tiff-3.6.1 ]; then \
${ECHO_MSG} ""; \
@@ -100,14 +109,13 @@ post-patch:
${WRKSRC}/configure
${REINPLACE_CMD} -e 's,-O hfaxd.conf,-O hfaxd.conf-dist,' \
${WRKSRC}/hfaxd/Makefile.in
- ${REINPLACE_CMD} -e 's,-O typerules,-O typerules-dist -src typerules,' \
+ ${REINPLACE_CMD} -e 's,-O typerules,-O typerules-dist,' \
-e 's,-O pagesizes,-O pagesizes-dist -src pagesizes,' \
- ${WRKSRC}/util/Makefile.in
+ ${WRKSRC}/libhylafax/Makefile.in
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}
- ${INSTALL_SCRIPT} ${WRKDIR}/hylafax.sh.sample ${PREFIX}/etc/rc.d
.for f in hfaxd.conf pagesizes typerules
if [ ! -f ${PREFIX}/lib/fax/${f} ]; then ${CP} -p ${PREFIX}/lib/fax/${f}-dist ${PREFIX}/lib/fax/${f}; fi
.endfor
diff --git a/comms/hylafax/distinfo b/comms/hylafax/distinfo
index b428567ce74f..8bc7efc42195 100644
--- a/comms/hylafax/distinfo
+++ b/comms/hylafax/distinfo
@@ -1,3 +1,3 @@
-MD5 (hylafax-4.4.4.tar.gz) = 4beb3d438ca6c4f00f1d94f9643e6668
-SHA256 (hylafax-4.4.4.tar.gz) = 6c059a39efea9b5d8d24004dc4775ae114026813ea3b6ca4e377d4f29c8eb569
-SIZE (hylafax-4.4.4.tar.gz) = 1188551
+MD5 (hylafax-6.0.2.tar.gz) = 2ab173a3bd50c8ca68d2c84f6e416d52
+SHA256 (hylafax-6.0.2.tar.gz) = 60def351462adaab7955f7cfb2a1f283119381aff6845b7a66010a268731924f
+SIZE (hylafax-6.0.2.tar.gz) = 1329186
diff --git a/comms/hylafax/files/hylafax.sh.in b/comms/hylafax/files/hylafax.sh.in
new file mode 100644
index 000000000000..3fa44f733788
--- /dev/null
+++ b/comms/hylafax/files/hylafax.sh.in
@@ -0,0 +1,29 @@
+
+#!/bin/sh
+#
+# $Id: hylafax.sh
+
+# PROVIDE: hylafax
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+# be sure to initialize the following:
+# server: %%PREFIX%%/sbin/faxsetup
+# modems: %%PREFIX%%/sbin/faxaddmodem
+# incoming calls: /etc/ttys
+
+hylafax_enable=${hylafax_enable-"NO"}
+
+. /etc/rc.subr
+
+name="hylafax"
+rcvar=`set_rcvar`
+
+start_cmd="%%PREFIX%%/sbin/hylafax start"
+stop_cmd="%%PREFIX%%/sbin/hylafax stop"
+procname="%%PREFIX%%/sbin/faxq"
+
+load_rc_config $name
+run_rc_command "$1"
+
+# eof
diff --git a/comms/hylafax/files/hylafax.sh.sample.in b/comms/hylafax/files/hylafax.sh.sample.in
deleted file mode 100644
index bf5fcb80bf18..000000000000
--- a/comms/hylafax/files/hylafax.sh.sample.in
+++ /dev/null
@@ -1,25 +0,0 @@
-#! /bin/sh
-# hylafax startup example.
-# be sure to initialize the following:
-# server: %%PREFIX%%/sbin/faxsetup
-# modems: %%PREFIX%%/sbin/faxaddmodem
-# incoming calls: /etc/ttys
-
-case "$1" in
-start)
- if [ -x %%PREFIX%%/sbin/hylafax ]; then
- %%PREFIX%%/sbin/hylafax start
- fi
- ;;
-stop)
- if [ -x %%PREFIX%%/sbin/hylafax ]; then
- %%PREFIX%%/sbin/hylafax stop
- fi
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- exit 64
- ;;
-esac
-
-exit 0
diff --git a/comms/hylafax/files/patch-Makefile b/comms/hylafax/files/patch-Makefile.in
index d24e12fe3976..d24e12fe3976 100644
--- a/comms/hylafax/files/patch-Makefile
+++ b/comms/hylafax/files/patch-Makefile.in
diff --git a/comms/hylafax/files/patch-configure b/comms/hylafax/files/patch-configure
new file mode 100644
index 000000000000..5339c0d3618c
--- /dev/null
+++ b/comms/hylafax/files/patch-configure
@@ -0,0 +1,144 @@
+--- configure.orig 2009-05-15 19:50:52.000000000 +0200
++++ configure 2009-05-31 11:46:51.000000000 +0200
+@@ -831,6 +831,7 @@
+ # NB: use ANSI C prototype to weed out non-ANSI compilers.
+ #
+ cat>dummy.c<<EOF
++#include <stdlib.h>
+ main(int argc, char* argv) { exit(0); }
+ EOF
+
+@@ -982,6 +983,7 @@
+ # Make dependency information.
+ #
+ cat>dummy.c<<EOF
++#include <stdlib.h>
+ main(int argc, char* argv) { exit(0); }
+ EOF
+ capture cat dummy.c
+@@ -1664,10 +1666,10 @@
+ LIBJBIG=""
+ if [ "$DISABLE_JBIG" != "yes" ]; then
+ Note "Checking for JBIG library support"
+- CheckForLibrary jbg_enc_init -ljbig &&
++ CheckForLibrary jbg_enc_init -L/usr/local/lib -L/usr/local/lib -ljbig &&
+ CheckForIncludeFile jbig.h && {
+ HAVE_JBIG="#define HAVE_JBIG 1"
+- LIBJBIG="-ljbig"
++ LIBJBIG="-L/usr/local/lib -L/usr/local/lib -ljbig"
+ }
+ if [ "x$LIBJBIG" = "x" ]; then
+ Note "... not found. Disabling JBIG support"
+@@ -1832,17 +1834,48 @@
+ done
+ if [ "$ISGXX" = yes ]; then
+ if [ -z "$CXXRUNTIME" ]; then
+- for f in memmove strdup; do
+- CheckForLibrary $f -lc || {
+- CheckForLibrary $f -lg++ && {
++ f="memmove"
++ CheckForLibraryWithArgs $f '(char *)0L, "", 0' -lc || {
++ CheckForLibraryWithArgs $f '(char *)0L, "", 0' -lg++ && {
++ Note "Looks like we need -lg++ for $f"
++ MACHDEPLIBS="$MACHDEPLIBS -lg++"
++ break;
++ }
++ }
++ f="strdup"
++ CheckForLibraryWithArgs $f '""' -lc || {
++ CheckForLibraryWithArgs $f '""' -lg++ && {
+ Note "Looks like we need -lg++ for $f"
+ MACHDEPLIBS="$MACHDEPLIBS -lg++"
+ break;
+ }
+ }
+- done
+ fi
+- for f in strtoul strerror memmove random; do
++ f="strtoul"
++ CheckForLibraryWithArgs $f '"", &"", 0' -lc || {
++ CheckForLibraryWithArgs $f '"", &"", 0' -liberty && {
++ Note "Looks like we need -liberty for $f"
++ MACHDEPLIBS="$MACHDEPLIBS -liberty"
++ break;
++ }
++ }
++ f="strerror"
++ CheckForLibraryWithArgs $f '""' -lc || {
++ CheckForLibraryWithArgs $f '""' -liberty && {
++ Note "Looks like we need -liberty for $f"
++ MACHDEPLIBS="$MACHDEPLIBS -liberty"
++ break;
++ }
++ }
++ f="memmove"
++ CheckForLibraryWithArgs $f '(char *)0L, "", 0' -lc || {
++ CheckForLibraryWithArgs $f '(char *)0L, "", 0' -liberty && {
++ Note "Looks like we need -liberty for $f"
++ MACHDEPLIBS="$MACHDEPLIBS -liberty"
++ break;
++ }
++ }
++ f="random"
+ CheckForLibrary $f -lc || {
+ CheckForLibrary $f -liberty && {
+ Note "Looks like we need -liberty for $f"
+@@ -1850,9 +1883,8 @@
+ break;
+ }
+ }
+- done
+ fi
+-CheckForLibrary floor -lm && {
++CheckForLibraryWithArgs floor "0.0" -lm && {
+ Note "Looks like -lm is the library for math functions."
+ MACHDEPLIBS="$MACHDEPLIBS -lm"
+ }
+@@ -2176,11 +2208,13 @@
+ #
+ CheckForFunc()
+ {
+- echo "extern int $1(); main(){$1($2);exit(0);}" >t.c
++ echo "#include <stdlib.h>" > t.c
++ echo "extern int $1(); main(){$1($2);exit(0);}" >>t.c
+ capture cat t.c
+ runMake t "t:; \${CC} t.c ${MACHDEPLIBS}"
+ }
+
++
+ #
+ # Look for a function declaration in system include files.
+ #
+@@ -2397,6 +2431,7 @@
+ EOF
+ }
+ cat<<'EOF'
++#include <stdlib.h>
+ extern char* malloc();
+ static void
+ boom(const char* msg)
+@@ -2532,6 +2567,7 @@
+ tiff_runlen_t=""
+ cat>t.c<<EOF
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "tiffio.h"
+ main()
+ {
+@@ -3233,7 +3269,7 @@
+ strtoul
+ writev
+ "
+-
++FUNCS=""
+ for i in $FUNCS; do
+ CheckForFunc $i || {
+ Note "... emulate $i"
+@@ -3291,6 +3327,7 @@
+ # Verify library is compatible.
+ #
+ cat>t.c<<EOF
++#include <stdlib.h>
+ #include "zlib.h"
+ main()
+ {
diff --git a/comms/hylafax/files/patch-nls.mk b/comms/hylafax/files/patch-nls.mk
new file mode 100644
index 000000000000..d2abfa3867d1
--- /dev/null
+++ b/comms/hylafax/files/patch-nls.mk
@@ -0,0 +1,32 @@
+--- po/nls.mk.orig 2009-01-21 15:32:14.000000000 +0100
++++ po/nls.mk 2009-05-31 12:40:46.000000000 +0200
+@@ -8,6 +8,7 @@
+ ${MSGCAT} libhylafax/messages.pot hylafax-client/messages.pot hylafax-server/messages.pot >> $@.tmp
+ mv $@.tmp $@
+
++FIXMATCH= ${DEPTH}/*/messages.po
+
+ # A bit more trikery here
+ # We want $(wildcard...) because we don't want to try to "rebuild" thes messages.pot
+@@ -15,18 +16,18 @@
+ # But legacy makes (SCO) don't support $(wildcard...). Luckly, they don't support $(...)
+ # At all, so they just drop it all. Real makes support $(wildcard)
+ # That's why we use the $(...${...})
+-libhylafax/messages.pot: $(wildcard ${patsubst %, ${DEPTH}/%/messages.po, libhylafax})
++libhylafax/messages.pot: ${FIXMATCH:Mlibhylafax}
+ test -d libhylafax || mkdir libhylafax
+ ${MSGCAT} $^ > $@.tmp
+ mv $@.tmp $@
+
+-hylafax-client/messages.pot: $(wildcard ${patsubst %, ${DEPTH}/%/messages.po, ${CLIENTS}})
++hylafax-client/messages.pot: ${FIXMATCH:Mclient}
+ test -d hylafax-client || mkdir hylafax-client
+ ${MSGCAT} $^ > $@.tmp
+ mv $@.tmp $@
+
+
+-hylafax-server/messages.pot: $(wildcard ${patsubst %, ${DEPTH}/%/messages.po, ${SERVERS}})
++hylafax-server/messages.pot: ${FIXMATCH:Mserver}
+ test -d hylafax-server || mkdir hylafax-server
+ ${MSGCAT} $^ > $@.tmp
+ mv $@.tmp $@
diff --git a/comms/hylafax/pkg-plist b/comms/hylafax/pkg-plist
index 408e726af7a5..224b46865c39 100644
--- a/comms/hylafax/pkg-plist
+++ b/comms/hylafax/pkg-plist
@@ -5,7 +5,6 @@ bin/faxrm
bin/faxstat
bin/sendfax
bin/sendpage
-etc/rc.d/hylafax.sh.sample
lib/fax/faxcover.ps
lib/fax/faxcover_example_sgi.ps
lib/fax/faxmail.ps
@@ -58,6 +57,18 @@ sbin/probemodem
sbin/lockname
sbin/ondelay
sbin/hylafax
+%%WITH_NLS%%share/locale/es/LC_MESSAGES/hylafax-client.mo
+%%WITH_NLS%%share/locale/es/LC_MESSAGES/hylafax-server.mo
+%%WITH_NLS%%share/locale/es/LC_MESSAGES/libhylafax.mo
+%%WITH_NLS%%share/locale/id/LC_MESSAGES/hylafax-client.mo
+%%WITH_NLS%%share/locale/id/LC_MESSAGES/hylafax-server.mo
+%%WITH_NLS%%share/locale/id/LC_MESSAGES/libhylafax.mo
+%%WITH_NLS%%share/locale/nl/LC_MESSAGES/hylafax-client.mo
+%%WITH_NLS%%share/locale/nl/LC_MESSAGES/hylafax-server.mo
+%%WITH_NLS%%share/locale/nl/LC_MESSAGES/libhylafax.mo
+%%WITH_NLS%%share/locale/vi/LC_MESSAGES/hylafax-client.mo
+%%WITH_NLS%%share/locale/vi/LC_MESSAGES/hylafax-server.mo
+%%WITH_NLS%%share/locale/vi/LC_MESSAGES/libhylafax.mo
@cwd /var/spool
hylafax/COPYRIGHT
@exec mkfifo %D/hylafax/FIFO
@@ -124,11 +135,13 @@ hylafax/config/ip568x
hylafax/config/linux-isdn-2
hylafax/config/lucent
hylafax/config/lucent-isa
+hylafax/config/lucent-mt-10
hylafax/config/lucent-mt-2
hylafax/config/lucent-mt-20
hylafax/config/lucent-mt-21
-hylafax/config/lucent-mt-10
+hylafax/config/mainpine-10
hylafax/config/mainpine-2
+hylafax/config/mainpine-20
hylafax/config/mainpine-21
hylafax/config/moto-288
hylafax/config/mt-1432
@@ -187,6 +200,7 @@ hylafax/etc/templates/en/faxrcvd-success.txt
hylafax/etc/templates/en/notify-blocked.txt
hylafax/etc/templates/en/notify-done-page.txt
hylafax/etc/templates/en/notify-done.txt
+hylafax/etc/templates/en/notify-faxmaster.txt
hylafax/etc/templates/en/notify-failed-page.txt
hylafax/etc/templates/en/notify-failed.txt
hylafax/etc/templates/en/notify-format_failed.txt
@@ -207,6 +221,7 @@ hylafax/etc/templates/fr/faxrcvd-success.txt
hylafax/etc/templates/fr/notify-blocked.txt
hylafax/etc/templates/fr/notify-done-page.txt
hylafax/etc/templates/fr/notify-done.txt
+hylafax/etc/templates/fr/notify-faxmaster.txt
hylafax/etc/templates/fr/notify-failed-page.txt
hylafax/etc/templates/fr/notify-failed.txt
hylafax/etc/templates/fr/notify-format_failed.txt
@@ -227,6 +242,7 @@ hylafax/etc/templates/de/faxrcvd-success.txt
hylafax/etc/templates/de/notify-blocked.txt
hylafax/etc/templates/de/notify-done-page.txt
hylafax/etc/templates/de/notify-done.txt
+hylafax/etc/templates/de/notify-faxmaster.txt
hylafax/etc/templates/de/notify-failed-page.txt
hylafax/etc/templates/de/notify-failed.txt
hylafax/etc/templates/de/notify-format_failed.txt
@@ -247,6 +263,7 @@ hylafax/etc/templates/ro/faxrcvd-success.txt
hylafax/etc/templates/ro/notify-blocked.txt
hylafax/etc/templates/ro/notify-done-page.txt
hylafax/etc/templates/ro/notify-done.txt
+hylafax/etc/templates/ro/notify-faxmaster.txt
hylafax/etc/templates/ro/notify-failed-page.txt
hylafax/etc/templates/ro/notify-failed.txt
hylafax/etc/templates/ro/notify-format_failed.txt
@@ -267,6 +284,7 @@ hylafax/etc/templates/pt_BR/faxrcvd-success.txt
hylafax/etc/templates/pt_BR/notify-blocked.txt
hylafax/etc/templates/pt_BR/notify-done-page.txt
hylafax/etc/templates/pt_BR/notify-done.txt
+hylafax/etc/templates/pt_BR/notify-faxmaster.txt
hylafax/etc/templates/pt_BR/notify-failed-page.txt
hylafax/etc/templates/pt_BR/notify-failed.txt
hylafax/etc/templates/pt_BR/notify-format_failed.txt
@@ -287,6 +305,7 @@ hylafax/etc/templates/pt/faxrcvd-success.txt
hylafax/etc/templates/pt/notify-blocked.txt
hylafax/etc/templates/pt/notify-done-page.txt
hylafax/etc/templates/pt/notify-done.txt
+hylafax/etc/templates/pt/notify-faxmaster.txt
hylafax/etc/templates/pt/notify-failed-page.txt
hylafax/etc/templates/pt/notify-failed.txt
hylafax/etc/templates/pt/notify-format_failed.txt
@@ -307,6 +326,7 @@ hylafax/etc/templates/es/faxrcvd-success.txt
hylafax/etc/templates/es/notify-blocked.txt
hylafax/etc/templates/es/notify-done-page.txt
hylafax/etc/templates/es/notify-done.txt
+hylafax/etc/templates/es/notify-faxmaster.txt
hylafax/etc/templates/es/notify-failed-page.txt
hylafax/etc/templates/es/notify-failed.txt
hylafax/etc/templates/es/notify-format_failed.txt
@@ -327,6 +347,7 @@ hylafax/etc/templates/it/faxrcvd-success.txt
hylafax/etc/templates/it/notify-blocked.txt
hylafax/etc/templates/it/notify-done-page.txt
hylafax/etc/templates/it/notify-done.txt
+hylafax/etc/templates/it/notify-faxmaster.txt
hylafax/etc/templates/it/notify-failed-page.txt
hylafax/etc/templates/it/notify-failed.txt
hylafax/etc/templates/it/notify-format_failed.txt
@@ -347,6 +368,7 @@ hylafax/etc/templates/pl/faxrcvd-success.txt
hylafax/etc/templates/pl/notify-blocked.txt
hylafax/etc/templates/pl/notify-done-page.txt
hylafax/etc/templates/pl/notify-done.txt
+hylafax/etc/templates/pl/notify-faxmaster.txt
hylafax/etc/templates/pl/notify-failed-page.txt
hylafax/etc/templates/pl/notify-failed.txt
hylafax/etc/templates/pl/notify-format_failed.txt
@@ -375,6 +397,7 @@ hylafax/etc/templates/html-sample1/hook.sh
hylafax/etc/templates/html-sample1/job-data.inc
hylafax/etc/templates/html-sample1/notify-blocked.txt
hylafax/etc/templates/html-sample1/notify-done.txt
+hylafax/etc/templates/html-sample1/notify-faxmaster.txt
hylafax/etc/templates/html-sample1/notify-failed.txt
hylafax/etc/templates/html-sample1/notify-format_failed.txt
hylafax/etc/templates/html-sample1/session_log.inc