aboutsummaryrefslogtreecommitdiff
path: root/comms/kermit/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-08-05 10:11:45 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-08-05 10:11:45 +0000
commita7c3ce89417f88674b25e8db403e018f6a93b9ef (patch)
tree5609f960f49792af5b6dff1517f38b6d3518af89 /comms/kermit/Makefile
parente4ad483acdd2c38c887f71a4ee86fc8721ab31ac (diff)
downloadports-a7c3ce89417f88674b25e8db403e018f6a93b9ef.tar.gz
ports-a7c3ce89417f88674b25e8db403e018f6a93b9ef.zip
Notes
Diffstat (limited to 'comms/kermit/Makefile')
-rw-r--r--comms/kermit/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/comms/kermit/Makefile b/comms/kermit/Makefile
index deda3744d043..8bd40d14161c 100644
--- a/comms/kermit/Makefile
+++ b/comms/kermit/Makefile
@@ -35,11 +35,12 @@ MAKE_ARGS= KTARGET=freebsd CC="${CC}" CC2="${CC}" \
LIBS="-L${OPENSSLLIB} \
-lssl -lcrypto -lncurses -lcrypt -lutil -lm"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800037 && ${ARCH} == "amd64"
-BROKEN= does not compile on amd64
-.endif
+post-patch:
+# FreeBSD has hexdump(3) in libutil, which conflicts with local macro
+ @${REINPLACE_CMD} -E 's,([[:blank:]])(hexdump),\1__\2,' \
+ ${WRKSRC}/ck_crp.c ${WRKSRC}/ckcdeb.h ${WRKSRC}/ckcftp.c \
+ ${WRKSRC}/ckcnet.c ${WRKSRC}/ckctel.c ${WRKSRC}/ckuath.c \
+ ${WRKSRC}/ckutio.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/krbmit ${PREFIX}/bin/kermit
@@ -58,4 +59,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ckermod.ini ${EXAMPLESDIR}/dot.mykermrc
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>