aboutsummaryrefslogtreecommitdiff
path: root/comms/libconcord
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-03 08:15:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-03 08:15:28 +0000
commit33970b6429fd6baadba39a0f46d01cb4dd47c0d5 (patch)
treeff5a457075fc03b3f129d61661190b3194783263 /comms/libconcord
parente35cf64a81a5cf6355b0731848fa0bbedd307b60 (diff)
downloadports-33970b6429fd6baadba39a0f46d01cb4dd47c0d5.tar.gz
ports-33970b6429fd6baadba39a0f46d01cb4dd47c0d5.zip
Notes
Diffstat (limited to 'comms/libconcord')
-rw-r--r--comms/libconcord/Makefile26
-rw-r--r--comms/libconcord/distinfo2
-rw-r--r--comms/libconcord/files/patch-configure16
-rw-r--r--comms/libconcord/pkg-descr6
-rw-r--r--comms/libconcord/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/comms/libconcord/Makefile b/comms/libconcord/Makefile
new file mode 100644
index 000000000000..7405d705d92c
--- /dev/null
+++ b/comms/libconcord/Makefile
@@ -0,0 +1,26 @@
+# Created by: Stephen Hurd <shurd@sasktel.net>
+# $FreeBSD$
+
+PORTNAME= libconcord
+PORTVERSION= 1.1
+CATEGORIES= comms
+MASTER_SITES= SF/concordance/concordance/${PORTVERSION}
+DISTNAME= concordance-${PORTVERSION}
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Logitech Harmony configuration library
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconf
+LIB_DEPENDS= libhidapi.so:${PORTSDIR}/comms/hidapi \
+ libzip.so:${PORTSDIR}/archivers/libzip
+
+USE_LDCONFIG= yes
+USES= tar:bzip2 libtool shared-mime-info
+WRKSRC_SUBDIR= libconcord
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/comms/libconcord/distinfo b/comms/libconcord/distinfo
new file mode 100644
index 000000000000..e380d1ba87ed
--- /dev/null
+++ b/comms/libconcord/distinfo
@@ -0,0 +1,2 @@
+SHA256 (concordance-1.1.tar.bz2) = ca5ffbd8c0fd06d41192c1d5e3c8b964c2393ea6d3d9c5e495c1da4b2c778a05
+SIZE (concordance-1.1.tar.bz2) = 1142393
diff --git a/comms/libconcord/files/patch-configure b/comms/libconcord/files/patch-configure
new file mode 100644
index 000000000000..0bd440f89d52
--- /dev/null
+++ b/comms/libconcord/files/patch-configure
@@ -0,0 +1,16 @@
+--- configure.orig 2014-03-28 20:27:39.000000000 -0700
++++ configure 2014-05-31 01:13:47.000000000 -0700
+@@ -15457,6 +15457,13 @@
+ fi
+ LIBCONCORD_LDFLAGS="-l$USBLIB"
+ ;;
++ freebsd*)
++ USBLIB="hidapi"
++
++$as_echo "#define WANT_HIDAPI 1" >>confdefs.h
++
++ LIBCONCORD_LDFLAGS="-l$USBLIB"
++ ;;
+ darwin*)
+ USBLIB="hidapi"
+
diff --git a/comms/libconcord/pkg-descr b/comms/libconcord/pkg-descr
new file mode 100644
index 000000000000..05b1fbd891d3
--- /dev/null
+++ b/comms/libconcord/pkg-descr
@@ -0,0 +1,6 @@
+The concordance software suite allows you to program your Logitech Harmony
+remote using a configuration object retreived from the harmony website. The
+Logitech Harmony is a highly configuration universal remote than can control
+most multimedia devices.
+
+This port contains the C Libraries for the concordance framework.
diff --git a/comms/libconcord/pkg-plist b/comms/libconcord/pkg-plist
new file mode 100644
index 000000000000..9d78fdcb963a
--- /dev/null
+++ b/comms/libconcord/pkg-plist
@@ -0,0 +1,6 @@
+include/libconcord.h
+lib/libconcord.a
+lib/libconcord.so
+lib/libconcord.so.3
+lib/libconcord.so.3.0.0
+share/mime/packages/libconcord.xml