aboutsummaryrefslogtreecommitdiff
path: root/comms/libticables
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-23 16:29:05 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-23 16:29:05 +0000
commita8203f58cca31de743520d6d0ba5d43d9b2318af (patch)
tree700bb634a94a67869f1571a6f5d599dc351b8ce9 /comms/libticables
parent8831aedb0ec13d38a86d3d9978744661529bbe1c (diff)
downloadports-a8203f58cca31de743520d6d0ba5d43d9b2318af.tar.gz
ports-a8203f58cca31de743520d6d0ba5d43d9b2318af.zip
Notes
Diffstat (limited to 'comms/libticables')
-rw-r--r--comms/libticables/Makefile12
-rw-r--r--comms/libticables/distinfo4
-rw-r--r--comms/libticables/files/patch-configure36
-rw-r--r--comms/libticables/files/patch-src-bsd-bsd_mapping.c50
-rw-r--r--comms/libticables/files/patch-src-intrface.c10
-rw-r--r--comms/libticables/files/patch-src-ioports.c38
-rw-r--r--comms/libticables/files/patch-src-linux-slv_link2.c11
-rw-r--r--comms/libticables/files/patch-src-slv_link.c18
-rw-r--r--comms/libticables/pkg-plist5
9 files changed, 67 insertions, 117 deletions
diff --git a/comms/libticables/Makefile b/comms/libticables/Makefile
index f3e9d9125ff0..8027b036b1a3 100644
--- a/comms/libticables/Makefile
+++ b/comms/libticables/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libticables
-PORTVERSION= 3.7.7
-PORTREVISION= 2
+PORTVERSION= 3.9.2
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tilp
@@ -19,14 +18,9 @@ LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
GNU_CONFIGURE= yes
USE_GETTEXT= yes
-USE_GNOME= pkgconfig
-USE_LIBTOOL_VER= 13
+USE_GNOME= gnomehack pkgconfig
+USE_LIBTOOL_VER= 15
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
- LDFLAGS="-L${LOCALBASE}/lib"
-
-MAN1= ticables-config.1
-
.include <bsd.port.mk>
diff --git a/comms/libticables/distinfo b/comms/libticables/distinfo
index 91994f75b0f7..d94bae5152e7 100644
--- a/comms/libticables/distinfo
+++ b/comms/libticables/distinfo
@@ -1,2 +1,2 @@
-MD5 (libticables-3.7.7.tar.gz) = d47c54228fb883a3cf1d5f779a926471
-SIZE (libticables-3.7.7.tar.gz) = 548323
+MD5 (libticables-3.9.2.tar.gz) = 354675bfbd881082a9447efde9935226
+SIZE (libticables-3.9.2.tar.gz) = 575639
diff --git a/comms/libticables/files/patch-configure b/comms/libticables/files/patch-configure
deleted file mode 100644
index 1091e940ad38..000000000000
--- a/comms/libticables/files/patch-configure
+++ /dev/null
@@ -1,36 +0,0 @@
---- configure.orig Wed Aug 27 12:17:39 2003
-+++ configure Tue Mar 23 16:08:32 2004
-@@ -1934,6 +1934,7 @@
- ACLOCALDIR=`aclocal --print-ac-dir`
-
- fi
-+ACLOCALDIR=""
-
-
- if test x$ACLOCALDIR != x ; then
-@@ -6257,7 +6258,8 @@
-
- # detect system type
- case "$host" in
--# alpha-*-*bsd*) ARCH="-D__FBSD__" ;;
-+ i386-*-*bsd*) ARCH="-D__BSD__ -D__I386__" ;;
-+ *-*-*bsd*) ARCH="-D__BSD__" ;;
- alpha*-*-linux-*) ARCH="-D__ALPHA__ -D__LINUX__" ;;
- alpha*-*-*-*) ARCH="-D__ALPHA__ -D__LINUX__" ;;
- arm*-*-linux-*) ARCH="-D__ARM__ -D__LINUX__" ;;
-@@ -6266,7 +6268,6 @@
- i[3456]86-*-hurd-*) ARCH="-D__LINUX__" ;;
- i[3456]86-*-mingw*) ARCH="-D__WIN32__ -D__MINGW32__ -Os -s" ;;
- i[3456]86-*-cygwin) ARCH="-D__WIN32__ -D__CYGWIN__ -mno-cygwin" ;;
-- i[3456]86-*-*bsd*) ARCH="-D__BSD__" ;;
- ia64-*-linux-*) ARCH="-D__LINUX__" ;;
- m68k-*-linux-*) ARCH="-D__M68K__ -D__LINUX__" ;;
- mips-*-linux-*) ARCH="-D__MIPS__ -D__LINUX__" ;;
-@@ -24767,6 +24768,7 @@
-
-
-
-+LDFLAGS="$LDFLAGS $INTLLIBS"
-
-
-
diff --git a/comms/libticables/files/patch-src-bsd-bsd_mapping.c b/comms/libticables/files/patch-src-bsd-bsd_mapping.c
new file mode 100644
index 000000000000..95f40b2168da
--- /dev/null
+++ b/comms/libticables/files/patch-src-bsd-bsd_mapping.c
@@ -0,0 +1,50 @@
+--- src/bsd/bsd_mapping.c.orig Mon May 30 14:01:58 2005
++++ src/bsd/bsd_mapping.c Mon May 30 14:09:38 2005
+@@ -74,9 +74,7 @@
+ break;
+
+ case LINK_AVR:
+- if(resources & IO_API) {
+- *method |= IOM_API | IOM_OK;
+- }
++ printl1(2, "AVR link support has been removed !\n");
+ break;
+
+ case LINK_SER:
+@@ -114,6 +112,7 @@
+
+ case LINK_TIE:
+ case LINK_VTI:
++ case LINK_VTL:
+ *method |= IOM_API | IOM_OK;
+ break;
+
+@@ -212,7 +211,10 @@
+ ret = bsd_map_io((TicableMethod)method, port);
+ if(ret)
+ return ret;
+-
++
++ // set fields to default values
++ nul_register_cable(lc);
++
+ // set the link cable
+ printl1(0, _("registering cable...\n"));
+ switch (type) {
+@@ -242,16 +244,6 @@
+ ser_register_cable_1(lc);
+ else if(method & IOM_IOCTL)
+ ser_register_cable_2(lc);
+- break;
+-
+- case LINK_AVR:
+- if ((port != SERIAL_PORT_1) &&
+- (port != SERIAL_PORT_2) &&
+- (port != SERIAL_PORT_3) &&
+- (port != SERIAL_PORT_4) && (port != USER_PORT))
+- return ERR_INVALID_PORT;
+-
+- avr_register_cable(lc);
+ break;
+
+ case LINK_VTL:
diff --git a/comms/libticables/files/patch-src-intrface.c b/comms/libticables/files/patch-src-intrface.c
deleted file mode 100644
index 48bef61ee817..000000000000
--- a/comms/libticables/files/patch-src-intrface.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/intrface.c.orig Sat Sep 13 18:45:17 2003
-+++ src/intrface.c Sat Sep 13 19:56:41 2003
-@@ -722,6 +722,7 @@
- /*********************/
-
- extern const char *search_for_tipar_node(int minor);
-+extern const char *search_for_tiser_node(int minor);
-
- static int convert_port_into_device(void)
- {
diff --git a/comms/libticables/files/patch-src-ioports.c b/comms/libticables/files/patch-src-ioports.c
deleted file mode 100644
index 5208e4a33c8e..000000000000
--- a/comms/libticables/files/patch-src-ioports.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/ioports.c.orig Wed Aug 27 11:34:39 2003
-+++ src/ioports.c Wed May 12 17:56:00 2004
-@@ -41,7 +41,7 @@
- #if defined(__I386__) && defined(HAVE_ASM_IO_H) && defined(HAVE_SYS_PERM_H)
- # include <sys/perm.h>
- # include <asm/io.h>
--#elif defined(__BSD__)
-+#elif defined(__BSD__) && defined(__I386__)
- # include <machine/sysarch.h>
- # include <machine/cpufunc.h>
- #elif defined(__WIN32__)
-@@ -107,7 +107,7 @@
- }
- #endif /* 0 */ /* __MACOSX__ */
-
--#if defined(__I386__) && defined(HAVE_ASM_IO_H) && defined(HAVE_SYS_PERM_H) || defined(__ALPHA__) || defined(__BSD__)
-+#if defined(__I386__) && defined(HAVE_ASM_IO_H) && defined(HAVE_SYS_PERM_H) || defined(__ALPHA__) || (defined(__BSD__) && defined(__I386__))
- static int linux_asm_read_io(unsigned int addr)
- {
- return inb(addr);
-@@ -208,7 +208,7 @@
- {
- #if defined(__I386__) && defined(HAVE_ASM_IO_H) && defined(HAVE_SYS_PERM_H) || defined(__ALPHA__) || defined(__BSD__) || defined(__MACOSX__)
-
--#ifndef __MACOSX__
-+#if !(defined(__MACOSX__) || (defined(__BSD__) && !defined(__I386__)))
- if (method & IOM_ASM) {
- io_rd = linux_asm_read_io;
- io_wr = linux_asm_write_io;
-@@ -417,7 +417,7 @@
- int io_close(unsigned long from, unsigned long num)
- {
- #if defined(__I386__) && defined(HAVE_ASM_IO_H) && defined(HAVE_SYS_PERM_H) || defined(__ALPHA__) || defined(__BSD__) || defined(__MACOSX__)
--#ifndef __MACOSX__
-+#if !(defined(__MACOSX__) || (defined(__BSD__) && !defined(__I386__)))
- if (method & IOM_ASM)
- #ifndef __BSD__
- return (ioperm(from, num, 0) ? ERR_ROOT : 0);
diff --git a/comms/libticables/files/patch-src-linux-slv_link2.c b/comms/libticables/files/patch-src-linux-slv_link2.c
new file mode 100644
index 000000000000..0fb5f99a1b49
--- /dev/null
+++ b/comms/libticables/files/patch-src-linux-slv_link2.c
@@ -0,0 +1,11 @@
+--- src/linux/slv_link2.c.orig Sun Sep 26 13:11:20 2004
++++ src/linux/slv_link2.c Mon May 30 15:27:12 2005
+@@ -111,7 +111,7 @@
+ {}
+ };
+
+-//static int max_ps = 32; // max packet size (32 ot 64)
++static int max_ps = 32; // max packet size (32 ot 64)
+
+ static int nBytesWrite2 = 0;
+ static uint8_t *wBuf2 = NULL;
diff --git a/comms/libticables/files/patch-src-slv_link.c b/comms/libticables/files/patch-src-slv_link.c
deleted file mode 100644
index 824d7fe28ef4..000000000000
--- a/comms/libticables/files/patch-src-slv_link.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/slv_link.c.orig Wed Aug 27 11:34:38 2003
-+++ src/slv_link.c Tue Mar 23 16:09:02 2004
-@@ -1423,6 +1423,7 @@
- MAX_PACKET_SIZE, (time_out * 10));
- */
-
-+#ifndef __BSD__
- /* Reset endpoints */
- ret = usb_clear_halt(tigl_han, TIGL_BULK_OUT);
- if (ret < 0) {
-@@ -1455,6 +1456,7 @@
- }
- }
- }
-+#endif
-
- /* Reset buffers */
- nBytesRead = 0;
diff --git a/comms/libticables/pkg-plist b/comms/libticables/pkg-plist
index d8d406ecaeab..14b9fd88f771 100644
--- a/comms/libticables/pkg-plist
+++ b/comms/libticables/pkg-plist
@@ -1,16 +1,13 @@
-bin/ticables-config
include/tilp/cabl_def.h
include/tilp/cabl_err.h
include/tilp/cabl_int.h
include/tilp/cabl_ver.h
include/tilp/export.h
-include/tilp/intl.h
include/tilp/ticables.h
include/tilp/timeout.h
lib/libticables.a
-lib/libticables.la
lib/libticables.so
-lib/libticables.so.10
+lib/libticables.so.12
libdata/pkgconfig/ticables.pc
share/locale/fr/LC_MESSAGES/libticables.mo
@unexec rmdir %D/include/tilp 2>/dev/null || true