aboutsummaryrefslogtreecommitdiff
path: root/comms/libticables
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
commitf5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa (patch)
tree343e91600b9cf81ffb94bf71017b43a88bfcbf45 /comms/libticables
parente9e0ba8df0a817712eab81d4a962e79cae35dca1 (diff)
downloadports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.tar.gz
ports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.zip
Notes
Diffstat (limited to 'comms/libticables')
-rw-r--r--comms/libticables/Makefile12
-rw-r--r--comms/libticables/files/extra-patch-configure26
2 files changed, 35 insertions, 3 deletions
diff --git a/comms/libticables/Makefile b/comms/libticables/Makefile
index a1805e1b1ae1..78a40cb6c708 100644
--- a/comms/libticables/Makefile
+++ b/comms/libticables/Makefile
@@ -15,8 +15,6 @@ MASTER_SITE_SUBDIR= tilp
MAINTAINER= tijl@ulyssis.org
COMMENT= TI calculator link cables library
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_GETTEXT= yes
USE_GNOME= gnomehack pkgconfig
@@ -24,4 +22,12 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_LDCONFIG= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/libticables/files/extra-patch-configure b/comms/libticables/files/extra-patch-configure
new file mode 100644
index 000000000000..7b30c348af12
--- /dev/null
+++ b/comms/libticables/files/extra-patch-configure
@@ -0,0 +1,26 @@
+--- configure.orig 2009-03-07 19:05:24.000000000 +0300
++++ configure 2009-03-07 19:06:25.000000000 +0300
+@@ -26925,21 +26925,13 @@
+ echo "${ECHO_T}no" >&6
+ fi
+
+-if test x$LIBUSB_CONFIG = xyes; then
+- LIBUSB_CFLAGS=`libusb-config --cflags`
+- LIBUSB_LIBS=`libusb-config --libs`
++ LIBUSB_CFLAGS=""
++ LIBUSB_LIBS="-lusb"
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_LIBUSB 1
+ _ACEOF
+
+-else
+- LIBUSB_CFLAGS=
+- LIBUSB_LIBS=
+-fi
+-
+-
+-
+ # Checks for header files.
+
+