aboutsummaryrefslogtreecommitdiff
path: root/comms/lirc/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:27:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 17:27:29 +0000
commitc4d4cacd63490d4b63e844ae298880332a388ba7 (patch)
tree3913b841cc9c2f98d7e4b2056eafc0d9980bf1c8 /comms/lirc/Makefile
parent5faefa6350cd172add279e339bd86a650313beb3 (diff)
- Remove conditional checks relevant only on FreeBSD 5.x and older
Notes
Notes: svn path=/head/; revision=225288
Diffstat (limited to 'comms/lirc/Makefile')
-rw-r--r--comms/lirc/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 8bee112f7394..917ab9b1057e 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -23,6 +23,9 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
OPTIONS= IRMAN "Build with libirman support" On
@@ -44,13 +47,6 @@ CONFIGURE_ARGS+= --with-driver=irman --with-driver=dvico
CONFIGURE_ARGS+= --with-driver=any --with-driver=dvico
.endif
-.if ${OSVERSION} >= 500041
-# These are already included in the getopt_long case on < 50041
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-.endif
-
MAN1= ircat.1 irexec.1 irpty.1 irrecord.1 irsend.1 irw.1 \
irxevent.1 lircrcd.1 mode2.1 smode2.1 xmode2.1
MAN8= lircd.8 lircmd.8