aboutsummaryrefslogtreecommitdiff
path: root/comms/lrzsz
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-01-16 12:23:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-01-16 12:23:45 +0000
commitf9c348c80f52b895c9ab75b63b8f8b2c09d3b2cc (patch)
tree189733a301184df86dd66ff61fcc22acfe5adcd6 /comms/lrzsz
parent90816505435704f5b385fc5c60995c1520064627 (diff)
Notes
Diffstat (limited to 'comms/lrzsz')
-rw-r--r--comms/lrzsz/Makefile2
-rw-r--r--comms/lrzsz/files/patch-rbsb.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/comms/lrzsz/Makefile b/comms/lrzsz/Makefile
index 75d2b4174d1b..0bf1ce504635 100644
--- a/comms/lrzsz/Makefile
+++ b/comms/lrzsz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lrzsz
PORTVERSION= 0.12.20
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms
MASTER_SITES= http://www.netsw.org/net/modem/protocols/zmodem/lrzsz/ \
http://www.ohse.de/uwe/releases/
diff --git a/comms/lrzsz/files/patch-rbsb.c b/comms/lrzsz/files/patch-rbsb.c
new file mode 100644
index 000000000000..05abec6f0a30
--- /dev/null
+++ b/comms/lrzsz/files/patch-rbsb.c
@@ -0,0 +1,11 @@
+--- src/rbsb.c.org 2010-01-15 22:41:21.000000000 +0900
++++ src/rbsb.c 2010-01-15 22:41:34.000000000 +0900
+@@ -296,7 +296,7 @@
+ tty.c_iflag |= IXOFF;
+
+ /* No echo, crlf mapping, INTR, QUIT, delays, no erase/kill */
+- tty.c_lflag &= ~(ECHO | ICANON | ISIG);
++ tty.c_lflag &= ~(ECHO | ICANON | ISIG | IEXTEN);
+ tty.c_oflag = 0; /* Transparent output */
+
+ tty.c_cflag &= ~(PARENB); /* Same baud rate, disable parity */