aboutsummaryrefslogtreecommitdiff
path: root/comms/lrzsz
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 23:04:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 23:04:48 +0000
commita5b076053ebbcdb7ec73c600dcdc88dc90c30fb0 (patch)
treef0ea18f34ac0e68bc6cc4a1b3ed1a4a07ad1a4a4 /comms/lrzsz
parent49dda8d0284c06ea77b5b1975fd723f7f6676e2f (diff)
downloadports-a5b076053ebbcdb7ec73c600dcdc88dc90c30fb0.tar.gz
ports-a5b076053ebbcdb7ec73c600dcdc88dc90c30fb0.zip
Notes
Diffstat (limited to 'comms/lrzsz')
-rw-r--r--comms/lrzsz/Makefile1
-rw-r--r--comms/lrzsz/files/patch-src::lrz.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/comms/lrzsz/Makefile b/comms/lrzsz/Makefile
index b518d5fbcbf9..8ddcf1843c81 100644
--- a/comms/lrzsz/Makefile
+++ b/comms/lrzsz/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lrzsz
PORTVERSION= 0.12.20
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.ohse.de/uwe/releases/ \
http://www.netsw.org/net/modem/protocols/zmodem/lrzsz/
diff --git a/comms/lrzsz/files/patch-src::lrz.c b/comms/lrzsz/files/patch-src::lrz.c
new file mode 100644
index 000000000000..9a1af487d185
--- /dev/null
+++ b/comms/lrzsz/files/patch-src::lrz.c
@@ -0,0 +1,15 @@
+--- src/lrz.c.orig Sun Sep 28 16:02:13 2003
++++ src/lrz.c Sun Sep 28 16:02:34 2003
+@@ -1159,9 +1159,9 @@
+
+ nameend = name + 1 + strlen(name);
+ if (*nameend) { /* file coming from Unix or DOS system */
+- long modtime;
+- long bytes_total;
+- int mode;
++ long modtime=0;
++ long bytes_total=DEFBYTL;
++ int mode=0;
+ sscanf(nameend, "%ld%lo%o", &bytes_total, &modtime, &mode);
+ zi->modtime=modtime;
+ zi->bytes_total=bytes_total;