aboutsummaryrefslogtreecommitdiff
path: root/comms/lysdr/files
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-10-15 14:55:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-10-15 14:55:14 +0000
commit7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae (patch)
treed30bee8baf5be305289898828fb58299162e2f54 /comms/lysdr/files
parentb3175cfda759707ed077a4649b634cad8934eb1b (diff)
downloadports-7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae.tar.gz
ports-7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae.zip
Notes
Diffstat (limited to 'comms/lysdr/files')
-rw-r--r--comms/lysdr/files/Makefile3
-rw-r--r--comms/lysdr/files/cexp.c46
2 files changed, 0 insertions, 49 deletions
diff --git a/comms/lysdr/files/Makefile b/comms/lysdr/files/Makefile
index 6903040952f2..70d4ede8d64a 100644
--- a/comms/lysdr/files/Makefile
+++ b/comms/lysdr/files/Makefile
@@ -6,9 +6,6 @@ CFLAGS+= `pkg-config -cflags ${PACKAGES}`
LDFLAGS+= `pkg-config -libs ${PACKAGES}` -lm
SRCS= gui.c sdr.c filter.c audio_jack.c smeter.c waterfall.c lysdr.c
-.if ${OSVERSION} < 900000
-SRCS+= cexp.c
-.endif
PROG= lysdr
WITHOUT_MAN= yes
diff --git a/comms/lysdr/files/cexp.c b/comms/lysdr/files/cexp.c
deleted file mode 100644
index 595e913be5d8..000000000000
--- a/comms/lysdr/files/cexp.c
+++ /dev/null
@@ -1,46 +0,0 @@
-/* $NetBSD: cexp.c,v 1.1 2007/08/20 16:01:34 drochner Exp $ */
-
-/*-
- * Copyright (c) 2007 The NetBSD Foundation, Inc.
- * All rights reserved.
- *
- * This code is derived from software written by Stephen L. Moshier.
- * It is redistributed by the NetBSD Foundation by permission of the author.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
- * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
- * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
-#include <complex.h>
-#include <math.h>
-
-double complex
-cexp(double complex z)
-{
- double complex w;
- double r, x, y;
-
- x = creal(z);
- y = cimag(z);
- r = exp(x);
- w = r * cos(y) + r * sin(y) * I;
- return w;
-}