aboutsummaryrefslogtreecommitdiff
path: root/comms/mgetty+sendfax
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2003-09-29 14:55:39 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2003-09-29 14:55:39 +0000
commitcd35646b2dfad817f298ce31b0c3b1f2d6583e39 (patch)
treebf2e7db457834bf9eb51ccd791d00dcc9e597bfa /comms/mgetty+sendfax
parent476adb867f9f4bd353e5bb37ce516dd2ec28dbfd (diff)
downloadports-cd35646b2dfad817f298ce31b0c3b1f2d6583e39.tar.gz
ports-cd35646b2dfad817f298ce31b0c3b1f2d6583e39.zip
Notes
Diffstat (limited to 'comms/mgetty+sendfax')
-rw-r--r--comms/mgetty+sendfax/Makefile2
-rw-r--r--comms/mgetty+sendfax/files/patch-v30
2 files changed, 31 insertions, 1 deletions
diff --git a/comms/mgetty+sendfax/Makefile b/comms/mgetty+sendfax/Makefile
index 89e6c1437c7f..0544c0f6e684 100644
--- a/comms/mgetty+sendfax/Makefile
+++ b/comms/mgetty+sendfax/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mgetty
PORTVERSION= 1.1.30.12.16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms
MASTER_SITES= ftp://alpha.greenie.net/pub/mgetty/source/1.1/
DISTNAME= mgetty1.1.30-Dec16
diff --git a/comms/mgetty+sendfax/files/patch-v b/comms/mgetty+sendfax/files/patch-v
new file mode 100644
index 000000000000..78c9262b59a8
--- /dev/null
+++ b/comms/mgetty+sendfax/files/patch-v
@@ -0,0 +1,30 @@
+--- voice/libvoice/signal.c.orig Sat Oct 23 23:58:01 1999
++++ voice/libvoice/signal.c Fri Jan 24 22:03:15 2003
+@@ -34,23 +34,16 @@
+
+ static void signal_sigchld(int sig)
+ {
++ /*
++ This appears to break passing back the shells exitstatus to vgetty
++
+ pid_t pid;
+ int status;
+- pid = wait(&status); /* This appears to fix core dumps on HPUX. Maybe this
++ pid = wait(&status);*/ /* This appears to fix core dumps on HPUX. Maybe this
+ * also fixes the same problem on Solaris.
+ */
+ signal(SIGCHLD, signal_sigchld);
+- if (status) {
+- lprintf(L_WARN, "%s: Got child %d exit status %d signal",
+- program_name,
+- pid,
+- status);
+- }
+- else {
+- lprintf(L_JUNK, "%s: Got child %d exit signal",
+- program_name,
+- pid);
+- }
++ lprintf(L_JUNK, "%s: Got child status change signal", program_name);
+ queue_event(create_event(SIGNAL_SIGCHLD));
+ }