aboutsummaryrefslogtreecommitdiff
path: root/comms/mgetty+sendfax
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1994-11-17 14:48:00 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1994-11-17 14:48:00 +0000
commite0ca3fc42af35e0341545567a83057d1de91d9f1 (patch)
treef20558adf8cf91b145dbf585aeb75c6761f00e11 /comms/mgetty+sendfax
parent26cc4a3cc47c86375a721dfc8e094ce7b411c88a (diff)
downloadports-e0ca3fc42af35e0341545567a83057d1de91d9f1.tar.gz
ports-e0ca3fc42af35e0341545567a83057d1de91d9f1.zip
Notes
Diffstat (limited to 'comms/mgetty+sendfax')
-rw-r--r--comms/mgetty+sendfax/Makefile17
-rw-r--r--comms/mgetty+sendfax/pkg-comment2
-rw-r--r--comms/mgetty+sendfax/pkg-plist8
-rw-r--r--comms/mgetty+sendfax/scripts/configure11
4 files changed, 26 insertions, 12 deletions
diff --git a/comms/mgetty+sendfax/Makefile b/comms/mgetty+sendfax/Makefile
index 6da96f423859..241b29b69ddf 100644
--- a/comms/mgetty+sendfax/Makefile
+++ b/comms/mgetty+sendfax/Makefile
@@ -1,7 +1,16 @@
-DISTNAME= mgetty-0.21
-DISTFILES= mgetty021-Nov09.tar.gz
+DISTNAME= mgetty-0.22
+DISTFILES= mgetty+sendfax-0.22.tar.gz
MASTER_SITES= ftp://hpsystem2.informatik.tu-muenchen.de/pub/comp/networking/communication/modem/mgetty/
-MAKE_FLAGS= FAX_SPOOL=/var/spool/fax LDFLAGS=-lutil prefix=${PREFIX}
-IS_INTERACTIVE= yes
+MAKE_FLAGS= CC=cc spool=/var/spool LDFLAGS=-lutil prefix=${PREFIX} -f
+USE_GMAKE= yes
+IS_INTERACTIVE= yes
+
+pre-install:
+ @mkdir -p ${PREFIX}/bin
+ @mkdir -p ${PREFIX}/lib
+ @mkdir -p ${PREFIX}/info
+ @mkdir -p ${PREFIX}/man/man1
+ @mkdir -p ${PREFIX}/man/man4
+ @(cd ${WRKSRC}/doc; ${GMAKE} manpages)
.include <bsd.port.mk>
diff --git a/comms/mgetty+sendfax/pkg-comment b/comms/mgetty+sendfax/pkg-comment
index 30dca611f590..e51cdac32c23 100644
--- a/comms/mgetty+sendfax/pkg-comment
+++ b/comms/mgetty+sendfax/pkg-comment
@@ -1 +1 @@
-mgetty+sendfax version 0.21 - handle external logins, send and receive faxes
+mgetty+sendfax version 0.22 - handle external logins, send and receive faxes
diff --git a/comms/mgetty+sendfax/pkg-plist b/comms/mgetty+sendfax/pkg-plist
index 77824a1509cd..9108fe4984ff 100644
--- a/comms/mgetty+sendfax/pkg-plist
+++ b/comms/mgetty+sendfax/pkg-plist
@@ -1,4 +1,5 @@
@cd /usr/local
+@mode 775
@owner bin
@group bin
bin/faxspool
@@ -18,7 +19,8 @@ lib/mgetty+sendfax/login.config
@owner bin
@mode 644
lib/mgetty+sendfax/faxheader
-lib/mgetty+sendfax/cour24i.pbm
+lib/mgetty+sendfax/cour25.pbm
+lib/mgetty+sendfax/cour25n.pbm
man/man1/g3topbm.1
man/man1/pbmtog3.1
man/man1/g3cat.1
@@ -26,6 +28,8 @@ man/man1/faxspool.1
man/man1/faxrunq.1
man/man1/faxq.1
man/man1/faxrm.1
+man/man1/fax.1
+man/man1/coverpg.1
man/man4/mgettydefs.4
man/man5/faxqueue.5
man/man8/sendfax.8
@@ -36,6 +40,6 @@ info/mgetty.info-2
info/mgetty.info-3
@cd /var/spool
@exec mkdir -p %D/fax/incoming
-@exec mkdir -p %D/fax/outging
+@exec mkdir -p %D/fax/outgoing
@exec chmod -R 775 %D/fax
@unexec rm -r %D/fax
diff --git a/comms/mgetty+sendfax/scripts/configure b/comms/mgetty+sendfax/scripts/configure
index b05525e4bc40..dddd70aa4d26 100644
--- a/comms/mgetty+sendfax/scripts/configure
+++ b/comms/mgetty+sendfax/scripts/configure
@@ -1,9 +1,9 @@
#!/bin/sh
-H=${WRKSRC}/policy.h
+H=$WRKSRC/policy.h
trap "rm -f $H; exit 1" 1 2 3
-cp ${WRKSRC}/policy.h-dist $H || exit 1
+cp $WRKSRC/policy.h-dist $H || exit 1
ww () {
@@ -57,12 +57,13 @@ cat <<END
You could use it to call "uucico" for all users starting with "U*"
(works only with Taylor UUCP 1.04 with my patch), or to call a fido
mailer for fido calls (only if -DFIDO defined)...
- See the samples in the example mgetty.login file.
+ See the samples in the example login.config file (built from login.cfg.in).
WARNING: make sure that this file isn't world-accessable (SECURITY!)
- If you want to call /bin/login in any case, do not define this
+ If you want to call /usr/bin/login in any case, do not define this
END
+echo "#undef LOGIN_CFG_FILE" >>$H
wn "config file:" LOGIN_CFG_FILE
ww DEFAULT_LOGIN_PROGRAM \"/usr/bin/login\"
@@ -296,7 +297,7 @@ this is the command to set the modem to use the desired flow control.
For hardware handshake, this could be &H3 for the ZyXEL, &K3 for
Rockwell-Based modems or \\Q3&S0 for Exar-Based Modems (i.e. some GVC's)
END
-wq command: "&H3" FAX_MODEM_HANDSHAKE
+wq command: "AT&H3" FAX_MODEM_HANDSHAKE
cat <<END
When sending a fax, if the other side says "page bad, retrain