aboutsummaryrefslogtreecommitdiff
path: root/comms/minicom
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2005-11-27 15:07:30 +0000
committerAnders Nordby <anders@FreeBSD.org>2005-11-27 15:07:30 +0000
commit717d893835d13876bcfb1f103377025f77a26f55 (patch)
tree590603f9e97d2ea15af978cfbb4e3a0f8d652780 /comms/minicom
parent48789882f9ce9ebf1c79223104766f3c6b8392ef (diff)
downloadports-717d893835d13876bcfb1f103377025f77a26f55.tar.gz
ports-717d893835d13876bcfb1f103377025f77a26f55.zip
Notes
Diffstat (limited to 'comms/minicom')
-rw-r--r--comms/minicom/Makefile18
-rw-r--r--comms/minicom/scripts/create-dev-link58
2 files changed, 8 insertions, 68 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 7c6785d1af4f..d17a1e8aa37a 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -33,11 +33,15 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock
-.if defined(BATCH)
-CONFIGURE_ARGS+= --enable-dfl-port=/dev/cuaa0
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+MINICOM_DEFAULT_PORT?= /dev/cuad0
.else
-CONFIGURE_ARGS+= --enable-dfl-port=/dev/modem
+MINICOM_DEFAULT_PORT?= /dev/cuaa0
.endif
+CONFIGURE_ARGS+= --enable-dfl-port=${MINICOM_DEFAULT_PORT}
MAN1= minicom.1 runscript.1 ascii-xfr.1 xminicom.1
@@ -48,12 +52,6 @@ post-patch:
${REINPLACE_CMD} -E -e "s@^(SUBDIRS = .*) intl@\1@" \
${WRKSRC}/Makefile.in
-pre-configure:
-.if !defined(BATCH)
- # this script creates a link from your comm port to /dev/modem
- ${SH} ${SCRIPTDIR}/create-dev-link
-.endif
-
post-install:
${CHOWN} uucp:dialer ${PREFIX}/bin/minicom
${CHMOD} 4511 ${PREFIX}/bin/minicom
@@ -72,4 +70,4 @@ post-install:
${DOCSDIR})
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/minicom/scripts/create-dev-link b/comms/minicom/scripts/create-dev-link
deleted file mode 100644
index 6c1d44d467ab..000000000000
--- a/comms/minicom/scripts/create-dev-link
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/sh -
-#
-# pre-install script for Minicom port to FreeBSD 2.x
-
-echo ""
-echo "Minicom will be installed mode 4511 (setuid) owner uucp, and group dialer."
-echo ""
-echo -n "Is this ok? [y] "
- read fooz
- if [ ! ${fooz} ] ; then
- fooz=Y
- fi
- if [ ${fooz} = Y -o ${fooz} = y -o ${fooz} = yes ] ; then
- # ok to continue
- else
- echo ""
- exit 1
- fi
-
-
-echo ""
-echo "Minicom needs to know what device your modem is hanging off of."
-echo "I (the porter) have adopted Satoshi Asami's lead of using /dev/modem."
-echo ""
-echo -n "Lets see if you have too..."
-
-# might want to test for ``-h'' rather than ``-e''
-if [ -e /dev/modem ]; then
- echo " Good you have:"
- /bin/ls -l /dev/modem
-else
- echo "Nope, you haven't (yet)."
- echo "The patches to Minicom hardcode /dev/modem."
- echo -n "Would you like me to make this link for you? [Y] "
- read foo
- if [ ! ${foo} ] ; then
- foo=Y
- fi
- if [ ${foo} = Y -o ${foo} = y -o ${foo} = yes ] ; then
- echo "From the list below, what port number is your modem attached to?"
- cd /dev
- /bin/ls -C cuaa*
- echo ""
- echo -n "Enter the number X from cuaaX above : "
- read bar
- if [ ${bar} ] ; then
- if [ -e /dev/cuaa${bar} ]; then
- ln -s /dev/cuaa${bar} /dev/modem
- else
- echo "Error: /dev/cuaa${bar} doesn't exist."
- exit 1
- fi
- fi
- fi
-fi
-
-echo ""
-exit 0