aboutsummaryrefslogtreecommitdiff
path: root/comms/nec2c
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2012-06-05 19:23:38 +0000
committerDiane Bruce <db@FreeBSD.org>2012-06-05 19:23:38 +0000
commit1534767a3735aa0afce683fde4e0703faac2407c (patch)
treedab7303b121a3bafd27c633116234b416e1e1bfc /comms/nec2c
parent9443714572ab5d3bc74fe67bf1e4b895888a7356 (diff)
downloadports-1534767a3735aa0afce683fde4e0703faac2407c.tar.gz
ports-1534767a3735aa0afce683fde4e0703faac2407c.zip
Notes
Diffstat (limited to 'comms/nec2c')
-rw-r--r--comms/nec2c/Makefile1
-rw-r--r--comms/nec2c/files/patch-misc.c20
-rw-r--r--comms/nec2c/files/patch-nec2c.h13
3 files changed, 34 insertions, 0 deletions
diff --git a/comms/nec2c/Makefile b/comms/nec2c/Makefile
index 10d4d55a26bb..b1a2a7fbb12b 100644
--- a/comms/nec2c/Makefile
+++ b/comms/nec2c/Makefile
@@ -10,6 +10,7 @@
PORTNAME= nec2c
PORTVERSION= .9
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://ftp-mirror.internap.com/pub/FreeBSD/distfiles/nec2c/ \
http://ftp.cerias.purdue.edu/pub/os/FreeBSD/distfiles/nec2c/
diff --git a/comms/nec2c/files/patch-misc.c b/comms/nec2c/files/patch-misc.c
new file mode 100644
index 000000000000..809e45ff32da
--- /dev/null
+++ b/comms/nec2c/files/patch-misc.c
@@ -0,0 +1,20 @@
+--- misc.c.orig 2012-06-05 13:35:29.000000000 -0500
++++ misc.c 2012-06-05 13:36:34.000000000 -0500
+@@ -192,7 +192,7 @@
+
+ /*** Memory allocation/freeing utils ***/
+
+-void mem_alloc( void **ptr, int req )
++void mem_alloc( void **ptr, size_t req )
+ {
+ free_ptr( ptr );
+ *ptr = malloc( req );
+@@ -203,7 +203,7 @@
+
+ /*------------------------------------------------------------------------*/
+
+-void mem_realloc( void **ptr, int req )
++void mem_realloc( void **ptr, size_t req )
+ {
+ *ptr = realloc( *ptr, req );
+ if( *ptr == NULL )
diff --git a/comms/nec2c/files/patch-nec2c.h b/comms/nec2c/files/patch-nec2c.h
new file mode 100644
index 000000000000..416e9acd8acc
--- /dev/null
+++ b/comms/nec2c/files/patch-nec2c.h
@@ -0,0 +1,13 @@
+--- nec2c.h.orig 2012-06-05 13:34:14.000000000 -0500
++++ nec2c.h 2012-06-05 13:34:45.000000000 -0500
+@@ -201,8 +201,8 @@
+ void secnds(double *x);
+ int stop(int flag);
+ int load_line(char *buff, FILE *pfile);
+-void mem_alloc( void **ptr, int req );
+-void mem_realloc( void **ptr, int req );
++void mem_alloc( void **ptr, size_t req );
++void mem_realloc( void **ptr, size_t req );
+ void free_ptr( void **ptr );
+ /* somnec.c */
+ void somnec(double epr, double sig, double fmhz);