aboutsummaryrefslogtreecommitdiff
path: root/comms/obexapp
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-05-25 10:50:47 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-05-25 10:50:47 +0000
commitdbc3a63caa95386e88b5e45cb9bbd1ead6a2217c (patch)
tree49c8305a3002f630893f0e64e74239cca77c13e3 /comms/obexapp
parent212583e0fd78b46830c96f6024fb2f951a4259bd (diff)
Notes
Diffstat (limited to 'comms/obexapp')
-rw-r--r--comms/obexapp/Makefile16
-rw-r--r--comms/obexapp/files/patch-Makefile22
2 files changed, 27 insertions, 11 deletions
diff --git a/comms/obexapp/Makefile b/comms/obexapp/Makefile
index 3df1ebfd7448..06de7533401a 100644
--- a/comms/obexapp/Makefile
+++ b/comms/obexapp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= obexapp
PORTVERSION= 1.4.6
+PORTREVISION= 1
CATEGORIES= comms net
MASTER_SITES= http://www.geocities.com/m_evmenkin/
@@ -18,14 +19,21 @@ LIB_DEPENDS= openobex:${PORTSDIR}/comms/openobex
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ICONV= yes
+PLIST_FILES= bin/obexapp
+
+.if !defined(NO_INSTALL_MANPAGES)
MAN1= obexapp.1
MANCOMPRESSED= yes
-PLIST_FILES= bin/obexapp
+.else
+MAKE_ENV+= NO_MAN=yes
+.endif
+
+MAKE_ENV+= NO_WERROR=yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502101
-IGNORE= Needs 5.x from 20 Jan 2004 or later (sdpd)
+IGNORE= needs 5.x from 20 Jan 2004 or later (sdpd)
.endif
.if ${OSVERSION} < 502121
@@ -33,8 +41,4 @@ IGNORE= Needs 5.x from 20 Jan 2004 or later (sdpd)
ONLY_FOR_ARCHS= i386
.endif
-post-patch:
- @${FIND} ${WRKSRC} -name \*.c | ${XARGS} \
- ${REINPLACE_CMD} -e 's|<sdp.h>|</usr/include/sdp.h>|'
-
.include <bsd.port.post.mk>
diff --git a/comms/obexapp/files/patch-Makefile b/comms/obexapp/files/patch-Makefile
index def3cd2edbfb..a95fb90db3d4 100644
--- a/comms/obexapp/files/patch-Makefile
+++ b/comms/obexapp/files/patch-Makefile
@@ -1,15 +1,27 @@
--- Makefile.orig Mon Apr 23 20:29:18 2007
-+++ Makefile Wed Apr 25 20:41:52 2007
-@@ -1,8 +1,10 @@
- # $Id: Makefile,v 1.11 2007/04/23 18:29:18 max Exp $
- # $FreeBSD$
++++ Makefile Thu May 3 13:48:19 2007
+@@ -3,4 +3,7 @@
-BINDIR= /usr/local/bin
-MANDIR= /usr/local/man/man
+PREFIX?= /usr/local
++LOCALBASE?= /usr/local
+
+BINDIR= ${PREFIX}/bin
+MANDIR= ${PREFIX}/man/man
PROG= obexapp
- MAN1= obexapp.1
+@@ -15,4 +18,4 @@
+-CFLAGS+= -I/usr/local/include \
+- -I/usr/local/include/openobex \
++CFLAGS+= -idirafter ${LOCALBASE}/include \
++ -I${LOCALBASE}/include/openobex \
+ -fno-strict-aliasing
+@@ -20,3 +23,3 @@
+ DPADD= ${LIBBLUETOOTH} ${LIBSDP} ${LIBBSDXML} ${LIBREADLINE}
+-LDADD= -L/usr/lib -L/usr/local/lib \
++LDADD= -L/usr/lib -L${LOCALBASE}/lib \
+ -lbluetooth -lsdp -lopenobex -lbsdxml -lreadline -liconv
+@@ -24,2 +27 @@
+ .include <bsd.prog.mk>
+-