aboutsummaryrefslogtreecommitdiff
path: root/comms/obexapp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-12 21:05:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-12 21:05:10 +0000
commit296c687cf898df61f28ef3f6c342649398d8f540 (patch)
treee23b45778375c28b4f65f54385f22ca0f73bd1a3 /comms/obexapp
parent49f6c471fd3f6ec869b79e86acbae5bc5f6a2963 (diff)
downloadports-296c687cf898df61f28ef3f6c342649398d8f540.tar.gz
ports-296c687cf898df61f28ef3f6c342649398d8f540.zip
Notes
Diffstat (limited to 'comms/obexapp')
-rw-r--r--comms/obexapp/Makefile3
-rw-r--r--comms/obexapp/distinfo4
-rw-r--r--comms/obexapp/files/patch-Makefile6
-rw-r--r--comms/obexapp/files/patch-main.c11
-rw-r--r--comms/obexapp/files/patch-server.c25
5 files changed, 6 insertions, 43 deletions
diff --git a/comms/obexapp/Makefile b/comms/obexapp/Makefile
index 6e963b535091..38cbf71b22bd 100644
--- a/comms/obexapp/Makefile
+++ b/comms/obexapp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= obexapp
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= comms net
MASTER_SITES= http://www.geocities.com/m_evmenkin/
@@ -15,7 +15,6 @@ COMMENT= Obex application to transfer objects to mobile equipment
LIB_DEPENDS= openobex-1.0.1:${PORTSDIR}/comms/openobex
-USE_GNOME= glib12
WRKSRC= ${WRKDIR}/${PORTNAME}
# libbluetooth is only installed on i386
diff --git a/comms/obexapp/distinfo b/comms/obexapp/distinfo
index 6cd0ac5ad4fb..26ceff2a5ad8 100644
--- a/comms/obexapp/distinfo
+++ b/comms/obexapp/distinfo
@@ -1,2 +1,2 @@
-MD5 (obexapp-1.1.tar.gz) = fbe6006f5f9490303ea43078edd298e8
-SIZE (obexapp-1.1.tar.gz) = 195743
+MD5 (obexapp-1.2.tar.gz) = 3f02b3e490f018bf8eb6f2d8f670ae56
+SIZE (obexapp-1.2.tar.gz) = 303365
diff --git a/comms/obexapp/files/patch-Makefile b/comms/obexapp/files/patch-Makefile
index e0a424db973b..e5716cd1fb7f 100644
--- a/comms/obexapp/files/patch-Makefile
+++ b/comms/obexapp/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile.orig Mon Mar 22 22:14:11 2004
-+++ Makefile Mon Mar 22 22:15:52 2004
+--- Makefile.orig Mon Apr 12 03:10:25 2004
++++ Makefile Mon Apr 12 03:10:59 2004
@@ -1,8 +1,10 @@
- # $Id: Makefile,v 1.6 2004/03/12 22:10:52 max Exp $
+ # $Id: Makefile,v 1.7 2004/04/09 21:09:09 max Exp $
# $FreeBSD$
-BINDIR= /usr/local/bin
diff --git a/comms/obexapp/files/patch-main.c b/comms/obexapp/files/patch-main.c
deleted file mode 100644
index 25d04ae5b05a..000000000000
--- a/comms/obexapp/files/patch-main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.c.orig Mon Mar 22 21:01:45 2004
-+++ main.c Mon Mar 22 21:02:10 2004
-@@ -137,7 +137,7 @@
- custfunc.listen = obexapp_transport_listen;
- custfunc.write = obexapp_transport_write;
- custfunc.handleinput = obexapp_transport_handle_input;
-- custfunc.userdata = &context;
-+ custfunc.customdata = &context;
-
- /* Process command line options */
- service = 0;
diff --git a/comms/obexapp/files/patch-server.c b/comms/obexapp/files/patch-server.c
deleted file mode 100644
index 05568c646607..000000000000
--- a/comms/obexapp/files/patch-server.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- server.c.orig Mon Mar 22 21:04:12 2004
-+++ server.c Mon Mar 22 21:32:45 2004
-@@ -105,6 +105,7 @@
- {
- context_p context = (context_p) OBEX_GetUserData(handle);
- struct passwd *pw = NULL;
-+ struct sockaddr *saddr = NULL;
- gint error;
-
- if (context->user != NULL) {
-@@ -169,7 +170,13 @@
-
- g_message("%s: Starting OBEX server", G_GNUC_FUNCTION);
-
-- if (OBEX_ServerRegister(handle, "OBEX") < 0) {
-+ if (( saddr = (struct sockaddr *) g_malloc(sizeof(struct sockaddr))) == NULL) {
-+ g_critical("%s(): Could not allocate saddr",
-+ G_GNUC_FUNCTION);
-+ exit(1);
-+ }
-+
-+ if (OBEX_ServerRegister(handle, saddr, sizeof(struct sockaddr)) < 0) {
- g_critical("%s(): OBEX_ServerRegister failed", G_GNUC_FUNCTION);
- return (-1);
- }