aboutsummaryrefslogtreecommitdiff
path: root/comms/p5-Cisco-UCS/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-11-27 15:35:57 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-11-27 15:35:57 +0000
commit3586b23510d1eae77e698391d02532978427f03d (patch)
treec63a742ff419f583fcc4696fbf187a675430de28 /comms/p5-Cisco-UCS/Makefile
parent4887372546acbd3e95c89de3429a04c5c70a3b4d (diff)
downloadports-3586b23510d1eae77e698391d02532978427f03d.tar.gz
ports-3586b23510d1eae77e698391d02532978427f03d.zip
Notes
Diffstat (limited to 'comms/p5-Cisco-UCS/Makefile')
-rw-r--r--comms/p5-Cisco-UCS/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/comms/p5-Cisco-UCS/Makefile b/comms/p5-Cisco-UCS/Makefile
index 4d0a91de3edc..1b02f2cb9eaf 100644
--- a/comms/p5-Cisco-UCS/Makefile
+++ b/comms/p5-Cisco-UCS/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: p5-Cisco-UCS
-# Date created: 2012-04-11
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= Cisco-UCS
-PORTVERSION= 0.031
+PORTVERSION= 0.29
+PORTEPOCH= 1
CATEGORIES= comms perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +11,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= A Perl interface to the Cisco UCS XML API
-BUILD_DEPENDS= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= Cisco::UCS.3
+MAN3= Cisco::UCS.3 Cisco::UCS::Blade.3 Cisco::UCS::Chassis.3 \
+ Cisco::UCS::Common::EthernetPort.3 Cisco::UCS::Common::Fan.3 \
+ Cisco::UCS::Common::FanModule.3 Cisco::UCS::Common::PSU.3 \
+ Cisco::UCS::Common::SwitchCard.3 Cisco::UCS::FEX.3 \
+ Cisco::UCS::Fault.3 Cisco::UCS::Interconnect.3 \
+ Cisco::UCS::MgmtEntity.3 Cisco::UCS::ServiceProfile.3
.include <bsd.port.mk>