aboutsummaryrefslogtreecommitdiff
path: root/comms/p5-Device-SerialPort
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>2003-07-08 16:32:45 +0000
committerNick Sayer <nsayer@FreeBSD.org>2003-07-08 16:32:45 +0000
commit3627b3c3b73666f2d5f8a5c10d30045124e88181 (patch)
treeb56389538ce4a1819fc6a2fe9533a1907f825333 /comms/p5-Device-SerialPort
parent6028ecb611d0623fef310604fdbbddfcf27c8440 (diff)
downloadports-3627b3c3b73666f2d5f8a5c10d30045124e88181.tar.gz
ports-3627b3c3b73666f2d5f8a5c10d30045124e88181.zip
Notes
Diffstat (limited to 'comms/p5-Device-SerialPort')
-rw-r--r--comms/p5-Device-SerialPort/Makefile24
-rw-r--r--comms/p5-Device-SerialPort/distinfo1
-rw-r--r--comms/p5-Device-SerialPort/files/patch-aa11
-rw-r--r--comms/p5-Device-SerialPort/pkg-descr4
-rw-r--r--comms/p5-Device-SerialPort/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/comms/p5-Device-SerialPort/Makefile b/comms/p5-Device-SerialPort/Makefile
new file mode 100644
index 000000000000..e8d8284b7a77
--- /dev/null
+++ b/comms/p5-Device-SerialPort/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Device-SerialPort
+# Date created: July 6th 2003
+# Whom: Nick Sayer <nsayer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Device-SerialPort
+PORTVERSION= 0.22
+CATEGORIES= comms perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Device
+PKGNAMEPREFIX= p5-
+DISTNAME= Device-SerialPort-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A perl5 module for simple serial port control
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Device::SerialPort.3
+
+.include <bsd.port.mk>
diff --git a/comms/p5-Device-SerialPort/distinfo b/comms/p5-Device-SerialPort/distinfo
new file mode 100644
index 000000000000..44c2882fdf98
--- /dev/null
+++ b/comms/p5-Device-SerialPort/distinfo
@@ -0,0 +1 @@
+MD5 (Device-SerialPort-0.22.tar.gz) = 4cc2590d89f4475dd3cecaa81087b5b3
diff --git a/comms/p5-Device-SerialPort/files/patch-aa b/comms/p5-Device-SerialPort/files/patch-aa
new file mode 100644
index 000000000000..c0661fc128d9
--- /dev/null
+++ b/comms/p5-Device-SerialPort/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Tue Jul 8 09:10:12 2003
++++ Makefile.PL Tue Jul 8 09:11:03 2003
+@@ -15,7 +15,7 @@
+ }
+ }
+ unless (@SERIALS) {
+- @SERIALS=( "/dev/ttyS1", "/dev/cua01", "/dev/cua/b", "/dev/tty1" );
++ @SERIALS=( "/dev/ttyd0", "/dev/cuaa0", "/dev/ucom0" );
+ print "(use 'perl Makefile.PL TESTPORT=<DEVICE>' to override this search)\n";
+ }
+
diff --git a/comms/p5-Device-SerialPort/pkg-descr b/comms/p5-Device-SerialPort/pkg-descr
new file mode 100644
index 000000000000..e5ee308035e3
--- /dev/null
+++ b/comms/p5-Device-SerialPort/pkg-descr
@@ -0,0 +1,4 @@
+Device::SerialPort is a perl module that provides a simple interface to serial
+ports and their settings (baud rate, word length, etc).
+
+WWW: http://sendpage.org/device-serialport/
diff --git a/comms/p5-Device-SerialPort/pkg-plist b/comms/p5-Device-SerialPort/pkg-plist
new file mode 100644
index 000000000000..47c2834d0834
--- /dev/null
+++ b/comms/p5-Device-SerialPort/pkg-plist
@@ -0,0 +1,7 @@
+bin/modemtest
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Device/SerialPort.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Device/SerialPort/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Device/SerialPort/SerialPort.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Device/SerialPort/SerialPort.so
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Device/SerialPort 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Device 2>/dev/null || true