aboutsummaryrefslogtreecommitdiff
path: root/comms/p5-SMS-Send-TW-HiAir/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-07 05:07:21 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-07 05:07:21 +0000
commit5f7741876cc39feb8b69ba13d8ee068e257d8e80 (patch)
tree4a4792458e8fd0c51b043d9c570c828ff137c2c4 /comms/p5-SMS-Send-TW-HiAir/Makefile
parent9bf517e525c878d1ddd2287b68888d258cab3d0b (diff)
Notes
Diffstat (limited to 'comms/p5-SMS-Send-TW-HiAir/Makefile')
-rw-r--r--comms/p5-SMS-Send-TW-HiAir/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/comms/p5-SMS-Send-TW-HiAir/Makefile b/comms/p5-SMS-Send-TW-HiAir/Makefile
new file mode 100644
index 000000000000..de6e5591ad15
--- /dev/null
+++ b/comms/p5-SMS-Send-TW-HiAir/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-SMS-Send-TW-HiAir
+# Date created: 2010-01-06
+# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SMS-Send-TW-HiAir
+PORTVERSION= 0.01
+CATEGORIES= comms perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jnlin@csie.nctu.edu.tw
+COMMENT= SMS::Send driver for http://hiair.hinet.net/
+
+RUN_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
+ p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SMS::Send::TW::HiAir.3
+
+.include <bsd.port.mk>