aboutsummaryrefslogtreecommitdiff
path: root/comms/p5-SMS-Send
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-03-12 17:30:28 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-03-12 17:30:28 +0000
commitd7078132df6f3861e54d85b3a0e777bdba2abf48 (patch)
treeddd8ddbb4da094865b6e29ff29d54d9c2bc58bc3 /comms/p5-SMS-Send
parent6d3464464ba7653fe9e7e1bf5bb4d876b2bf8d60 (diff)
downloadports-d7078132df6f3861e54d85b3a0e777bdba2abf48.tar.gz
ports-d7078132df6f3861e54d85b3a0e777bdba2abf48.zip
Notes
Diffstat (limited to 'comms/p5-SMS-Send')
-rw-r--r--comms/p5-SMS-Send/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/comms/p5-SMS-Send/Makefile b/comms/p5-SMS-Send/Makefile
index e5d282e525f1..7146b28a40df 100644
--- a/comms/p5-SMS-Send/Makefile
+++ b/comms/p5-SMS-Send/Makefile
@@ -7,6 +7,7 @@
PORTNAME= SMS-Send
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= comms perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= Driver-based API for sending SMS messages
-BUILD_DEPENDS= ${SITE_PERL}/Class/Adapter.pm:${PORTSDIR}/devel/p5-Class-Adapter \
- ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
- ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Class-Adapter>=0:${PORTSDIR}/devel/p5-Class-Adapter \
+ p5-Params-Util>=0.14:${PORTSDIR}/devel/p5-Params-Util
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -28,4 +26,10 @@ MAN3= SMS::Send.3 \
SMS::Send::Driver.3 \
SMS::Send::Test.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= p5-Module-Pluggable>=2.5:${PORTSDIR}/devel/p5-Module-Pluggable
+.endif
+
+.include <bsd.port.post.mk>