aboutsummaryrefslogtreecommitdiff
path: root/comms/predict
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /comms/predict
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Notes
Diffstat (limited to 'comms/predict')
-rw-r--r--comms/predict/Makefile2
-rw-r--r--comms/predict/files/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/comms/predict/Makefile b/comms/predict/Makefile
index 86dc7810ef1f..88af5226d17d 100644
--- a/comms/predict/Makefile
+++ b/comms/predict/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
INSTALL_TARGET= install install.man
-MAKE_ENV= LIBS="${PTHREAD_LIBS}"
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
post-patch:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/predict.h > ${WRKSRC}/predict.h
diff --git a/comms/predict/files/Makefile b/comms/predict/files/Makefile
index 35b8406ed673..3385bbb71049 100644
--- a/comms/predict/files/Makefile
+++ b/comms/predict/files/Makefile
@@ -16,7 +16,7 @@ CFLAGS = -O2
default: all
all: predict vocalizer/vocalizer
-LIBS += -lm -lncurses
+LIBS = ${LDFLAGS} -pthread -lm -lncurses
predict: predict.c predict.h
${CC} ${CFLAGS} -o predict predict.c ${LIBS}