aboutsummaryrefslogtreecommitdiff
path: root/comms/py-adafruit-ampy
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2018-08-01 03:43:16 +0000
committerFukang Chen <loader@FreeBSD.org>2018-08-01 03:43:16 +0000
commit3430621a095ef76b93a1fc228aaf4746a9e5e48a (patch)
tree3e77f26b4f4397438fbc67d49a2f4d7cf0a42d06 /comms/py-adafruit-ampy
parent2640f03a8a593b465799a7b903c1c9aee8eea606 (diff)
Notes
Diffstat (limited to 'comms/py-adafruit-ampy')
-rw-r--r--comms/py-adafruit-ampy/Makefile23
-rw-r--r--comms/py-adafruit-ampy/distinfo3
-rw-r--r--comms/py-adafruit-ampy/pkg-descr4
3 files changed, 30 insertions, 0 deletions
diff --git a/comms/py-adafruit-ampy/Makefile b/comms/py-adafruit-ampy/Makefile
new file mode 100644
index 000000000000..49783740d716
--- /dev/null
+++ b/comms/py-adafruit-ampy/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= adafruit-ampy
+PORTVERSION= 1.0.5
+CATEGORIES= comms python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Adafruit MicroPython tool
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}serial>0:comms/py-serial@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-dotenv>0:www/py-python-dotenv@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/comms/py-adafruit-ampy/distinfo b/comms/py-adafruit-ampy/distinfo
new file mode 100644
index 000000000000..70034dd83c3c
--- /dev/null
+++ b/comms/py-adafruit-ampy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532874072
+SHA256 (adafruit-ampy-1.0.5.tar.gz) = 1055827874010f48c7dbd3cde4b1d7c6f6732661fad193b188a398e88961fc62
+SIZE (adafruit-ampy-1.0.5.tar.gz) = 13837
diff --git a/comms/py-adafruit-ampy/pkg-descr b/comms/py-adafruit-ampy/pkg-descr
new file mode 100644
index 000000000000..8ce4d15883e4
--- /dev/null
+++ b/comms/py-adafruit-ampy/pkg-descr
@@ -0,0 +1,4 @@
+Adafruit MicroPython Tool (ampy) - Utility to interact with
+a MicroPython board over a serial connection.
+
+WWW: https://github.com/adafruit/ampy