aboutsummaryrefslogtreecommitdiff
path: root/comms/py-libimobiledevice
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2014-09-28 22:58:51 +0000
committerAlberto Villa <avilla@FreeBSD.org>2014-09-28 22:58:51 +0000
commitc6c79da969e63a1b59f318e5e20c9a2475290bf2 (patch)
tree3519e27224702b200392e2556264193fb94f359e /comms/py-libimobiledevice
parent0393573f88dd44a26be995caa3ce8ef85916f214 (diff)
Notes
Diffstat (limited to 'comms/py-libimobiledevice')
-rw-r--r--comms/py-libimobiledevice/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/comms/py-libimobiledevice/Makefile b/comms/py-libimobiledevice/Makefile
index 5e83a99149ec..d79b799ce269 100644
--- a/comms/py-libimobiledevice/Makefile
+++ b/comms/py-libimobiledevice/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= comms python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,8 @@ BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython \
${PYTHON_SITELIBDIR}/plist.so:${PORTSDIR}/devel/py-libplist
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/plist.so:${PORTSDIR}/devel/py-libplist
-USE_PYTHON= yes
+USES= python
+CONFIGURE_ENV= PYTHON_LDFLAGS="`pkg-config --libs python-${PYTHON_VER}`"
SLAVE_PORT= yes
MASTERDIR= ${.CURDIR:H:H}/comms/libimobiledevice
@@ -20,7 +21,8 @@ PLIST= ${.CURDIR}/pkg-plist
BUILD_WRKSRC= ${WRKSRC}/cython
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-PLIST_FILES= ${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.a \
+PLIST_FILES= include/imobiledevice/cython/imobiledevice.pxd \
+ ${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.a \
${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.so
post-patch:
@@ -29,4 +31,9 @@ post-patch:
-e 's/$$(imobiledevice_la_DEPENDENCIES)//' \
${BUILD_WRKSRC}/Makefile.in
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/imobiledevice/cython
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/imobiledevice.pxd \
+ ${STAGEDIR}${PREFIX}/include/imobiledevice/cython
+
.include "${MASTERDIR}/Makefile"