aboutsummaryrefslogtreecommitdiff
path: root/comms/py-qt5-serialport
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 21:56:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 21:56:50 +0000
commit5b3f3dd953448e0ec3ddc609dbf53a005662635d (patch)
treec8ea48f297bee52a8d84f4ec84da2d9fa23078a5 /comms/py-qt5-serialport
parent7f63a1808f185107b013d2e350c33370099f37b3 (diff)
Notes
Diffstat (limited to 'comms/py-qt5-serialport')
-rw-r--r--comms/py-qt5-serialport/Makefile27
-rw-r--r--comms/py-qt5-serialport/pkg-descr4
-rw-r--r--comms/py-qt5-serialport/pkg-plist5
3 files changed, 36 insertions, 0 deletions
diff --git a/comms/py-qt5-serialport/Makefile b/comms/py-qt5-serialport/Makefile
new file mode 100644
index 000000000000..3d93efc9e90a
--- /dev/null
+++ b/comms/py-qt5-serialport/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= serialport
+CATEGORIES= comms devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtSerialPort module
+
+CONFIGURE_ARGS= --enable QtSerialPort
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run
+USE_QT5= core gui serialport qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtSerialPort API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/comms/py-qt5-serialport/pkg-descr b/comms/py-qt5-serialport/pkg-descr
new file mode 100644
index 000000000000..93e030e71c41
--- /dev/null
+++ b/comms/py-qt5-serialport/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtSerialPort module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/comms/py-qt5-serialport/pkg-plist b/comms/py-qt5-serialport/pkg-plist
new file mode 100644
index 000000000000..f486a202a68a
--- /dev/null
+++ b/comms/py-qt5-serialport/pkg-plist
@@ -0,0 +1,5 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtSerialPort.so
+%%PYQT_SIPDIR%%/QtSerialPort/QtSerialPortmod.sip
+%%PYQT_SIPDIR%%/QtSerialPort/qserialport.sip
+%%PYQT_SIPDIR%%/QtSerialPort/qserialportinfo.sip
+%%API%%share/qt5/qsci/api/python/QtSerialPort.api