aboutsummaryrefslogtreecommitdiff
path: root/comms/qpage
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
commit546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8 (patch)
tree7b9cd553a62be7a9bd52800d334be8b703eb93a1 /comms/qpage
parent01ab6da99c55af36e516b7f8016373124c4039cf (diff)
downloadports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.tar.gz
ports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.zip
As threatened on freebsd-ports: all startup scripts know about the two
options `start' and `stop' now (unless I have forgotten any). This allows us to call the scripts from /etc/rc.shutdown with the correct option. The (42 or so) ports that already DTRT before are unchanged.
Notes
Notes: svn path=/head/; revision=30229
Diffstat (limited to 'comms/qpage')
-rw-r--r--comms/qpage/Makefile5
-rw-r--r--comms/qpage/files/qpage.sh20
2 files changed, 22 insertions, 3 deletions
diff --git a/comms/qpage/Makefile b/comms/qpage/Makefile
index 2d144e0659d1..e80b620fd93f 100644
--- a/comms/qpage/Makefile
+++ b/comms/qpage/Makefile
@@ -20,9 +20,8 @@ MAN1= qpage.1
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/qpage.sh ]; then \
${ECHO} "Install ${PREFIX}/etc/rc.d/qpage.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/qpage.sh; \
- ${ECHO} "[ -x ${PREFIX}/bin/qpage ] && ${PREFIX}/bin/qpage -q10 && ${ECHO} -n ' qpage'" >> ${PREFIX}/etc/rc.d/qpage.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/qpage.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/qpage.sh \
+ ${PREFIX}/etc/rc.d/qpage.sh \
fi
.include <bsd.port.mk>
diff --git a/comms/qpage/files/qpage.sh b/comms/qpage/files/qpage.sh
new file mode 100644
index 000000000000..a183fa095842
--- /dev/null
+++ b/comms/qpage/files/qpage.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x ${PREFIX}/bin/qpage ] && ${PREFIX}/bin/qpage -q10 && echo -n ' qpage'
+ ;;
+stop)
+ killall qpage && echo -n ' qpage'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0