aboutsummaryrefslogtreecommitdiff
path: root/comms/qpage
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-05-17 22:08:09 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-05-17 22:08:09 +0000
commit87b19a362505c3a5a95a19f46fb4991196e3233d (patch)
tree324c136aa452509713b2aa870283c3735b2d3a68 /comms/qpage
parent5f6ef8da87072878f774a4ec6537870b652bd673 (diff)
downloadports-87b19a362505c3a5a95a19f46fb4991196e3233d.tar.gz
ports-87b19a362505c3a5a95a19f46fb4991196e3233d.zip
- make it run by the user uucp;
- since I'm there, create the spool directory for a port installation. PR: ports/62617 Submitted by: Mike Andrews
Notes
Notes: svn path=/head/; revision=109380
Diffstat (limited to 'comms/qpage')
-rw-r--r--comms/qpage/Makefile5
-rw-r--r--comms/qpage/files/patch-config.input13
-rw-r--r--comms/qpage/pkg-plist2
3 files changed, 16 insertions, 4 deletions
diff --git a/comms/qpage/Makefile b/comms/qpage/Makefile
index f326a3f6cf23..d13ed68c72a8 100644
--- a/comms/qpage/Makefile
+++ b/comms/qpage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qpage
PORTVERSION= 3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms
MASTER_SITES= http://www.qpage.org/download/
EXTRACT_SUFX= .tar.Z
@@ -37,5 +37,8 @@ post-install:
${INSTALL_SCRIPT} -m 640 ${WRKDIR}/${PORTNAME}-${PORTVERSION}/example.cf \
${PREFIX}/etc/qpage-example.cf; \
fi
+ ${MKDIR} /var/spool/${PORTNAME}
+ ${CHOWN} uucp:dialer /var/spool/${PORTNAME}
+ ${CHMOD} 0775 /var/spool/${PORTNAME}
.include <bsd.port.mk>
diff --git a/comms/qpage/files/patch-config.input b/comms/qpage/files/patch-config.input
index 00e48e4a485f..fb47644040ac 100644
--- a/comms/qpage/files/patch-config.input
+++ b/comms/qpage/files/patch-config.input
@@ -1,5 +1,5 @@
---- config.input.orig Sat Jan 10 00:43:26 2004
-+++ config.input Sat Jan 10 00:44:05 2004
+--- config.input.orig Thu Nov 5 07:05:36 1998
++++ config.input Mon May 17 23:14:53 2004
@@ -20,7 +20,7 @@
# See the QuickPage documentation for complete details about
# the syntax of the configuration file.
@@ -18,3 +18,12 @@
#
+@@ -51,7 +51,7 @@
+ # for that user, QuickPage will assume all group privileges
+ # assigned to that user.
+ #
+-DAEMON_USER="daemon"
++DAEMON_USER="uucp"
+
+
+ #
diff --git a/comms/qpage/pkg-plist b/comms/qpage/pkg-plist
index bcb7424270c5..6550af9a7d91 100644
--- a/comms/qpage/pkg-plist
+++ b/comms/qpage/pkg-plist
@@ -1,5 +1,5 @@
bin/qpage
etc/qpage-example.cf
etc/rc.d/qpage.sh
-@exec if [ ! -d /var/spool/qpage ]; then mkdir /var/spool/qpage; chown root:dialer /var/spool/qpage; chmod 0775 /var/spool/qpage; fi
+@exec if [ ! -d /var/spool/qpage ]; then mkdir /var/spool/qpage; chown uucp:dialer /var/spool/qpage; chmod 0775 /var/spool/qpage; fi
@unexec if [ -d /var/spool/qpage ]; then rm -rf /var/spool/qpage; fi