aboutsummaryrefslogtreecommitdiff
path: root/comms/qpage
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-28 22:03:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-28 22:03:28 +0000
commit8f15720c8451df633f2ee88bd58298c69a70342f (patch)
tree5fc8cdd209fc4f3b6b20d14559c2a313d6712202 /comms/qpage
parentf5bf8a1a6b00626f2f68c8fe25a3672ee78eef64 (diff)
downloadports-8f15720c8451df633f2ee88bd58298c69a70342f.tar.gz
ports-8f15720c8451df633f2ee88bd58298c69a70342f.zip
Notes
Diffstat (limited to 'comms/qpage')
-rw-r--r--comms/qpage/Makefile2
-rw-r--r--comms/qpage/files/patch-util.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/comms/qpage/Makefile b/comms/qpage/Makefile
index d13ed68c72a8..fa229482795b 100644
--- a/comms/qpage/Makefile
+++ b/comms/qpage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qpage
PORTVERSION= 3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms
MASTER_SITES= http://www.qpage.org/download/
EXTRACT_SUFX= .tar.Z
diff --git a/comms/qpage/files/patch-util.c b/comms/qpage/files/patch-util.c
new file mode 100644
index 000000000000..fd7e6b7ff33c
--- /dev/null
+++ b/comms/qpage/files/patch-util.c
@@ -0,0 +1,11 @@
+--- util.c.orig Sun Oct 25 20:55:11 1998
++++ util.c Thu Oct 28 23:58:37 2004
+@@ -537,7 +537,7 @@
+ ** Now make sure we didn't chop a word in the middle.
+ */
+ if (*src && end) {
+- *end++ = '\0';
++ *++end = '\0';
+ src = start;
+ }
+