aboutsummaryrefslogtreecommitdiff
path: root/comms/qt5-connectivity
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 18:10:14 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 18:10:14 +0000
commit4c67812e0161cb63098ede0c2645e53c5060ecd9 (patch)
tree66663b28c2c298161be86b00114ab18d6fad8670 /comms/qt5-connectivity
parent7b72d170ba3c89c7e408c333297d8ecfa3ba72f1 (diff)
downloadports-4c67812e0161cb63098ede0c2645e53c5060ecd9.tar.gz
ports-4c67812e0161cb63098ede0c2645e53c5060ecd9.zip
Notes
Diffstat (limited to 'comms/qt5-connectivity')
-rw-r--r--comms/qt5-connectivity/Makefile17
-rw-r--r--comms/qt5-connectivity/pkg-plist208
2 files changed, 225 insertions, 0 deletions
diff --git a/comms/qt5-connectivity/Makefile b/comms/qt5-connectivity/Makefile
new file mode 100644
index 000000000000..c504ea587f2c
--- /dev/null
+++ b/comms/qt5-connectivity/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= connectivity
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= comms
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt connectivity (Bluetooth/NFC) module
+
+USE_QT5= concurrent core qml quick buildtools_build
+QT_DIST= ${PORTNAME}
+USES= qmake
+
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+.include <bsd.port.mk>
diff --git a/comms/qt5-connectivity/pkg-plist b/comms/qt5-connectivity/pkg-plist
new file mode 100644
index 000000000000..a17a9dd25e26
--- /dev/null
+++ b/comms/qt5-connectivity/pkg-plist
@@ -0,0 +1,208 @@
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/adapter1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/adapter_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/agent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/androidbroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/bluez5_helper_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/bluez_data_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/corebluetoothwrapper_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/device1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/device_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/devicediscoverybroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/hcimanager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/inputstreamthread_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/jni_android_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/localdevicebroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/lowenergynotificationhub_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/manager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_agent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_client1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_client_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_manager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_objectpush1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_transfer1_bluez5_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/obex_transfer_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/objectmanager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtcentralmanager_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtchanneldelegate_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtconnectionmonitor_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtdeviceinquiry_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtdevicepair_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtl2capchannel_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtledeviceinquiry_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtobexsession_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtrfcommchannel_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtsdpinquiry_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtservicerecord_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtsocketlistener_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/osxbtutility_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/ppshelpers_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/profile1_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/properties_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothaddress_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdevicediscoveryagent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdevicediscoverytimer_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdeviceinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothhostinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothlocaldevice_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserver_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothservicediscoveryagent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserviceinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothsocket_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothsocket_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_bluez_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferreply_qnx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothtransferrequest_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergycontroller_osx_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergycontroller_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergyserviceprivate_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qprivatelinearbuffer_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/serveracceptancethread_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/service_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/servicediscoverybroadcastreceiver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/servicemap_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/uistrings_p.h
+%%QT_INCDIR%%/QtBluetooth/QBluetoothAddress
+%%QT_INCDIR%%/QtBluetooth/QBluetoothDeviceDiscoveryAgent
+%%QT_INCDIR%%/QtBluetooth/QBluetoothDeviceInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothHostInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothLocalDevice
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServer
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServiceDiscoveryAgent
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServiceInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothSocket
+%%QT_INCDIR%%/QtBluetooth/QBluetoothTransferManager
+%%QT_INCDIR%%/QtBluetooth/QBluetoothTransferReply
+%%QT_INCDIR%%/QtBluetooth/QBluetoothTransferRequest
+%%QT_INCDIR%%/QtBluetooth/QBluetoothUuid
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyCharacteristic
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyController
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyDescriptor
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyHandle
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyService
+%%QT_INCDIR%%/QtBluetooth/QtBluetooth
+%%QT_INCDIR%%/QtBluetooth/QtBluetoothDepends
+%%QT_INCDIR%%/QtBluetooth/QtBluetoothVersion
+%%QT_INCDIR%%/QtBluetooth/qbluetooth.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothaddress.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothdevicediscoveryagent.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothdeviceinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothglobal.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothhostinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothlocaldevice.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothserver.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothservicediscoveryagent.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothserviceinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothsocket.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothtransfermanager.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothtransferreply.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothtransferrequest.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothuuid.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergycharacteristic.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergycontroller.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergydescriptor.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergyservice.h
+%%QT_INCDIR%%/QtBluetooth/qtbluetoothversion.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/adapter_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/agent_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/dbusobjectmanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/dbusproperties_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/manager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/neard_helper_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_p_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpserver_simulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_p_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qllcpsocket_simulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qndefnfcsmartposterrecord_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qndefrecord_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_emulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_neard_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_simulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanagerimpl_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanagervirtualbase_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharemanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharemanager_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharemanagerimpl_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharetarget_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharetarget_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldsharetargetimpl_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype1_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype2_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype3_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtagtype4_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_emulator_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_neard_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_qnx_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnxnfceventfilter_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnxnfcmanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnxnfcsharemanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qtlv_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/tag_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/targetemulator_p.h
+%%QT_INCDIR%%/QtNfc/QNdefFilter
+%%QT_INCDIR%%/QtNfc/QNdefMessage
+%%QT_INCDIR%%/QtNfc/QNdefNfcIconRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcSmartPosterRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcTextRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcUriRecord
+%%QT_INCDIR%%/QtNfc/QNdefRecord
+%%QT_INCDIR%%/QtNfc/QNearFieldManager
+%%QT_INCDIR%%/QtNfc/QNearFieldShareManager
+%%QT_INCDIR%%/QtNfc/QNearFieldShareTarget
+%%QT_INCDIR%%/QtNfc/QNearFieldTarget
+%%QT_INCDIR%%/QtNfc/QQmlNdefRecord
+%%QT_INCDIR%%/QtNfc/QtNfc
+%%QT_INCDIR%%/QtNfc/QtNfcDepends
+%%QT_INCDIR%%/QtNfc/QtNfcVersion
+%%QT_INCDIR%%/QtNfc/qndeffilter.h
+%%QT_INCDIR%%/QtNfc/qndefmessage.h
+%%QT_INCDIR%%/QtNfc/qndefnfcsmartposterrecord.h
+%%QT_INCDIR%%/QtNfc/qndefnfctextrecord.h
+%%QT_INCDIR%%/QtNfc/qndefnfcurirecord.h
+%%QT_INCDIR%%/QtNfc/qndefrecord.h
+%%QT_INCDIR%%/QtNfc/qnearfieldmanager.h
+%%QT_INCDIR%%/QtNfc/qnearfieldsharemanager.h
+%%QT_INCDIR%%/QtNfc/qnearfieldsharetarget.h
+%%QT_INCDIR%%/QtNfc/qnearfieldtarget.h
+%%QT_INCDIR%%/QtNfc/qnfcglobal.h
+%%QT_INCDIR%%/QtNfc/qqmlndefrecord.h
+%%QT_INCDIR%%/QtNfc/qtnfcversion.h
+%%QT_LIBDIR%%/cmake/Qt5Bluetooth/Qt5BluetoothConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5Bluetooth/Qt5BluetoothConfigVersion.cmake
+%%QT_LIBDIR%%/cmake/Qt5Nfc/Qt5NfcConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5Nfc/Qt5NfcConfigVersion.cmake
+%%QT_LIBDIR%%/libQt5Bluetooth.prl
+%%QT_LIBDIR%%/libQt5Bluetooth.so
+%%QT_LIBDIR%%/libQt5Bluetooth.so.5
+%%QT_LIBDIR%%/libQt5Bluetooth.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5Bluetooth.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5Bluetooth.so.%%FULLVER%%.debug
+%%QT_LIBDIR%%/libQt5Nfc.prl
+%%QT_LIBDIR%%/libQt5Nfc.so
+%%QT_LIBDIR%%/libQt5Nfc.so.5
+%%QT_LIBDIR%%/libQt5Nfc.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5Nfc.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5Nfc.so.%%FULLVER%%.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_bluetooth.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_bluetooth_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_nfc.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_nfc_private.pri
+%%QT_QMLDIR%%/QtBluetooth/libdeclarative_bluetooth.so
+%%DEBUG%%%%QT_QMLDIR%%/QtBluetooth/libdeclarative_bluetooth.so.debug
+%%QT_QMLDIR%%/QtBluetooth/plugins.qmltypes
+%%QT_QMLDIR%%/QtBluetooth/qmldir
+%%QT_QMLDIR%%/QtNfc/libdeclarative_nfc.so
+%%DEBUG%%%%QT_QMLDIR%%/QtNfc/libdeclarative_nfc.so.debug
+%%QT_QMLDIR%%/QtNfc/plugins.qmltypes
+%%QT_QMLDIR%%/QtNfc/qmldir
+libdata/pkgconfig/Qt5Bluetooth.pc
+libdata/pkgconfig/Qt5Nfc.pc