aboutsummaryrefslogtreecommitdiff
path: root/comms/qt5-serialbus/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-09-17 09:46:54 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-09-17 09:46:54 +0000
commit3346021972b58ae3975cf109e41beb4d895dd577 (patch)
treeff6682b425056cf66ba4ca415211efb1b19cc258 /comms/qt5-serialbus/Makefile
parentd0e47e76ab45dc3eadf4c50d94669a800e87fe10 (diff)
Notes
Diffstat (limited to 'comms/qt5-serialbus/Makefile')
-rw-r--r--comms/qt5-serialbus/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/comms/qt5-serialbus/Makefile b/comms/qt5-serialbus/Makefile
new file mode 100644
index 000000000000..0cd26dbe8882
--- /dev/null
+++ b/comms/qt5-serialbus/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= serialbus
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= comms
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt functions to access industrial bus systems
+
+USE_QT5= core network serialport buildtools_build
+QT_DIST= serialbus
+USES= compiler:c++11-lib qmake
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+BUILD_WRKSRC= ${WRKSRC}/src/serialbus
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+.include <bsd.port.mk>