aboutsummaryrefslogtreecommitdiff
path: root/comms/qtel
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2015-01-07 12:16:26 +0000
committerStephen Hurd <shurd@FreeBSD.org>2015-01-07 12:16:26 +0000
commitee249a75ee54b36e22ebc3a16f626e7db6d13f34 (patch)
tree83ab7b07a849aa6f83d6d2ece12119a79d8aae73 /comms/qtel
parent7d6f65abc1d861601be2d689192c0faaff02b662 (diff)
downloadports-ee249a75ee54b36e22ebc3a16f626e7db6d13f34.tar.gz
ports-ee249a75ee54b36e22ebc3a16f626e7db6d13f34.zip
Notes
Diffstat (limited to 'comms/qtel')
-rw-r--r--comms/qtel/Makefile19
-rw-r--r--comms/qtel/pkg-descr4
-rw-r--r--comms/qtel/pkg-plist21
3 files changed, 44 insertions, 0 deletions
diff --git a/comms/qtel/Makefile b/comms/qtel/Makefile
new file mode 100644
index 000000000000..315b07bd0675
--- /dev/null
+++ b/comms/qtel/Makefile
@@ -0,0 +1,19 @@
+# Created by: shurd
+# $FreeBSD$
+
+PORTNAME= qtel
+
+MAINTAINER= hamradio@freebsd.org
+COMMENT= Qtel Echolink client
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libecholib.so:${PORTSDIR}/comms/svxlink
+
+MASTERDIR= ${.CURDIR}/../svxlink
+USE_QT4= corelib gui network qmake_build linguist_build moc_build rcc_build uic_build
+PKGDIR= ${.CURDIR}
+CMAKE_ARGS+= -DUSE_QT:BOOL=YES \
+ -DQT_ONLY:BOOL=YES
+
+.include "${MASTERDIR}/Makefile"
diff --git a/comms/qtel/pkg-descr b/comms/qtel/pkg-descr
new file mode 100644
index 000000000000..8f115627b7e6
--- /dev/null
+++ b/comms/qtel/pkg-descr
@@ -0,0 +1,4 @@
+Qtel, the Qt EchoLink client, is a graphical application used to access the
+EchoLink network.
+
+WWW: http://www.svxlink.org/
diff --git a/comms/qtel/pkg-plist b/comms/qtel/pkg-plist
new file mode 100644
index 000000000000..103fc47a269e
--- /dev/null
+++ b/comms/qtel/pkg-plist
@@ -0,0 +1,21 @@
+bin/qtel
+include/svxlink/AsyncQtApplication.h
+%%STATIC%%lib/libasyncqt.a
+lib/libasyncqt.so.1.3.0
+lib/libasyncqt.so.1.3
+lib/libasyncqt.so
+share/applications/qtel.desktop
+share/qtel/translations/qtel_sv.qm
+share/qtel/translations/qtel_de.qm
+share/qtel/translations/qtel_tr.qm
+share/qtel/translations/qtel_nl.qm
+share/qtel/translations/qtel_it.qm
+share/qtel/translations/qtel_uk.qm
+share/qtel/translations/qtel_ru.qm
+share/qtel/translations/qtel_hu.qm
+share/qtel/translations/qtel_es.qm
+share/qtel/translations/qtel_ja.qm
+share/qtel/translations/qtel_fr.qm
+share/qtel/sounds/connect.raw
+share/icons/link.xpm
+man/man1/qtel.1.gz