aboutsummaryrefslogtreecommitdiff
path: root/comms/quisk/files
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2015-11-27 20:57:14 +0000
committerStephen Hurd <shurd@FreeBSD.org>2015-11-27 20:57:14 +0000
commite31189f2d862356f0d6c920e7c4ad13e2ae56df3 (patch)
tree887d38769b81a35be22d756b3e91168c60fd5bfc /comms/quisk/files
parentc2df85f0fe704014b1b9f857c8031cf49d1b68d9 (diff)
downloadports-e31189f2d862356f0d6c920e7c4ad13e2ae56df3.tar.gz
ports-e31189f2d862356f0d6c920e7c4ad13e2ae56df3.zip
Notes
Diffstat (limited to 'comms/quisk/files')
-rw-r--r--comms/quisk/files/patch-microphone.c11
-rw-r--r--comms/quisk/files/patch-setup.py8
2 files changed, 15 insertions, 4 deletions
diff --git a/comms/quisk/files/patch-microphone.c b/comms/quisk/files/patch-microphone.c
new file mode 100644
index 000000000000..a08ad2fafb31
--- /dev/null
+++ b/comms/quisk/files/patch-microphone.c
@@ -0,0 +1,11 @@
+--- microphone.c.orig 2015-11-27 20:43:24 UTC
++++ microphone.c
+@@ -56,7 +56,7 @@ static int timeVOX = 2000; // VOX han
+
+ static int doTxCorrect = 0; // Corrections for UDP sample transmit
+ static double TxCorrectLevel;
+-static complex TxCorrectDc;
++static complex double TxCorrectDc;
+
+ // Used for the Hermes protocol
+ #define HERMES_TX_BUF_SAMPLES 4800
diff --git a/comms/quisk/files/patch-setup.py b/comms/quisk/files/patch-setup.py
index 28fda8441342..69b0eaa4527f 100644
--- a/comms/quisk/files/patch-setup.py
+++ b/comms/quisk/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2014-06-01 15:30:01.000000000 -0700
-+++ setup.py 2014-06-01 15:31:15.000000000 -0700
-@@ -11,8 +11,8 @@
+--- setup.py.orig 2015-11-27 20:41:34 UTC
++++ setup.py
+@@ -12,8 +12,8 @@ fp.write("#QUISK version %s\n" % Version
fp.close()
module1 = Extension ('quisk._quisk',
@@ -8,6 +8,6 @@
- #library_dirs = ['.'],
+ include_dirs = ['%%LOCALBASE%%/include/portaudio2', '%%LOCALBASE%%/include'],
+ library_dirs = ['%%LOCALBASE%%/lib/portaudio2', '%%LOCALBASE%%/lib'],
- libraries = ['asound', 'portaudio', 'pulse-simple', 'fftw3', 'm'],
+ libraries = ['asound', 'portaudio', 'pulse', 'fftw3', 'm'],
sources = ['quisk.c', 'sound.c', 'sound_alsa.c', 'sound_portaudio.c', 'sound_pulseaudio.c',
'is_key_down.c', 'microphone.c', 'utility.c',