aboutsummaryrefslogtreecommitdiff
path: root/comms/quisk
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-07-03 20:55:19 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-07-03 20:55:19 +0000
commit6254c184d8139e1f88066a25e900804fda28c69d (patch)
tree815ad55eab37a22bffedbeeb74221765da223e31 /comms/quisk
parent676d8be6aed3fb576d2835e6dbb2c6fbf7423a54 (diff)
downloadports-6254c184d8139e1f88066a25e900804fda28c69d.tar.gz
ports-6254c184d8139e1f88066a25e900804fda28c69d.zip
This is QUISK, a Software Defined Radio (SDR).
- Quisk can control the HiQSDR. - As a receiver it can use the SDR-IQ by RfSpace as a sample source. - As a receiver it can use your soundcard as a sample source. - Quisk can control SoftRock hardware for both receive and transmit. - As a transmitter it can accept microphone input and send that to your transmitter for SSB operation. For CW, QUISK can mute the audio and substitute a side tone. PR: ports/190366 Submitted by: Stephen Hurd <shurd@FreeBSD.org> Reviewed by: db, skreuzer Approved by: db, skreuzer (mentors) Differential Revision: https://phabric.freebsd.org/D301
Notes
Notes: svn path=/head/; revision=360456
Diffstat (limited to 'comms/quisk')
-rw-r--r--comms/quisk/Makefile34
-rw-r--r--comms/quisk/distinfo2
-rw-r--r--comms/quisk/files/patch-quisk.c11
-rw-r--r--comms/quisk/files/patch-setup.py13
-rw-r--r--comms/quisk/pkg-descr10
5 files changed, 70 insertions, 0 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
new file mode 100644
index 000000000000..5fc2187afdf5
--- /dev/null
+++ b/comms/quisk/Makefile
@@ -0,0 +1,34 @@
+# Created by: Stephen Hurd <shurd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= quisk
+PORTVERSION= 3.6.18
+CATEGORIES= comms hamradio
+MASTER_SITES= http://james.ahlstrom.name/quisk/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR=shurd
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= A Software Defined Radio (SDR)
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
+ portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2 \
+ libasound.so:${PORTSDIR}/audio/alsa-lib \
+ libpulse.so:${PORTSDIR}/audio/pulseaudio
+
+USE_PYTHON= 2.7+
+USE_WX= 2.8+
+WANT_UNICODE= yes
+WX_COMPS= python
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+post-extract:
+ ${RM} ${WRKSRC}/_quisk.so ${WRKSRC}/sdriqpkg/sdriq.so
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/comms/quisk/distinfo b/comms/quisk/distinfo
new file mode 100644
index 000000000000..312d3253d350
--- /dev/null
+++ b/comms/quisk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (quisk-3.6.18.tar.gz) = 851e13193ed43ea992345f438b34ae968e0ed5e44c6635a6e4503459932cdce8
+SIZE (quisk-3.6.18.tar.gz) = 1106206
diff --git a/comms/quisk/files/patch-quisk.c b/comms/quisk/files/patch-quisk.c
new file mode 100644
index 000000000000..25344a07f5d7
--- /dev/null
+++ b/comms/quisk/files/patch-quisk.c
@@ -0,0 +1,11 @@
+--- quisk.c.orig 2014-06-28 19:10:12.000000000 -0700
++++ quisk.c 2014-06-28 19:10:48.000000000 -0700
+@@ -1156,7 +1156,7 @@
+ if (filter_bandwidth < 19000) { // No filtering for wide bandwidth
+ for (i = 0; i < nSamples; i++)
+ cSamples[i] = dRxFilterOut(cSamples[i], bank);
+- measure_audio_sum += cSamples[i] * conj(cSamples[i]);
++ measure_audio_sum = measure_audio_sum + cSamples[i] * conj(cSamples[i]);
+ measure_audio_count += 1;
+ }
+ break;
diff --git a/comms/quisk/files/patch-setup.py b/comms/quisk/files/patch-setup.py
new file mode 100644
index 000000000000..28fda8441342
--- /dev/null
+++ b/comms/quisk/files/patch-setup.py
@@ -0,0 +1,13 @@
+--- setup.py.orig 2014-06-01 15:30:01.000000000 -0700
++++ setup.py 2014-06-01 15:31:15.000000000 -0700
+@@ -11,8 +11,8 @@
+ fp.close()
+
+ module1 = Extension ('quisk._quisk',
+- #include_dirs = ['.'],
+- #library_dirs = ['.'],
++ include_dirs = ['%%LOCALBASE%%/include/portaudio2', '%%LOCALBASE%%/include'],
++ library_dirs = ['%%LOCALBASE%%/lib/portaudio2', '%%LOCALBASE%%/lib'],
+ libraries = ['asound', 'portaudio', 'pulse-simple', 'fftw3', 'm'],
+ sources = ['quisk.c', 'sound.c', 'sound_alsa.c', 'sound_portaudio.c', 'sound_pulseaudio.c',
+ 'is_key_down.c', 'microphone.c', 'utility.c',
diff --git a/comms/quisk/pkg-descr b/comms/quisk/pkg-descr
new file mode 100644
index 000000000000..d8b2f8c59bc6
--- /dev/null
+++ b/comms/quisk/pkg-descr
@@ -0,0 +1,10 @@
+This is QUISK, a Software Defined Radio (SDR).
+- Quisk can control the HiQSDR.
+- As a receiver it can use the SDR-IQ by RfSpace as a sample source.
+- As a receiver it can use your soundcard as a sample source.
+- Quisk can control SoftRock hardware for both receive and transmit.
+- As a transmitter it can accept microphone input and send that to your
+ transmitter for SSB operation. For CW, QUISK can mute the audio and
+ substitute a side tone.
+
+WWW: http://james.ahlstrom.name/quisk/