aboutsummaryrefslogtreecommitdiff
path: root/comms/quisk
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2018-06-11 22:21:07 +0000
committerStephen Hurd <shurd@FreeBSD.org>2018-06-11 22:21:07 +0000
commit2ef692847aef25d07a254da2ed3e5a7b3cb7e0b6 (patch)
tree8b69ff4f69fbdefa6ec5eb8cc58551a2fecb3592 /comms/quisk
parentcb246f1b243468f5b8eebc81e1cad3d1cbc9e5aa (diff)
downloadports-2ef692847aef25d07a254da2ed3e5a7b3cb7e0b6.tar.gz
ports-2ef692847aef25d07a254da2ed3e5a7b3cb7e0b6.zip
Notes
Diffstat (limited to 'comms/quisk')
-rw-r--r--comms/quisk/Makefile1
-rw-r--r--comms/quisk/files/patch-quisk.py14
2 files changed, 15 insertions, 0 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index 72564435277e..38094301957f 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -3,6 +3,7 @@
PORTNAME= quisk
PORTVERSION= 4.1.3
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://james.ahlstrom.name/quisk/ \
LOCAL/db
diff --git a/comms/quisk/files/patch-quisk.py b/comms/quisk/files/patch-quisk.py
new file mode 100644
index 000000000000..848c18844c60
--- /dev/null
+++ b/comms/quisk/files/patch-quisk.py
@@ -0,0 +1,14 @@
+--- quisk.py.orig 2018-06-11 21:58:22 UTC
++++ quisk.py
+@@ -21,6 +21,11 @@ os.chdir(os.path.normpath(os.path.dirnam
+ if sys.path[0] != "'.'": # Make sure the current working directory is on path
+ sys.path.insert(0, '.')
+
++# Hack to ensure unicode is available.
++import locale
++if locale.nl_langinfo(locale.CODESET) == 'US-ASCII':
++ locale.setlocale(locale.LC_ALL, 'en_US.UTF-8')
++
+ import wxversion # Thanks to Mario, DH5YM
+ wxversion.ensureMinimal('2.8')
+