aboutsummaryrefslogtreecommitdiff
path: root/comms/scmxx/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-11-21 19:13:49 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-11-21 19:13:49 +0000
commitfac16aaf89d26ff603a2a30014ff768d354e3521 (patch)
tree11b8e8393b631fb109026af0a5977ffb1622f053 /comms/scmxx/Makefile
parenta908358dcadafe53e61d3a38f5a8676eee6ae3ad (diff)
downloadports-fac16aaf89d26ff603a2a30014ff768d354e3521.tar.gz
ports-fac16aaf89d26ff603a2a30014ff768d354e3521.zip
Notes
Diffstat (limited to 'comms/scmxx/Makefile')
-rw-r--r--comms/scmxx/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/comms/scmxx/Makefile b/comms/scmxx/Makefile
index 36d527f038fe..b98c5b01a5d1 100644
--- a/comms/scmxx/Makefile
+++ b/comms/scmxx/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= scmxx
-PORTVERSION= 0.6.1.6
+PORTVERSION= 0.6.3.1
CATEGORIES= comms
MASTER_SITES= http://ma2geo.mathematik.uni-karlsruhe.de/~hendrik/scmxx/download/
MAINTAINER= janos.mohacsi@bsd.hu
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ iconv.3:${PORTSDIR}/converters/libiconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
MAN1= scmxx.1
@@ -27,7 +30,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
-.for file in phonebook sms vCalendar
+.for file in phonebook sms.txt vCalendar.vcs vCard.vcf
${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
.endfor
.endif