aboutsummaryrefslogtreecommitdiff
path: root/comms/smstools3
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-06-15 08:13:38 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-06-15 08:13:38 +0000
commit6203b5885e087262c475215815accbb2e478410a (patch)
treeb84e58fa0810133b26aa0f40c17589dca7688358 /comms/smstools3
parentcd9ef434396beb21cfa73b776446e8deb8e1992b (diff)
downloadports-6203b5885e087262c475215815accbb2e478410a.tar.gz
ports-6203b5885e087262c475215815accbb2e478410a.zip
Notes
Diffstat (limited to 'comms/smstools3')
-rw-r--r--comms/smstools3/Makefile23
-rw-r--r--comms/smstools3/distinfo6
-rw-r--r--comms/smstools3/files/patch-Makefile9
-rw-r--r--comms/smstools3/files/patch-install.sh6
-rw-r--r--comms/smstools3/files/patch-src-Makefile19
-rw-r--r--comms/smstools3/files/patch-src_smsd_cfg.c20
-rw-r--r--comms/smstools3/pkg-plist10
7 files changed, 47 insertions, 46 deletions
diff --git a/comms/smstools3/Makefile b/comms/smstools3/Makefile
index 88aa436b8bdf..38366e81da46 100644
--- a/comms/smstools3/Makefile
+++ b/comms/smstools3/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= smstools
-PORTVERSION= 3.1.3
-PORTREVISION= 1
+PORTVERSION= 3.1.5
CATEGORIES= comms
MASTER_SITES= http://smstools3.kekekasvi.com/packages/
DISTNAME= smstools3-${PORTVERSION}
@@ -32,19 +31,17 @@ SUB_LIST+= SPOOLDIR="${SPOOLDIR}" LOGDIR="${LOGDIR}" PIDDIR="${PIDDIR}" \
PLIST_SUB+= SPOOLDIR="${SPOOLDIR}" LOGDIR="${LOGDIR}" PIDDIR="${PIDDIR}" \
SMSD_USER="${SMSD_USER}" SMSD_GROUP="${SMSD_GROUP}"
-DOCS= alarmhandler.html blacklist.html book.html compiling.html \
- configure.html configure2.html costs.html eventhandler.html \
- faq.html fileformat.html gpl.html gpl_de.html \
- hardwarecomp.html history3.html index.html license.html \
- links.html localizing.html references.html run.html \
- softwarecomp.html statformat.html statusmonitor.html \
- support.gif support.html udh.html windows.html
+DOCS= blacklist.html book.html compiling.html \
+ configure.html configure2.html eventhandler.html \
+ faq.html fileformat.html gpl.html hardwarecomp.html \
+ history3.html index.html license.html localizing.html \
+ run.html statusmonitor.html udh.html windows.html
SLIDESHOW= blacklist.gif eventhandler.gif logfile.gif modem.gif \
move_l.gif move_r.gif page1.html page2.html page2.jpg \
page2b.html page3.html page4.html page5.html page6.html \
page7.html page8.html queue.gif sms.gif smstools3-small.jpg \
- statistic.gif status.gif support.gif
+ statistic.gif status.gif
EXAMPLES= .procmailrc .qmailrc language-ISO-8859-15.fi \
language-UTF-8.fi operator_logo1.sms operator_logo2.sms \
@@ -63,12 +60,12 @@ SCRIPTS= checkhandler-utf-8 email2sms eventhandler-utf-8 forwardsms \
LIB_DEPENDS+= mm.14:${PORTSDIR}/devel/mm
CFLAGS+= -I${LOCALBASE}/include
.else
-CFLAGS+= -D NOSTATS
+CFLAGS+= -DNOSTATS
.endif
post-patch:
- @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/install.sh \
- ${WRKSRC}/src/smsd_cfg.c
+ @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile \
+ ${WRKSRC}/install.sh ${WRKSRC}/src/smsd_cfg.c
@${REINPLACE_CMD} 's|/dev/ttyS0|/dev/cuad0|g' \
${WRKSRC}/examples/smsd.conf.easy \
${WRKSRC}/examples/smsd.conf.full \
diff --git a/comms/smstools3/distinfo b/comms/smstools3/distinfo
index 82d0f79f6522..c6d6a51166fc 100644
--- a/comms/smstools3/distinfo
+++ b/comms/smstools3/distinfo
@@ -1,3 +1,3 @@
-MD5 (smstools3-3.1.3.tar.gz) = bfec9dc1f8ae37fd5b189676f60c657c
-SHA256 (smstools3-3.1.3.tar.gz) = 8449ad90db36f0d33ffb0c40e4f7780199278b27de34b7c4ba28ab389c42859a
-SIZE (smstools3-3.1.3.tar.gz) = 234065
+MD5 (smstools3-3.1.5.tar.gz) = dbdb21ba3f58ebdecc9e1d356a01a72c
+SHA256 (smstools3-3.1.5.tar.gz) = 8c403e9ce46d37e33019ac4ebe8c446df54a3a954c334f252621b1c68f6dc056
+SIZE (smstools3-3.1.5.tar.gz) = 251255
diff --git a/comms/smstools3/files/patch-Makefile b/comms/smstools3/files/patch-Makefile
index 4a06161c0298..88fa1883bfae 100644
--- a/comms/smstools3/files/patch-Makefile
+++ b/comms/smstools3/files/patch-Makefile
@@ -1,6 +1,11 @@
--- Makefile.orig 2007-04-22 13:42:22.000000000 +0200
-+++ Makefile 2008-05-17 14:45:59.000000000 +0200
-@@ -6,17 +6,17 @@
++++ Makefile 2009-06-15 09:28:29.000000000 +0200
+@@ -2,21 +2,21 @@
+
+ # If you change destination of executables, remember to change
+ # startup script (init.d/sms3) too.
+-BINDIR=/usr/local/bin
++BINDIR=%%PREFIX%%/bin
VERSION=$(shell grep package_version src/version.h | cut -f2)
diff --git a/comms/smstools3/files/patch-install.sh b/comms/smstools3/files/patch-install.sh
index 607cefb5a788..18a117ccbb3c 100644
--- a/comms/smstools3/files/patch-install.sh
+++ b/comms/smstools3/files/patch-install.sh
@@ -5,7 +5,7 @@
BINDIR=$1
if [ -z "$BINDIR" ]; then
- BINDIR=/usr/local/bin
-+ BINDIR=/usr/local
++ BINDIR=%%PREFIX%%/bin
fi
makepath()
@@ -21,7 +21,7 @@
-
echo "Installing config file"
-copy examples/smsd.conf.easy /etc/smsd.conf
-+copy examples/smsd.conf.easy /usr/local/etc/smsd.conf
++copy examples/smsd.conf.easy %%PREFIX%%/etc/smsd.conf
echo "Creating minimum spool directories"
makedir /var/spool
@@ -48,4 +48,4 @@
- echo "You have installed executables to $BINDIR,"
- echo "you should manually edit $SMS3SCRIPT script."
-fi
-+echo 'Please dont forget to edit /usr/local/etc/smsd.conf.'
++echo 'Please dont forget to edit %%PREFIX%%/etc/smsd.conf.'
diff --git a/comms/smstools3/files/patch-src-Makefile b/comms/smstools3/files/patch-src-Makefile
index 6f6d7ab1fd2f..3f95d2bdf98c 100644
--- a/comms/smstools3/files/patch-src-Makefile
+++ b/comms/smstools3/files/patch-src-Makefile
@@ -1,6 +1,15 @@
---- src/Makefile.orig 2008-11-21 11:41:21.000000000 +0100
-+++ src/Makefile 2008-11-21 11:42:39.000000000 +0100
-@@ -6,7 +6,7 @@
+--- src/Makefile.orig 2009-06-01 13:53:29.000000000 +0200
++++ src/Makefile 2009-06-15 08:59:05.000000000 +0200
+@@ -1,7 +1,7 @@
+ # In case of windows, use os_cygwin=yes setting in the configuration file (smsd.conf).
+
+ # Select your setup size:
+-CFLAGS = -D NUMBER_OF_MODEMS=64
++CFLAGS += -DNUMBER_OF_MODEMS=64
+
+ # Uncomment for Solaris
+ # CFLAGS += -D SOLARIS
+@@ -9,7 +9,7 @@
# CC=gcc
# Comment this out, to enable statistics
@@ -9,12 +18,12 @@
# Uncomment this to force smsd to run in terminal mode
#CFLAGS += -D TERMINAL
-@@ -24,7 +24,7 @@
+@@ -31,7 +31,7 @@
ifneq (,$(findstring NOSTATS,$(CFLAGS)))
$(CC) $(CFLAGS) -o $@ $^
else
- $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs`
+ $(CC) `$(LOCALBASE)/bin/mm-config --cflags` $(CFLAGS) -o $@ $^ `$(LOCALBASE)/bin/mm-config --ldflags --libs`
- @echo "(Please ignore warning about tempnam -- it is used in a safe way)"
endif
+ clean:
diff --git a/comms/smstools3/files/patch-src_smsd_cfg.c b/comms/smstools3/files/patch-src_smsd_cfg.c
index df03fec70086..25346ba0388f 100644
--- a/comms/smstools3/files/patch-src_smsd_cfg.c
+++ b/comms/smstools3/files/patch-src_smsd_cfg.c
@@ -1,20 +1,20 @@
---- src/smsd_cfg.c Fri Apr 21 11:25:01 2006
-+++ src/smsd_cfg.c Fri Apr 21 11:27:51 2006
-@@ -387,7 +387,7 @@
- printf(" -h this help\n");
- printf(" -s display status monitor\n");
+--- src/smsd_cfg.c.orig 2009-06-01 12:58:10.000000000 +0200
++++ src/smsd_cfg.c 2009-06-15 09:11:18.000000000 +0200
+@@ -1449,7 +1449,7 @@
+ printf(" -t run smsd in terminal\n");
+ printf(" -C Communicate with device\n\n");
printf(" -V print copyright and version\n\n");
- printf("All other options are set by the file /etc/smsd.conf.\n\n");
+ printf("All other options are set by the file %%PREFIX%%/etc/smsd.conf.\n\n");
printf("Output is written to stdout, errors are written to stderr.\n\n");
exit(0);
}
-@@ -395,7 +395,7 @@
- void parsearguments(int argc,char** argv)
- {
+@@ -1459,7 +1459,7 @@
int result;
+ int i;
+
- strcpy(configfile,"/etc/smsd.conf");
+ strcpy(configfile,"%%PREFIX%%/etc/smsd.conf");
printstatus=0;
-
- do
+ arg_infofile[0] = 0;
+ arg_pidfile[0] = 0;
diff --git a/comms/smstools3/pkg-plist b/comms/smstools3/pkg-plist
index b5fe3c342db3..f00c75d2030e 100644
--- a/comms/smstools3/pkg-plist
+++ b/comms/smstools3/pkg-plist
@@ -25,25 +25,20 @@ bin/unicode2sms
@unexec if [ -f %D/etc/smsd.conf ] && cmp -s %D/etc/smsd.conf %D/etc/smsd.conf.sample; then rm -f %D/etc/smsd.conf; fi
etc/smsd.conf.sample
@exec if [ ! -f %D/etc/smsd.conf ] ; then cp -p %D/%F %B/smsd.conf; fi
-%%PORTDOCS%%%%DOCSDIR%%/alarmhandler.html
%%PORTDOCS%%%%DOCSDIR%%/blacklist.html
%%PORTDOCS%%%%DOCSDIR%%/book.html
%%PORTDOCS%%%%DOCSDIR%%/compiling.html
%%PORTDOCS%%%%DOCSDIR%%/configure.html
%%PORTDOCS%%%%DOCSDIR%%/configure2.html
-%%PORTDOCS%%%%DOCSDIR%%/costs.html
%%PORTDOCS%%%%DOCSDIR%%/eventhandler.html
%%PORTDOCS%%%%DOCSDIR%%/faq.html
%%PORTDOCS%%%%DOCSDIR%%/fileformat.html
%%PORTDOCS%%%%DOCSDIR%%/gpl.html
-%%PORTDOCS%%%%DOCSDIR%%/gpl_de.html
%%PORTDOCS%%%%DOCSDIR%%/hardwarecomp.html
%%PORTDOCS%%%%DOCSDIR%%/history3.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/license.html
-%%PORTDOCS%%%%DOCSDIR%%/links.html
%%PORTDOCS%%%%DOCSDIR%%/localizing.html
-%%PORTDOCS%%%%DOCSDIR%%/references.html
%%PORTDOCS%%%%DOCSDIR%%/run.html
%%PORTDOCS%%%%DOCSDIR%%/slideshow/blacklist.gif
%%PORTDOCS%%%%DOCSDIR%%/slideshow/eventhandler.gif
@@ -66,12 +61,7 @@ etc/smsd.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/slideshow/smstools3-small.jpg
%%PORTDOCS%%%%DOCSDIR%%/slideshow/statistic.gif
%%PORTDOCS%%%%DOCSDIR%%/slideshow/status.gif
-%%PORTDOCS%%%%DOCSDIR%%/slideshow/support.gif
-%%PORTDOCS%%%%DOCSDIR%%/softwarecomp.html
-%%PORTDOCS%%%%DOCSDIR%%/statformat.html
%%PORTDOCS%%%%DOCSDIR%%/statusmonitor.html
-%%PORTDOCS%%%%DOCSDIR%%/support.gif
-%%PORTDOCS%%%%DOCSDIR%%/support.html
%%PORTDOCS%%%%DOCSDIR%%/udh.html
%%PORTDOCS%%%%DOCSDIR%%/windows.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.procmailrc