aboutsummaryrefslogtreecommitdiff
path: root/comms/smstools
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-25 12:54:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-25 12:54:10 +0000
commit887363be265fe049b2c46e3eb64500c9921bb037 (patch)
tree8dcb0b0ef0d4eb6cd57a429513a305e652937efe /comms/smstools
parent63f0c6e0dac2fcbbe10611aea9b832fecb557b67 (diff)
downloadports-887363be265fe049b2c46e3eb64500c9921bb037.tar.gz
ports-887363be265fe049b2c46e3eb64500c9921bb037.zip
Notes
Diffstat (limited to 'comms/smstools')
-rw-r--r--comms/smstools/Makefile10
-rw-r--r--comms/smstools/files/patch-bin_sms48
-rw-r--r--comms/smstools/files/patch-install.sub35
-rw-r--r--comms/smstools/pkg-plist3
4 files changed, 2 insertions, 94 deletions
diff --git a/comms/smstools/Makefile b/comms/smstools/Makefile
index 6038a836e8ca..16358199b5c7 100644
--- a/comms/smstools/Makefile
+++ b/comms/smstools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smstools
PORTVERSION= 2.0.7
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.meinemullemaus.de/software/smstools/packages/
@@ -18,19 +19,12 @@ LIB_DEPENDS= mm:${PORTSDIR}/devel/mm
WRKSRC= ${WRKDIR}/smstools
USE_GMAKE= yes
USE_RC_SUBR= smsd.sh
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} \
- EXAMPLESDIR=${EXAMPLESDIR}
post-patch:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/smsd.sh.in > ${WRKDIR}/smsd.sh
- @${REINPLACE_CMD} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ @${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/src/smsd_cfg.c \
${WRKSRC}/install.sh \
${WRKSRC}/examples/smsd.conf.easy \
${WRKSRC}/examples/smsd.conf.full
-post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/smsd.sh ${PREFIX}/etc/rc.d/smsd.sh
-
.include <bsd.port.mk>
diff --git a/comms/smstools/files/patch-bin_sms b/comms/smstools/files/patch-bin_sms
deleted file mode 100644
index c88a529e85fb..000000000000
--- a/comms/smstools/files/patch-bin_sms
+++ /dev/null
@@ -1,48 +0,0 @@
---- bin/sms.orig Thu Jan 30 05:31:18 2003
-+++ bin/sms Mon Feb 20 12:39:53 2006
-@@ -1,21 +1,26 @@
--#! /bin/sh
--# This script can be used to start/stop smsd
--# as a daemon in Linux and Solaris.
-+#!/bin/sh
-+#
-+# $FreeBSD$
-+#
-+# PROVIDE: smsd
-+# REQUIRE: DAEMON
-+#
-+# Add the following line to %%PREFIX%%/etc/rc.conf to enable smsd:
-+#
-+# smsd_enable="YES"
-+#
-+smsd_enable=${smsd_enable-"NO"}
-+smsd_flags=${smsd_flags-""}
-
--case "$1" in
-- start)
-- find /var/spool/sms -name '*.LOCK' -exec rm {} \;
-- /usr/local/bin/smsd &
-- ;;
-- stop)
-- pkill smsd
-- ;;
-- restart|reload)
-- $0 stop
-- $0 start
-- ;;
-- *)
-- echo "Usage: $0 {start|stop|restart}"
-- exit 1
--esac
-+. /etc/rc.subr
-+
-+name=smsd
-+rcvar=`set_rcvar`
-+
-+command="find /var/spool/sms -name '*.LOCK' -exec rm {} \; %%PREFIX%%/sbin/${name}"
-+pidfile=/var/run/${name}.pid
-+sig_stop=-KILL
-+
-+load_rc_config ${name}
-+run_rc_command "$1"
-
diff --git a/comms/smstools/files/patch-install.sub b/comms/smstools/files/patch-install.sub
deleted file mode 100644
index 942fb73a02ac..000000000000
--- a/comms/smstools/files/patch-install.sub
+++ /dev/null
@@ -1,35 +0,0 @@
---- install.sub.orig Wed Apr 21 17:37:00 2004
-+++ install.sub Fri Jul 22 11:51:41 2005
-@@ -15,19 +15,22 @@
- exit 1
- fi
- echo "Installing"
--cp bin/smsd* bin/getsms* bin/putsms* /usr/local/bin
--copy bin/smsevent /usr/local/bin/smsevent
--copy bin/mysmsd /usr/local/bin/mysmsd
--copy bin/email2sms /usr/local/bin/email2sms
--copy bin/sendsms /usr/local/bin/sendsms
--copy bin/smsresend /usr/local/bin/smsresend
--copy examples/smsd.conf.easy /etc/smsd.conf
--[ -d /etc/init.d ] && copy bin/sms /etc/init.d/sms
--[ -d /sbin/init.d ] && copy bin/sms /sbin/init.d/sms
-+cp bin/smsd* bin/getsms* bin/putsms* %%PREFIX%%/bin
-+copy bin/smsevent %%PREFIX%%/bin/smsevent
-+copy bin/mysmsd %%PREFIX%%/bin/mysmsd
-+copy bin/email2sms %%PREFIX%%/bin/email2sms
-+copy bin/sendsms %%PREFIX%%/bin/sendsms
-+copy bin/smsresend %%PREFIX%%/bin/smsresend
-+copy examples/smsd.conf.easy %%PREFIX%%/etc/smsd.conf
-+rm examples/.qmailrc
-+rm examples/.procmailrc
-+[ -d %%PREFIX%%/etc/rc.d ] && copy bin/sms %%PREFIX%%/etc/rc.d/smsd.sh.sample
-+[ -d %%EXAMPLESDIR%% ] || mkdir -p %%EXAMPLESDIR%%
-+[ -d %%EXAMPLESDIR%% ] && cp -R examples/* %%EXAMPLESDIR%%
- [ -d /var/spool ] || mkdir /var/spool
- [ -d /var/spool/sms ] || mkdir /var/spool/sms
- [ -d /var/spool/sms/incoming ] || mkdir /var/spool/sms/incoming
- [ -d /var/spool/sms/outgoing ] || mkdir /var/spool/sms/outgoing
- [ -d /var/spool/sms/checked ] || mkdir /var/spool/sms/checked
- echo Installation finished
--echo 'Please dont forget to edit /etc/smsd.conf.'
-+echo 'Please dont forget to edit %%PREFIX%%/etc/smsd.conf.'
diff --git a/comms/smstools/pkg-plist b/comms/smstools/pkg-plist
index 406277b1d6fb..1fb92894c68c 100644
--- a/comms/smstools/pkg-plist
+++ b/comms/smstools/pkg-plist
@@ -4,7 +4,6 @@ bin/sms2unicode
bin/sms2xml
bin/smsd
bin/unicode2sms
-etc/rc.d/smsd.sh
etc/smsd.conf.sample
%%EXAMPLESDIR%%/email2sms
%%EXAMPLESDIR%%/mysmsd
@@ -18,8 +17,6 @@ etc/smsd.conf.sample
%%EXAMPLESDIR%%/smsd.conf.full
%%EXAMPLESDIR%%/smsevent
%%EXAMPLESDIR%%/sql_demo
-share/nls/POSIX
-share/nls/en_US.US-ASCII
@dirrm share/examples/smstools
@cwd /
@dirrm var/spool/sms/outgoing