aboutsummaryrefslogtreecommitdiff
path: root/comms/spandsp-devel5/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-30 22:22:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-30 22:22:38 +0000
commit1d6e8c365a32d3c383f34c31ea6b73cb4b4ae833 (patch)
tree85f5058b4ff8903a68c633624d26b9fc4fbf813c /comms/spandsp-devel5/files
parentad635cfe96b1f2de591bc617c52ebe3782015acf (diff)
Add spandsp, software fax library for Asterisk
PR: ports/82642 Submitted by: William Lloyd <wlloyd@slap.net>
Notes
Notes: svn path=/head/; revision=138271
Diffstat (limited to 'comms/spandsp-devel5/files')
-rw-r--r--comms/spandsp-devel5/files/patch-src-Makefile.in11
-rw-r--r--comms/spandsp-devel5/files/patch-src-playout.c10
-rw-r--r--comms/spandsp-devel5/files/patch-src-power_meter.c13
-rw-r--r--comms/spandsp-devel5/files/patch-src-spandsp-dc_restore.h14
-rw-r--r--comms/spandsp-devel5/files/patch-src-t31.c28
5 files changed, 76 insertions, 0 deletions
diff --git a/comms/spandsp-devel5/files/patch-src-Makefile.in b/comms/spandsp-devel5/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..3b8f9a6f252d
--- /dev/null
+++ b/comms/spandsp-devel5/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in~ Thu Apr 28 09:03:02 2005
++++ src/Makefile.in Thu Jun 23 15:27:14 2005
+@@ -211,7 +211,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ MAINTAINERCLEANFILES = Makefile.in
+-INCLUDES = -I$(top_buildir)
++#INCLUDES = -I$(top_buildir)
+ lib_LTLIBRARIES = libspandsp.la
+ libspandsp_la_SOURCES = adsi.c \
+ awgn.c \
diff --git a/comms/spandsp-devel5/files/patch-src-playout.c b/comms/spandsp-devel5/files/patch-src-playout.c
new file mode 100644
index 000000000000..2674f62f0de3
--- /dev/null
+++ b/comms/spandsp-devel5/files/patch-src-playout.c
@@ -0,0 +1,10 @@
+--- src/playout.c~ Fri Feb 4 14:19:30 2005
++++ src/playout.c Thu Jun 23 15:35:06 2005
+@@ -37,6 +37,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <limits.h>
++#include <sys/types.h>
+
+ #include "spandsp/telephony.h"
+ #include "spandsp/playout.h"
diff --git a/comms/spandsp-devel5/files/patch-src-power_meter.c b/comms/spandsp-devel5/files/patch-src-power_meter.c
new file mode 100644
index 000000000000..5209632685e7
--- /dev/null
+++ b/comms/spandsp-devel5/files/patch-src-power_meter.c
@@ -0,0 +1,13 @@
+--- src/power_meter.c.orig Thu Jun 30 22:40:33 2005
++++ src/power_meter.c Thu Jun 30 22:41:05 2005
+@@ -72,6 +72,10 @@
+ }
+ /*- End of function --------------------------------------------------------*/
+
++#ifndef INFINITY
++#define INFINITY (float)HUGE_VAL
++#endif
++
+ float power_meter_dbm0(power_meter_t *meter)
+ {
+ float val;
diff --git a/comms/spandsp-devel5/files/patch-src-spandsp-dc_restore.h b/comms/spandsp-devel5/files/patch-src-spandsp-dc_restore.h
new file mode 100644
index 000000000000..d2f63ad0d8e4
--- /dev/null
+++ b/comms/spandsp-devel5/files/patch-src-spandsp-dc_restore.h
@@ -0,0 +1,14 @@
+--- src/spandsp/dc_restore.h.orig Tue Jan 18 15:05:48 2005
++++ src/spandsp/dc_restore.h Thu Jun 30 22:35:33 2005
+@@ -85,6 +85,11 @@
+ }
+ /*- End of function --------------------------------------------------------*/
+
++#ifndef INT16_MAX
++#define INT16_MAX 0x7fff
++#define INT16_MIN (-0x7fff-1)
++#endif
++
+ static inline int16_t saturate(int32_t amp)
+ {
+ if (amp > INT16_MAX)
diff --git a/comms/spandsp-devel5/files/patch-src-t31.c b/comms/spandsp-devel5/files/patch-src-t31.c
new file mode 100644
index 000000000000..7ffd6abfd2d6
--- /dev/null
+++ b/comms/spandsp-devel5/files/patch-src-t31.c
@@ -0,0 +1,28 @@
+--- src/t31.c.orig Thu Jun 30 23:07:14 2005
++++ src/t31.c Thu Jun 30 23:10:28 2005
+@@ -51,19 +51,12 @@
+ t31_profile_t profiles[3] =
+ {
+ {
+- .echo = TRUE,
+- .verbose = TRUE,
+- .result_code_format = ASCII_RESULT_CODES,
+- .pulse_dial = FALSE,
+- .double_escape = FALSE,
+- .s_regs[0] = 0,
+- .s_regs[3] = '\r',
+- .s_regs[4] = '\n',
+- .s_regs[5] = '\b',
+- .s_regs[6] = 1,
+- .s_regs[7] = 60,
+- .s_regs[8] = 5,
+- .s_regs[10] = 0
++ TRUE,
++ TRUE,
++ ASCII_RESULT_CODES,
++ FALSE,
++ FALSE,
++ { 0, 0, 0, '\r', '\n', '\b', 1, 60, 5, 0 }
+ }
+ };
+