aboutsummaryrefslogtreecommitdiff
path: root/comms/sredird
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-27 01:36:46 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-27 01:36:46 +0000
commit4249db21f1550121828bf7be52f926ff5fea745d (patch)
tree62ac4af88a7966e2c2f1b399a78eb5c3a77ea13f /comms/sredird
parent8093fcc11c5e71b31db3557e9116c1ec7198276c (diff)
downloadports-4249db21f1550121828bf7be52f926ff5fea745d.tar.gz
ports-4249db21f1550121828bf7be52f926ff5fea745d.zip
Adding sredird version 1.1.7
An RFC 2217 compliant serial port redirector. PR: 15603 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Notes
Notes: svn path=/head/; revision=24127
Diffstat (limited to 'comms/sredird')
-rw-r--r--comms/sredird/Makefile26
-rw-r--r--comms/sredird/distinfo1
-rw-r--r--comms/sredird/files/patch-aa54
-rw-r--r--comms/sredird/files/patch-ab11
-rw-r--r--comms/sredird/pkg-comment1
-rw-r--r--comms/sredird/pkg-descr11
-rw-r--r--comms/sredird/pkg-plist4
7 files changed, 108 insertions, 0 deletions
diff --git a/comms/sredird/Makefile b/comms/sredird/Makefile
new file mode 100644
index 000000000000..595231e54801
--- /dev/null
+++ b/comms/sredird/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: sredird
+# Version required: 1.1.7
+# Date created: 19 Dec 1999
+# Whom: Maxim Sobolev <sobomax@altavista.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= sredird-1.1.7
+CATEGORIES= comms
+MASTER_SITES= http://metalab.unc.edu/pub/Linux/system/serial/
+
+MAINTAINER= sobomax@altavista.net
+
+do-build:
+ ${CC} ${CFLAGS} -g -Wall -o ${WRKSRC}/sredird ${WRKSRC}/sredird.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sredird ${PREFIX}/libexec
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/sredird
+ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/sredird
+ ${INSTALL_MAN} ${WRKSRC}/COPYING ${PREFIX}/share/doc/sredird
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/sredird/distinfo b/comms/sredird/distinfo
new file mode 100644
index 000000000000..afcb99ce4535
--- /dev/null
+++ b/comms/sredird/distinfo
@@ -0,0 +1 @@
+MD5 (sredird-1.1.7.tar.gz) = 4daa974b620ae1cf1dad80e295dcdef5
diff --git a/comms/sredird/files/patch-aa b/comms/sredird/files/patch-aa
new file mode 100644
index 000000000000..01b3a4eaad88
--- /dev/null
+++ b/comms/sredird/files/patch-aa
@@ -0,0 +1,54 @@
+--- sredird.c.orig Mon Sep 20 15:26:54 1999
++++ sredird.c Tue Dec 21 11:02:48 1999
+@@ -43,7 +43,12 @@
+ #include <fcntl.h>
+ #include <syslog.h>
+ #include <termios.h>
+-#include <termio.h>
++#ifndef __FreeBSD__ /* FreeBSD */
++#include <termio.h> /* Doesn't exist on FreeBSD */
++#else
++#include <netdb.h> /* Necessary for getprotobyname(3) function */
++#include <netinet/in_systm.h> /* Reqired for netinet/ip.h */
++#endif /* FreeBSD */
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+@@ -129,6 +134,14 @@
+ /* Default modem state polling in milliseconds (100 msec should be enough) */
+ #define ModemStatePolling 100
+
++/* FreeBSD specific definitions */
++#ifdef __FreeBSD__ /* FreeBSD */
++struct tms mytms;
++#define times(NULL) times(&mytms) /* Coz times(NULL) coredumps on FreeBSD */
++#define SOL_TCP getprotobyname("TCP")->p_proto /* SOL_TCP and SOL_IP undefined */
++#define SOL_IP getprotobyname("IP")->p_proto /* on FreeBSD */
++#endif /* FreeBSD */
++
+ /* Standard boolean definition */
+ typedef enum { False, True } Boolean;
+
+@@ -571,8 +584,10 @@
+ return(115200UL);
+ case B230400:
+ return(230400UL);
++#ifndef __FreeBSD__ /* Sadly, but FreeBSD doesn't support rates > 230K */
+ case B460800:
+ return(460800UL);
++#endif
+ default:
+ return(0UL);
+ }
+@@ -954,9 +969,11 @@
+ case 230400UL:
+ Speed = B230400;
+ break;
++#ifndef __FreeBSD__
+ case 460800UL:
+ Speed = B460800;
+ break;
++#endif
+ default:
+ LogMsg(LOG_WARNING,"Unknwon baud rate requested. Setting to 38400");
+ Speed = B38400;
diff --git a/comms/sredird/files/patch-ab b/comms/sredird/files/patch-ab
new file mode 100644
index 000000000000..8a75ff40c019
--- /dev/null
+++ b/comms/sredird/files/patch-ab
@@ -0,0 +1,11 @@
+--- README.orig Tue Dec 21 10:49:33 1999
++++ README Tue Dec 21 10:50:59 1999
+@@ -80,7 +80,7 @@
+ Sredird is designed to run under inetd control. The line in the inetd
+ configuration file (usually /etc/inetd.conf) should look like this:
+
+-sredir stream tcp nowait root /usr/sbin/tcpd /usr/sbin/sredird 5 /dev/modem /var/lock/LCK..modem
++sredir stream tcp nowait root /usr/local/libexec/sredird sredird 5 /dev/cuaa0 /var/spool/lock/LCK..cuaa0
+
+ Of course, "sredir" should be defined in the services file (usually
+ /etc/services, usual values start at port 7000) and "/dev/modem" should
diff --git a/comms/sredird/pkg-comment b/comms/sredird/pkg-comment
new file mode 100644
index 000000000000..0a030045f740
--- /dev/null
+++ b/comms/sredird/pkg-comment
@@ -0,0 +1 @@
+RFC 2217 compliant serial port redirector
diff --git a/comms/sredird/pkg-descr b/comms/sredird/pkg-descr
new file mode 100644
index 000000000000..db2257c10daa
--- /dev/null
+++ b/comms/sredird/pkg-descr
@@ -0,0 +1,11 @@
+Sredird is a serial port redirector that is compliant with the RFC 2217
+"Telnet Com Port Control Option" protocol. This protocol lets you share
+a serial port through the network. The only known RFC 2217 aware client
+is DialOut/IP V2, which is a Windows 95/98/NT client. For more
+information on it look at www.tacticalsoftware.com. Anyone interested in
+writing a client and who may need help with the RFC 2217 protocol could
+contact author of sredird. Information on RFC 2217 and the Telnet Protocol
+is available at www.ietf.org.
+
+- Maxim Sobolev
+sobomax@altavista.net
diff --git a/comms/sredird/pkg-plist b/comms/sredird/pkg-plist
new file mode 100644
index 000000000000..e2cb117b19c0
--- /dev/null
+++ b/comms/sredird/pkg-plist
@@ -0,0 +1,4 @@
+libexec/sredird
+share/doc/sredird/README
+share/doc/sredird/COPYING
+@dirrm share/doc/sredird