aboutsummaryrefslogtreecommitdiff
path: root/comms/syncterm
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-02 02:19:21 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-02 02:19:21 +0000
commit49db6a7c965e296aecd02386f8f0312722fd44a4 (patch)
tree0e026eaa59ca7af3b3b5a29577c610fd4bf84c39 /comms/syncterm
parente40789297d13da2ad861457df844abae8d5f8c16 (diff)
downloadports-49db6a7c965e296aecd02386f8f0312722fd44a4.tar.gz
ports-49db6a7c965e296aecd02386f8f0312722fd44a4.zip
Notes
Diffstat (limited to 'comms/syncterm')
-rw-r--r--comms/syncterm/Makefile50
-rw-r--r--comms/syncterm/distinfo3
-rw-r--r--comms/syncterm/pkg-descr5
3 files changed, 58 insertions, 0 deletions
diff --git a/comms/syncterm/Makefile b/comms/syncterm/Makefile
new file mode 100644
index 000000000000..2be5038c15d2
--- /dev/null
+++ b/comms/syncterm/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: syncterm
+# Date created: 3 October 2006
+# Whom: shurd
+#
+# $FreeBSD$
+#
+
+PORTNAME= syncterm
+PORTVERSION= 0.8.20061020
+CATEGORIES= comms
+MASTER_SITES= http://syncterm.bbsdev.net/
+DISTNAME= syncterm-src-20061020
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= An ANSI-BBS terminal which supports telnet, rlogin, and SSH
+
+LIB_DEPENDS= cl:${PORTSDIR}/security/cryptlib
+
+WRKSRC= ${WRKDIR}/syncterm-20061020
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+OPTIONS= X11 "Build with X11 support" ON \
+ SDL "Build with SDL support" ON \
+ DEBUG "Build a debug version" OFF
+
+PLIST_FILES= bin/syncterm
+
+.include <bsd.port.pre.mk>
+
+MAKE_ARGS+= -C syncterm
+MAKE_ARGS+= PREFIX=${PREFIX}
+MAKE_ARGS+= "INSTALL_EXE=${INSTALL_PROGRAM}"
+.if defined(WITHOUT_X11)
+MAKE_ARGS+= NO_X=1
+.else
+USE_XLIB= yes
+.endif
+.if !defined(WITHOUT_SDL)
+USE_SDL= sdl
+MAKE_ARGS+= USE_SDL=1
+.endif
+.if defined(WITH_DEBUG)
+MAKE_ARGS+= DEBUG=1
+.else
+MAKE_ARGS+= RELEASE=1
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/syncterm/distinfo b/comms/syncterm/distinfo
new file mode 100644
index 000000000000..099aa85acce3
--- /dev/null
+++ b/comms/syncterm/distinfo
@@ -0,0 +1,3 @@
+MD5 (syncterm-src-20061020.tgz) = a4b98f838e10c8d1af9adbc4aed92c80
+SHA256 (syncterm-src-20061020.tgz) = e04483224a68a5571d62e37de310d79c2de69c283c343825c8abc01eb4cd0b7b
+SIZE (syncterm-src-20061020.tgz) = 369046
diff --git a/comms/syncterm/pkg-descr b/comms/syncterm/pkg-descr
new file mode 100644
index 000000000000..726a9ccb7aa0
--- /dev/null
+++ b/comms/syncterm/pkg-descr
@@ -0,0 +1,5 @@
+An ANSI-BBS terminal designed to connect to remote BBSs via telnet, rlogin, or
+SSH. Supports ANSI music and the IBM charset when possible. Will run from a
+console, under X11 using XLib, or using SDL.
+
+WWW: http://syncterm.bbsdev.net/