aboutsummaryrefslogtreecommitdiff
path: root/comms/tlf
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-05-09 17:13:46 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-05-09 17:13:46 +0000
commitb9e58b5834559a96af18d16953a1a1665e7b9e5d (patch)
treea8b9a5cd520f604a9e3433cf713c17ff5b886bec /comms/tlf
parent36502ed17ad64ccb59cc120b55605b1b99ccf7f7 (diff)
downloadports-b9e58b5834559a96af18d16953a1a1665e7b9e5d.tar.gz
ports-b9e58b5834559a96af18d16953a1a1665e7b9e5d.zip
Notes
Diffstat (limited to 'comms/tlf')
-rw-r--r--comms/tlf/Makefile2
-rw-r--r--comms/tlf/distinfo6
-rw-r--r--comms/tlf/files/patch-fix_build_4x19
-rw-r--r--comms/tlf/files/patch-share_logcfg.dat13
-rw-r--r--comms/tlf/files/patch-src_audio.c226
-rw-r--r--comms/tlf/files/patch-src_callinput.c18
-rw-r--r--comms/tlf/files/patch-src_cluster_bg.c52
-rw-r--r--comms/tlf/files/patch-src_parse_logcfg.c19
-rw-r--r--comms/tlf/files/patch-src_rtty.c29
-rw-r--r--comms/tlf/files/patch-src_searchcallarray.c12
-rw-r--r--comms/tlf/files/patch-src_searchlog.c37
-rw-r--r--comms/tlf/files/patch-src_splitscreen.c36
-rw-r--r--comms/tlf/files/patch-src_splitscreen.h11
-rw-r--r--comms/tlf/files/patch-src_writecabrillo.c25
-rw-r--r--comms/tlf/pkg-plist56
15 files changed, 272 insertions, 289 deletions
diff --git a/comms/tlf/Makefile b/comms/tlf/Makefile
index 521323ddb323..16203e747c39 100644
--- a/comms/tlf/Makefile
+++ b/comms/tlf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tlf
-PORTVERSION= 0.9.19
+PORTVERSION= 0.9.30
CATEGORIES= comms hamradio
MASTER_SITES= http://www.wwns.com/tlf/ \
http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/
diff --git a/comms/tlf/distinfo b/comms/tlf/distinfo
index 7a62edd73c53..a8449acee129 100644
--- a/comms/tlf/distinfo
+++ b/comms/tlf/distinfo
@@ -1,3 +1,3 @@
-MD5 (tlf/tlf-0.9.19.tar.gz) = a6318f099d6baf910b425f8e32820c56
-SHA256 (tlf/tlf-0.9.19.tar.gz) = fc079eb58fb58bc2ea9162b8cef9baef4849fb8abd8ae74d6f3707b475ee0876
-SIZE (tlf/tlf-0.9.19.tar.gz) = 348768
+MD5 (tlf/tlf-0.9.30.tar.gz) = fc8faeb23d7a54c96eb3a962cc4d9e4e
+SHA256 (tlf/tlf-0.9.30.tar.gz) = c81f9fd21268bae1bca7b3eecd09216885e1b1b8428d4b1d50af386c036de4ee
+SIZE (tlf/tlf-0.9.30.tar.gz) = 390608
diff --git a/comms/tlf/files/patch-fix_build_4x b/comms/tlf/files/patch-fix_build_4x
new file mode 100644
index 000000000000..ead6eba45ba6
--- /dev/null
+++ b/comms/tlf/files/patch-fix_build_4x
@@ -0,0 +1,19 @@
+--- src/readctydata.c.orig Tue May 9 14:08:25 2006
++++ src/readctydata.c Tue May 9 14:09:12 2006
+@@ -45,6 +45,7 @@
+ char * ituloc;
+
+ FILE *fp_db;
++ char *loc;
+
+ strcpy(ctydb_location, "cty.dat");
+ if ( (fp_db = fopen (ctydb_location, "r")) == NULL)
+@@ -91,7 +92,7 @@
+ strncpy(buffer, buf, 79);
+ buffer[79] = 0;
+
+- char *loc = NULL; //PG4I, 26Jul2005
++ loc = NULL; //PG4I, 26Jul2005
+ if ((loc = strchr(buffer, '\r')))
+ *loc = '\0';
+
diff --git a/comms/tlf/files/patch-share_logcfg.dat b/comms/tlf/files/patch-share_logcfg.dat
new file mode 100644
index 000000000000..3b1a7a1703cb
--- /dev/null
+++ b/comms/tlf/files/patch-share_logcfg.dat
@@ -0,0 +1,13 @@
+--- share/logcfg.dat.orig Mon May 8 14:51:58 2006
++++ share/logcfg.dat Mon May 8 14:52:09 2006
+@@ -27,8 +27,8 @@
+ # #
+ #################################
+ #
+-EDITOR=joe
+-#EDITOR=vi
++#EDITOR=joe
++EDITOR=vi
+ #EDITOR=e3
+ #EDITOR=MC
+ #
diff --git a/comms/tlf/files/patch-src_audio.c b/comms/tlf/files/patch-src_audio.c
index 67fd8fb5dee5..95f1a7ef4086 100644
--- a/comms/tlf/files/patch-src_audio.c
+++ b/comms/tlf/files/patch-src_audio.c
@@ -1,18 +1,208 @@
---- src/audio.c.orig Sat Jul 10 21:31:56 2004
-+++ src/audio.c Sat Jul 10 21:32:05 2004
-@@ -578,6 +578,7 @@
-
- float testvalue;
- char key = '\0';
-+int runnit = 1;
-
- clear();
-
-@@ -586,7 +587,6 @@
- /* ------------initialize sound card --------*/
- init_audio();
-
--int runnit = 1;
-
- while (runnit == 1) {
-
+--- src/audio.c.orig Wed Apr 5 03:16:50 2006
++++ src/audio.c Mon May 8 14:31:45 2006
+@@ -30,6 +30,8 @@
+ #include "onechar.h"
+
+ extern char sc_device[];
++char soundlog_dir[FILENAME_MAX];
++char *home;
+
+ int afd;
+
+@@ -668,10 +670,8 @@
+ mvprintw(15,20, "recording %s", ph_message[0]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[0]);
++ snprintf(commands,sizeof(commands), "rec -w -w 8000 -d %s %s",
++ sc_device, ph_message[0]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -680,21 +680,16 @@
+ mvprintw(16,20, "");
+ refresh();
+
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[1]);
+- system (commands);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[1]);
+ runnit = 0;
+ break;
+ case 131 :
+ mvprintw(15,20, "recording %s", ph_message[2]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[2]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[2]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -702,10 +697,8 @@
+ mvprintw(15,20, "recording %s", ph_message[3]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[3]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[3]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -713,10 +706,8 @@
+ mvprintw(15,20, "recording %s", ph_message[4]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[4]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[4]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -724,10 +715,8 @@
+ mvprintw(15,20, "recording %s", ph_message[5]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[5]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[5]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -735,10 +724,8 @@
+ mvprintw(15,20, "recording %s", ph_message[6]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[6]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[6]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -746,10 +733,8 @@
+ mvprintw(15,20, "recording %s", ph_message[7]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[7]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[7]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -757,10 +742,8 @@
+ mvprintw(15,20, "recording %s", ph_message[8]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[8]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[8]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -768,10 +751,8 @@
+ mvprintw(15,20, "recording %s", ph_message[9]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[9]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[9]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -779,10 +760,8 @@
+ mvprintw(15,20, "recording %s", ph_message[10]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[10]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[10]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -790,10 +769,8 @@
+ mvprintw(15,20, "recording %s", ph_message[11]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[11]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[11]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -802,10 +779,8 @@
+ mvprintw(15,20, "recording %s", ph_message[12]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[12]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[12]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -814,10 +789,8 @@
+ mvprintw(15,20, "recording %s", ph_message[13]);
+ mvprintw(16,20, "");
+ refresh();
+- strcpy(commands,"rec -w -r 8000 -d ");
+- strcat(commands, sc_device);
+- strcat(commands, " "); // (W9WI)
+- strcat(commands, ph_message[13]);
++ snprintf(commands,sizeof(commands),"rec -w -r 8000 -d %s %s",
++ sc_device, ph_message[13]);
+ system (commands);
+ runnit = 0;
+ break;
+@@ -840,7 +813,13 @@
+ runnit = 0;
+ break;
+ case '3' :
+- sounddir = opendir("$HOME/tlf/soundlogs/"); // (W9WI)
++ if ((home = getenv("HOME")) != NULL) {
++ snprintf(soundlog_dir,sizeof(soundlog_dir),
++ "%s/tlf/soundlogs/", home);
++ sounddir = opendir(soundlog_dir);
++ } else
++ sounddir = NULL;
++
+
+ if (sounddir == NULL) break;
+
diff --git a/comms/tlf/files/patch-src_callinput.c b/comms/tlf/files/patch-src_callinput.c
deleted file mode 100644
index 3d6b53e399a5..000000000000
--- a/comms/tlf/files/patch-src_callinput.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/callinput.c.orig Sat Jul 10 21:33:41 2004
-+++ src/callinput.c Sat Jul 10 21:34:33 2004
-@@ -26,6 +26,7 @@
- #include "addspot.h"
- #include "changefreq.h"
-
-+void send_bandswitch(int freq);
-
-
- int callinput(void)
-@@ -105,7 +106,6 @@
-
- instring[1] = '\0';
-
--void send_bandswitch(int freq);
-
- if (use_rxvt == 0) attron(COLOR_PAIR(NORMCOLOR) | A_BOLD );
- else attron(COLOR_PAIR(NORMCOLOR) );
diff --git a/comms/tlf/files/patch-src_cluster_bg.c b/comms/tlf/files/patch-src_cluster_bg.c
deleted file mode 100644
index 13cae3bad4a3..000000000000
--- a/comms/tlf/files/patch-src_cluster_bg.c
+++ /dev/null
@@ -1,52 +0,0 @@
---- src/cluster_bg.c.orig Mon Aug 23 15:00:34 2004
-+++ src/cluster_bg.c Mon Aug 23 15:02:36 2004
-@@ -7,12 +7,11 @@
-
-
-
--int cluster_bg(int cluster) {
-+int cluster_bg(int cluster_arg) {
-
- extern char spot_ptr[MAX_SPOTS][82];
- extern int spotarray[MAX_SPOTS];
- extern char spotinfo[32][82];
--extern int cluster;
- extern int announcefilter;
- extern int bandinx;
-
-@@ -22,14 +21,14 @@
-
-
-
-- if (cluster == NOCLUSTER)
-+ if (cluster_arg == NOCLUSTER)
- return(1);
-
-- if (cluster == MAP)
-+ if (cluster_arg == MAP)
- clustermode = bandinx;
-- if (cluster == SPOTS)
-+ if (cluster_arg == SPOTS)
- clustermode = 9;
-- if ( cluster != CLUSTER)
-+ if ( cluster_arg != CLUSTER)
-
- {
- announcefilter = FILTER_DX;
-@@ -77,7 +76,7 @@
- }
-
-
-- if (cluster == CLUSTER){ /* all cluster info */
-+ if (cluster_arg == CLUSTER){ /* all cluster info */
-
- k = getclusterinfo();
-
-@@ -100,7 +99,6 @@
- extern int spotarray[];
- extern int announcefilter;
- extern char call[];
--extern int cluster;
- extern int bandinx;
-
- int bg, nd, i;
diff --git a/comms/tlf/files/patch-src_parse_logcfg.c b/comms/tlf/files/patch-src_parse_logcfg.c
deleted file mode 100644
index f9abf20810e7..000000000000
--- a/comms/tlf/files/patch-src_parse_logcfg.c
+++ /dev/null
@@ -1,19 +0,0 @@
-*** src/parse_logcfg.c.orig Fri Nov 12 15:37:30 2004
---- src/parse_logcfg.c Fri Nov 12 15:38:53 2004
-***************
-*** 170,176 ****
- extern char bc_hostaddress[MAXNODES][16];
- extern int lan_active;
- extern char thisnode;
-! extern char nodes;
- extern int node;
- extern int cqwwm2;
- extern int landebug;
---- 170,176 ----
- extern char bc_hostaddress[MAXNODES][16];
- extern int lan_active;
- extern char thisnode;
-! extern int nodes;
- extern int node;
- extern int cqwwm2;
- extern int landebug;
diff --git a/comms/tlf/files/patch-src_rtty.c b/comms/tlf/files/patch-src_rtty.c
deleted file mode 100644
index 54d99cfb6200..000000000000
--- a/comms/tlf/files/patch-src_rtty.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/rtty.c.orig Sat Jul 10 21:41:49 2004
-+++ src/rtty.c Sun Jul 11 00:52:01 2004
-@@ -72,7 +72,7 @@
-
- int ry_addtext(char *line) {
-
--extern char ry_term[][];
-+//extern char ry_term[][];
-
- int k, m, j;
- char *ptr;
-@@ -137,7 +137,7 @@
- int show_rtty(void) {
-
- extern int use_rxvt;
--extern char ry_term[][];
-+//extern char ry_term[][];
- extern int trxmode;
-
- if (trxmode != DIGIMODE)
-@@ -169,7 +169,7 @@
-
- extern char hiscall[];
- extern int miniterm;
--extern char ry_term[][];
-+//extern char ry_term[][];
-
- int i = 0;
- char line[40];
diff --git a/comms/tlf/files/patch-src_searchcallarray.c b/comms/tlf/files/patch-src_searchcallarray.c
deleted file mode 100644
index ad47891ff535..000000000000
--- a/comms/tlf/files/patch-src_searchcallarray.c
+++ /dev/null
@@ -1,12 +0,0 @@
-*** src/searchcallarray.c.orig Fri Nov 12 15:40:59 2004
---- src/searchcallarray.c Fri Nov 12 15:41:45 2004
-***************
-*** 25,31 ****
-
- int searchcallarray (char *hiscall)
- {
-- extern char hiscall[];
- extern int callarray_nr;
- extern char callarray[MAX_CALLS][20];
-
---- 25,30 ----
diff --git a/comms/tlf/files/patch-src_searchlog.c b/comms/tlf/files/patch-src_searchlog.c
deleted file mode 100644
index c050dd519f69..000000000000
--- a/comms/tlf/files/patch-src_searchlog.c
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/searchlog.c.orig Fri May 21 12:15:14 2004
-+++ src/searchlog.c Sun Jul 11 01:04:54 2004
-@@ -26,6 +26,8 @@
- # include <config.h>
- #endif
-
-+static char searchresult[MAX_CALLS][82];
-+static char result[MAX_CALLS][82];
-
- int searchlog(char *searchstring)
-
-@@ -75,9 +77,7 @@
- extern int itumult;
-
-
--char searchresult[MAX_CALLS][82];
- int srch_index=0;
--char result[MAX_CALLS][82];
- int r_index=0;
- char s_inputbuffer[82] = "";
- char s_inputbuffercpy[82] = "";
-@@ -90,13 +90,13 @@
- char *tmpstr;
-
- char callmaster_location[80];
--
-+#if 0
- if (strlen(s_inputbuffer)>=83)
- {
- printf ("WARNING: Input buffer is longer than 82 characters! exiting...");
- exit(1);
- }
--
-+#endif
- strcpy(callmaster_location, PACKAGE_DATA_DIR) ;
- strcat(callmaster_location, "/callmaster ") ;
-
diff --git a/comms/tlf/files/patch-src_splitscreen.c b/comms/tlf/files/patch-src_splitscreen.c
deleted file mode 100644
index 0cf68f7e14b6..000000000000
--- a/comms/tlf/files/patch-src_splitscreen.c
+++ /dev/null
@@ -1,36 +0,0 @@
-*** src/splitscreen.c.orig Fri Nov 12 15:44:12 2004
---- src/splitscreen.c Fri Nov 12 15:52:19 2004
-***************
-*** 50,56 ****
- extern struct tln_logline *logtail;
- extern struct tln_logline *temp;
- extern struct tln_logline *viewing;
-! extern char spot_ptr[100][82];
- extern char lastmsg[80];
- extern int ptr;
-
---- 50,56 ----
- extern struct tln_logline *logtail;
- extern struct tln_logline *temp;
- extern struct tln_logline *viewing;
-! extern char spot_ptr[MAX_SPOTS][82];
- extern char lastmsg[80];
- extern int ptr;
-
-***************
-*** 722,728 ****
- extern SCREEN *packetscreen;
- extern WINDOW *sclwin;
- extern WINDOW *entwin;
-! extern char spot_ptr[100][80];
- extern int tncport;
- extern int fdSertnc;
- extern int fdFIFO;
---- 722,728 ----
- extern SCREEN *packetscreen;
- extern WINDOW *sclwin;
- extern WINDOW *entwin;
-! extern char spot_ptr[MAX_SPOTS][82];
- extern int tncport;
- extern int fdSertnc;
- extern int fdFIFO;
diff --git a/comms/tlf/files/patch-src_splitscreen.h b/comms/tlf/files/patch-src_splitscreen.h
deleted file mode 100644
index 3cfe59bf113d..000000000000
--- a/comms/tlf/files/patch-src_splitscreen.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/splitscreen.h.orig Sat Jul 10 21:29:22 2004
-+++ src/splitscreen.h Sat Jul 10 21:29:42 2004
-@@ -17,7 +17,7 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- */
- // splitscreen.h
--
-+#include <sys/types.h>
- #include <curses.h>
- #include "sockserv.h"
- #include <errno.h>
diff --git a/comms/tlf/files/patch-src_writecabrillo.c b/comms/tlf/files/patch-src_writecabrillo.c
deleted file mode 100644
index d3c6583d5115..000000000000
--- a/comms/tlf/files/patch-src_writecabrillo.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/writecabrillo.c.orig Sat Jul 10 22:23:15 2004
-+++ src/writecabrillo.c Sat Jul 10 22:24:47 2004
-@@ -45,6 +45,7 @@
- char buf[181];
- char buffer[82]= "";
- char standardexchange[70] = "";
-+ char ssa_mt_exchange[30];
-
- FILE *fp1, *fp2;
-
-@@ -271,13 +272,12 @@
- strcat(buffer, "599 ");
-
- if (strcmp (whichcontest, "ssa_mt") == 0) {
-+ int i=0, j=0, k = 0;
- // strncat(buffer, buf+54, 9); // tbf for all contests? RC
- strcat(buffer, " ");
-
- sprintf(buffer + 79, "%03d ", atoi(buf+54));
-
-- char ssa_mt_exchange[30];
-- int i=0, j=0, k = 0;
-
- for (i=0; i < 12; i++) {
- if (isalpha(buf[54+i])){
diff --git a/comms/tlf/pkg-plist b/comms/tlf/pkg-plist
index cdddc6505285..2e1c374c8b8d 100644
--- a/comms/tlf/pkg-plist
+++ b/comms/tlf/pkg-plist
@@ -1,30 +1,30 @@
bin/soundlog
bin/tlf
-share/tlf/arrlsections
-share/tlf/callmaster
-share/tlf/cty.dat
-share/tlf/doc/README
-share/tlf/rules/dxped
-share/tlf/ea_sections
-share/tlf/rules/eusprint
-share/tlf/logcfg.dat
-share/tlf/rules/lzdx
-share/tlf/rules/pacc_dx
-share/tlf/rules/pacc_pa
-share/tlf/paccmults
-share/tlf/rules/qso
-share/tlf/rules/arrldx_dx
-share/tlf/rules/arrldx_usa
-share/tlf/rules/arrlfd
-share/tlf/rules/arrlss
-share/tlf/rules/cqww
-share/tlf/rules/spdx_dx
-share/tlf/rules/spdx_sp
-share/tlf/spdxmults
-share/tlf/rules/ssa_mt
-share/tlf/ssamults
-share/tlf/rules/template
-share/tlf/rules/wpx
-@dirrm share/tlf/doc
-@dirrm share/tlf/rules
-@dirrm share/tlf
+%%DATADIR%%/arrlsections
+%%DATADIR%%/callmaster
+%%DATADIR%%/cty.dat
+%%DATADIR%%/doc/README
+%%DATADIR%%/rules/dxped
+%%DATADIR%%/ea_sections
+%%DATADIR%%/rules/eusprint
+%%DATADIR%%/logcfg.dat
+%%DATADIR%%/rules/lzdx
+%%DATADIR%%/rules/pacc_dx
+%%DATADIR%%/rules/pacc_pa
+%%DATADIR%%/paccmults
+%%DATADIR%%/rules/qso
+%%DATADIR%%/rules/arrldx_dx
+%%DATADIR%%/rules/arrldx_usa
+%%DATADIR%%/rules/arrlfd
+%%DATADIR%%/rules/arrlss
+%%DATADIR%%/rules/cqww
+%%DATADIR%%/rules/spdx_dx
+%%DATADIR%%/rules/spdx_sp
+%%DATADIR%%/spdxmults
+%%DATADIR%%/rules/ssa_mt
+%%DATADIR%%/ssamults
+%%DATADIR%%/rules/template
+%%DATADIR%%/rules/wpx
+@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%/rules
+@dirrm %%DATADIR%%