aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl/files
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2012-08-14 23:30:31 +0000
committerDiane Bruce <db@FreeBSD.org>2012-08-14 23:30:31 +0000
commit2588104368d0a28879de32b1d6049c0da949d05e (patch)
tree576d6fd327e486b8b62ffa5fbc233789f225527c /comms/trustedqsl/files
parent32fc11f5a8589f7f66283f2de220d761cca711d5 (diff)
downloadports-2588104368d0a28879de32b1d6049c0da949d05e.tar.gz
ports-2588104368d0a28879de32b1d6049c0da949d05e.zip
Notes
Diffstat (limited to 'comms/trustedqsl/files')
-rw-r--r--comms/trustedqsl/files/Makefile14
-rw-r--r--comms/trustedqsl/files/Makefile.TrustedQSL-1.1163
-rw-r--r--comms/trustedqsl/files/patch-Makefile.in42
-rw-r--r--comms/trustedqsl/files/patch-TrustedQSL-1.11_crqwiz.cpp28
-rw-r--r--comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm9
-rw-r--r--comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp18
-rw-r--r--comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm9
-rw-r--r--comms/trustedqsl/files/patch-configure24
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in12
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_configure42
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp11
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp18
-rw-r--r--comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.1180
13 files changed, 66 insertions, 304 deletions
diff --git a/comms/trustedqsl/files/Makefile b/comms/trustedqsl/files/Makefile
deleted file mode 100644
index d73ae2cd0d1e..000000000000
--- a/comms/trustedqsl/files/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-# $FreeBSD$
-
-all:
- (cd tqsllib-2.0;./configure --with-wxwindows=${WX_CONFIG} \
- --prefix=${PREFIX} --with-expat=${LOCALBASE}; \
- make;make converter;make gen_crq; \
- make load_cert;make station_loc;make)
- (cd TrustedQSL-1.11;make)
-
-install:
- (cd tqsllib-2.0;make install)
- (cd tqsllib-2.0/.libs; \
- %%INSTALL%% converter gen_crq load_cert station_loc %%PREFIX%%/bin)
- (cd TrustedQSL-1.11;make install)
diff --git a/comms/trustedqsl/files/Makefile.TrustedQSL-1.11 b/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
deleted file mode 100644
index e4088bc751fa..000000000000
--- a/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
+++ /dev/null
@@ -1,63 +0,0 @@
-TQSLLIB=../tqsllib-2.0/.libs
-TQSLINC=../tqsllib-2.0
-TQSL_VERSION_MAJOR = 2
-TQSL_VERSION_MINOR = 0
-LIBS=-lz -lexpat -lcrypto
-INCDIR = -I$(TQSLINC)
-BUILD = unofficial
-WXFLAGS=`${WX_CONFIG} --cflags`
-WXLIBS=`${WX_CONFIG} --libs`
-DEFS = -DHAVE_CONFIG_H
-CXXFLAGS += $(DEFS) $(INCDIR) -DHAVE_LIBCRYPTO=1 -DSTDC_HEADERS=1 -DHAVE_MKDIR=1 -DHAVE_STRERROR=1 $(WXFLAGS)
-
-LDLIBS = -L$(TQSLLIB) -ltqsllib $(LIBS) $(WXLIBS)
-TQSLLIBFILE=$(TQSLLIB)/libtqsllib.a
-CCDEPMODE = depmode=gcc3
-BINDIR=${PREFIX}/bin
-DOCDIR=${PREFIX}/share/doc
-ETCDIR=${PREFIX}/etc
-PERL ?=perl
-CP ?=cp
-TOUCH ?=touch
-
-TARGETS = tqslcert tqsl
-
-all: tqslcertbuild.h tqslbuild.h $(TARGETS)
-
-TQSLCERT_OBJ = tqslcert.o crqwiz.o dxcc.o certtree.o tqslcert_prefs.o \
- getpassword.o extwizard.o loadcertwiz.o wxutil.o
-
-TQSL_OBJ = tqsl.o extwizard.o tqslwiz.o dxcc.o stationdial.o qsodatadialog.o \
- tqslvalidator.o tqsl_prefs.o wxutil.o
-
-tqslcert: $(TQSLCERT_OBJ) $(TQSLLIBFILE)
- $(CC) $(CXXFLAGS) -o $@ $(TQSLCERT_OBJ) $(LDLIBS) -lstdc++
-
-tqsl: $(TQSL_OBJ) $(TQSLLIBFILE)
- $(CC) $(CXXFLAGS) -o $@ $(TQSL_OBJ) $(LDLIBS) -lstdc++
-
-tqslcert.o:
- ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
-
-tqslcertbuild.h: tqslcertbuild.h.in Makefile
- $(PERL) touchver.pl tqslcertbuild.h.in BUILD $(BUILD)
- $(CP) tqslcertbuild.h.in tqslcertbuild.h
- $(TOUCH) tqslcertbuild.h.in
-
-tqslbuild.h: tqslbuild.h.in Makefile
- $(PERL) touchver.pl tqslbuild.h.in BUILD $(BUILD)
- $(CP) tqslbuild.h.in tqslbuild.h
- $(TOUCH) tqslbuild.h.in
-
-tqsl.o:
- ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
-
-%.o: %.cpp
- ${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
-
-clean:
- rm -f $(TARGETS) *.o *.a *~ xxx.*
-
-install:
- ${INSTALL} -d $(BINDIR) $(ETCDIR)/tqsl
- ${INSTALL} -C $(TARGETS) $(BINDIR)
diff --git a/comms/trustedqsl/files/patch-Makefile.in b/comms/trustedqsl/files/patch-Makefile.in
new file mode 100644
index 000000000000..36f8aceffdb0
--- /dev/null
+++ b/comms/trustedqsl/files/patch-Makefile.in
@@ -0,0 +1,42 @@
+--- Makefile.in.orig 2010-09-29 11:41:29.000000000 -0500
++++ Makefile.in 2012-08-11 18:44:55.000000000 -0500
+@@ -105,9 +105,9 @@
+ distcleancheck_listfiles = find . -type f -print
+ ACLOCAL = @ACLOCAL@
+ AMTAR = @AMTAR@
+-AUTOCONF = @AUTOCONF@
+-AUTOHEADER = @AUTOHEADER@
+-AUTOMAKE = @AUTOMAKE@
++AUTOCONF =
++AUTOHEADER =
++AUTOMAKE =
+ AWK = @AWK@
+ BUILD = @BUILD@
+ CC = @CC@
+@@ -143,7 +143,7 @@
+ LTLIBOBJS = @LTLIBOBJS@
+ MAKEINFO = @MAKEINFO@
+ MKDIR = @MKDIR@
+-MKDIR_P = @MKDIR_P@
++MKDIR_P = /bin/mkdir -p
+ OBJEXT = @OBJEXT@
+ OPENSSL = @OPENSSL@
+ PACKAGE = @PACKAGE@
+@@ -208,7 +208,7 @@
+ localedir = @localedir@
+ localstatedir = @localstatedir@
+ mandir = @mandir@
+-mkdir_p = @mkdir_p@
++mkdir_p = /bin/mkdir
+ oldincludedir = @oldincludedir@
+ pdfdir = @pdfdir@
+ platform = @platform@
+@@ -226,7 +226,7 @@
+ tqslresources = @tqslresources@
+ wxwin_libs = @wxwin_libs@
+ WXWIN_STATIC = @wxwin_static@
+-WXCONFIG = "$(WXDIR)/bin/wx-config"
++WXCONFIG = "$(WXDIR)"
+ helpdir = $(datadir)
+ AM_CXXFLAGS = -Wall `$(WXCONFIG) --cxxflags` -I$(TQSLINC) -I$(ZLIB)/include -I$(EXPAT)/include
+ AM_LDFLAGS = -L$(TQSLLIB) -L$(ZLIB)/lib -L$(EXPAT)/lib -L$(OPENSSL)/lib
diff --git a/comms/trustedqsl/files/patch-TrustedQSL-1.11_crqwiz.cpp b/comms/trustedqsl/files/patch-TrustedQSL-1.11_crqwiz.cpp
deleted file mode 100644
index ab29053abae4..000000000000
--- a/comms/trustedqsl/files/patch-TrustedQSL-1.11_crqwiz.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- TrustedQSL-1.11/crqwiz.cpp.orig Fri Mar 11 07:47:06 2005
-+++ TrustedQSL-1.11/crqwiz.cpp Fri May 11 12:23:38 2007
-@@ -9,6 +9,7 @@
- ***************************************************************************/
-
- #include <ctype.h>
-+#include <stdint.h>
- #include "crqwiz.h"
- #include "dxcc.h"
- #include "util.h"
-@@ -104,7 +105,7 @@
- CRQ_ProviderPage::DoUpdateInfo() {
- int sel = tc_provider->GetSelection();
- if (sel >= 0) {
-- int idx = (int)(tc_provider->GetClientData(sel));
-+ int idx = (int)((intptr_t)(tc_provider->GetClientData(sel)));
- if (idx >=0 && idx < (int)providers.size()) {
- Parent()->provider = providers[idx];
- wxString info;
-@@ -521,7 +522,7 @@
- }
- ok = (ok && havealpha && havenumeric);
- }
-- Parent()->dxcc = (int)(tc_dxcc->GetClientData(tc_dxcc->GetSelection()));
-+ Parent()->dxcc = (int)((intptr_t)(tc_dxcc->GetClientData(tc_dxcc->GetSelection())));
- if (Parent()->dxcc < 0) {
- msg = wxT("You must select a DXCC entity.");
- ok = false;
diff --git a/comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm b/comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm
deleted file mode 100644
index 1e83e4bb9c2e..000000000000
--- a/comms/trustedqsl/files/patch-TrustedQSL-1.11_left.xpm
+++ /dev/null
@@ -1,9 +0,0 @@
---- TrustedQSL-1.11/left.xpm.orig Mon Nov 21 21:27:38 2005
-+++ TrustedQSL-1.11/left.xpm Mon Nov 21 21:33:47 2005
-@@ -1,5 +1,5 @@
- /* XPM */
--static char *left[]={
-+static char *left_i[]={
- "10 10 29 1",
- ". c None",
- "d c #000000",
diff --git a/comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp b/comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp
deleted file mode 100644
index 4e597f366c7f..000000000000
--- a/comms/trustedqsl/files/patch-TrustedQSL-1.11_qsodatadialog.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- TrustedQSL-1.11/qsodatadialog.cpp.orig Mon Nov 21 21:27:29 2005
-+++ TrustedQSL-1.11/qsodatadialog.cpp Mon Nov 21 21:34:00 2005
-@@ -302,13 +302,13 @@
- sizer = new wxBoxSizer(wxHORIZONTAL);
- _recbottom_ctrl = new wxBitmapButton(this, QD_RECBOTTOM, wxBitmap(bottom), wxDefaultPosition, wxSize(18, TEXT_HEIGHT)),
- sizer->Add(_recbottom_ctrl, 0, wxTOP|wxBOTTOM, 5);
-- _recdown_ctrl = new wxBitmapButton(this, QD_RECDOWN, wxBitmap(left), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
-+ _recdown_ctrl = new wxBitmapButton(this, QD_RECDOWN, wxBitmap(left_i), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
- sizer->Add(_recdown_ctrl, 0, wxTOP|wxBOTTOM, 5);
- _recno_ctrl = new wxTextCtrl(this, QD_RECNO, wxT("1"), wxDefaultPosition,
- wxSize(4*TEXT_WIDTH,TEXT_HEIGHT));
- _recno_ctrl->Enable(FALSE);
- sizer->Add(_recno_ctrl, 0, wxALL, 5);
-- _recup_ctrl = new wxBitmapButton(this, QD_RECUP, wxBitmap(right), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
-+ _recup_ctrl = new wxBitmapButton(this, QD_RECUP, wxBitmap(right_i), wxDefaultPosition, wxSize(18, TEXT_HEIGHT));
- sizer->Add(_recup_ctrl, 0, wxTOP|wxBOTTOM, 5);
- _rectop_ctrl = new wxBitmapButton(this, QD_RECTOP, wxBitmap(top), wxDefaultPosition, wxSize(18, TEXT_HEIGHT)),
- sizer->Add(_rectop_ctrl, 0, wxTOP|wxBOTTOM, 5);
diff --git a/comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm b/comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm
deleted file mode 100644
index 56b2d8d0101e..000000000000
--- a/comms/trustedqsl/files/patch-TrustedQSL-1.11_right.xpm
+++ /dev/null
@@ -1,9 +0,0 @@
---- TrustedQSL-1.11/right.xpm.orig Mon Nov 21 21:27:56 2005
-+++ TrustedQSL-1.11/right.xpm Mon Nov 21 21:33:41 2005
-@@ -1,5 +1,5 @@
- /* XPM */
--static char *right[]={
-+static char *right_i[]={
- "10 10 30 1",
- "a c None",
- "g c #000000",
diff --git a/comms/trustedqsl/files/patch-configure b/comms/trustedqsl/files/patch-configure
new file mode 100644
index 000000000000..7a72f636f5aa
--- /dev/null
+++ b/comms/trustedqsl/files/patch-configure
@@ -0,0 +1,24 @@
+--- configure.orig 2012-08-11 14:24:17.000000000 -0500
++++ configure 2012-08-11 14:28:58.000000000 -0500
+@@ -4601,7 +4601,7 @@
+
+ checkwxdir(){
+ if test -z "$WXDIR"; then
+- if test -e "$1/bin/wx-config"; then
++ if test -e "%%WX_CONFIG%%"; then
+ WXDIR="$1"
+ fi
+ fi
+@@ -4813,10 +4813,10 @@
+ fi
+
+
+-wxwin_libs=`$WXDIR/bin/wx-config --libs`
++wxwin_libs=`%%WX_CONFIG%% --libs`
+ # Check whether --enable-wxwin-static was given.
+ if test "${enable_wxwin_static+set}" = set; then
+- enableval=$enable_wxwin_static; if test "$enableval" = "yes"; then wxwin_libs=`$WXDIR/bin/wx-config --static --libs`; fi
++ enableval=$enable_wxwin_static; if test "$enableval" = "yes"; then wxwin_libs=`%%WX_CONFIG%% --static --libs`; fi
+ fi
+
+
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in b/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in
deleted file mode 100644
index cb99bde9bb20..000000000000
--- a/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- tqsllib-2.0/Makefile.in.orig Fri Mar 11 07:58:31 2005
-+++ tqsllib-2.0/Makefile.in Tue Apr 18 15:53:02 2006
-@@ -767,8 +767,7 @@
-
- info-am:
-
--install-data-am: install-dataDATA install-docDATA \
-- install-includeHEADERS
-+install-data-am: install-includeHEADERS
-
- install-exec-am: install-binPROGRAMS install-exec-local \
- install-libLIBRARIES install-libLTLIBRARIES
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_configure b/comms/trustedqsl/files/patch-tqsllib-2.0_configure
deleted file mode 100644
index e85383ddf3e1..000000000000
--- a/comms/trustedqsl/files/patch-tqsllib-2.0_configure
+++ /dev/null
@@ -1,42 +0,0 @@
---- tqsllib-2.0/configure.orig Fri Mar 11 07:50:44 2005
-+++ tqsllib-2.0/configure Tue Feb 27 22:27:07 2007
-@@ -7793,8 +7793,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-- version_type=freebsd-$objformat
-+ version_type=freebsd-elf
- case $version_type in
- freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
-@@ -11512,8 +11511,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-- version_type=freebsd-$objformat
-+ version_type=freebsd-elf
- case $version_type in
- freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
-@@ -14682,8 +14680,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-- version_type=freebsd-$objformat
-+ version_type=freebsd-elf
- case $version_type in
- freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
-@@ -17050,8 +17047,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-- version_type=freebsd-$objformat
-+ version_type=freebsd-elf
- case $version_type in
- freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp b/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp
deleted file mode 100644
index b703c45c52f5..000000000000
--- a/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- tqsllib-2.0/openssl_cert.cpp.orig Fri Mar 11 07:47:11 2005
-+++ tqsllib-2.0/openssl_cert.cpp Wed Mar 29 11:27:41 2006
-@@ -1290,6 +1290,8 @@
- attrib->set = 1;
- #elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00907000
- attrib->single = 0;
-+#elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00908000
-+ attrib->single = 0;
- #else
- #error "Unexpected OpenSSL version; check X509_ATTRIBUTE struct compatibility"
- #endif
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp b/comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp
deleted file mode 100644
index c07b0b4d029a..000000000000
--- a/comms/trustedqsl/files/patch-tqsllib-2.0_tqslconvert.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- tqsllib-2.0/tqslconvert.cpp.orig 2007-12-18 08:39:49.000000000 -0500
-+++ tqsllib-2.0/tqslconvert.cpp 2007-12-18 08:42:31.000000000 -0500
-@@ -23,6 +23,7 @@
- #include <string>
- #include <ctype.h>
- #include <set>
-+#include <locale.h>
-
- //#include <iostream>
-
-@@ -264,6 +265,7 @@
-
- static const char *
- tqsl_infer_band(const char* infreq) {
-+ setlocale(LC_NUMERIC, "C");
- double freq = atof(infreq);
- double freq_khz = freq * 1000.0;
- int nband = 0;
diff --git a/comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.11 b/comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.11
deleted file mode 100644
index cddeb15f995d..000000000000
--- a/comms/trustedqsl/files/sysconfig.h.TrustedQSL-1.11
+++ /dev/null
@@ -1,80 +0,0 @@
-/* sysconfig.h. Generated by configure. */
-/* sysconfig.h.in. Generated from configure.in by autoheader. */
-
-/* Define to 1 if you have the <inttypes.h> header file. */
-#define HAVE_INTTYPES_H 1
-
-/* Define to 1 if you have the `crypto' library (-lcrypto). */
-#define HAVE_LIBCRYPTO 1
-
-/* Define to 1 if you have the `expat' library (-lexpat). */
-#define HAVE_LIBEXPAT 1
-
-/* Define to 1 if you have the `tqsllib' library (-ltqsllib). */
-#define HAVE_LIBTQSLLIB 1
-
-/* Define to 1 if you have the `tqsllibd' library (-ltqsllibd). */
-/* #undef HAVE_LIBTQSLLIBD */
-
-/* Define to 1 if you have the `z' library (-lz). */
-#define HAVE_LIBZ 1
-
-/* Define to 1 if you have the <memory.h> header file. */
-#define HAVE_MEMORY_H 1
-
-/* Define to 1 if you have the `mkdir' function. */
-#define HAVE_MKDIR 1
-
-/* Define to 1 if you have the <stdint.h> header file. */
-#define HAVE_STDINT_H 1
-
-/* Define to 1 if you have the <stdlib.h> header file. */
-#define HAVE_STDLIB_H 1
-
-/* Define to 1 if you have the `strerror' function. */
-#define HAVE_STRERROR 1
-
-/* Define to 1 if you have the <strings.h> header file. */
-#define HAVE_STRINGS_H 1
-
-/* Define to 1 if you have the <string.h> header file. */
-#define HAVE_STRING_H 1
-
-/* Define to 1 if you have the <sys/stat.h> header file. */
-#define HAVE_SYS_STAT_H 1
-
-/* Define to 1 if you have the <sys/types.h> header file. */
-#define HAVE_SYS_TYPES_H 1
-
-/* Define to 1 if you have the <unistd.h> header file. */
-#define HAVE_UNISTD_H 1
-
-/* Name of package */
-#define PACKAGE "TrustedQSL"
-
-/* Define to the address where bug reports for this package should be sent. */
-#define PACKAGE_BUGREPORT "lotw-help@arrl.org"
-
-/* Define to the full name of this package. */
-#define PACKAGE_NAME "TrustedQSL"
-
-/* Define to the full name and version of this package. */
-#define PACKAGE_STRING "TrustedQSL 1.11"
-
-/* Define to the one symbol short name of this package. */
-#define PACKAGE_TARNAME "TrustedQSL"
-
-/* Define to the version of this package. */
-#define PACKAGE_VERSION "1.11"
-
-/* Define to 1 if you have the ANSI C header files. */
-#define STDC_HEADERS 1
-
-/* Version number of package */
-#define VERSION "1.11"
-
-/* Define to empty if `const' does not conform to ANSI C. */
-/* #undef const */
-
-/* Define to `unsigned' if <sys/types.h> does not define. */
-/* #undef size_t */